静的ルーティング(スタティックルート) ~設定編①~

ベル

今回の授業は、前回に引き続き『静的ルーティング(スタティックルート)の基礎』です。今回は少し実践よりに授業していきます。前回でもでてきた、フローティングスタティックルートも出てきますので、ゆっくりコマンドを入れながら勉強していきましょうね!

 

前回の授業を受けれていない方は、こちらからお願いしますねー!

静的ルーティング(スタティックルート) ~基礎編①~

 

試験構成図

今回の授業で使用する構成は以下になります。

 

【物理構成図】

 

【論理構成図】

 

 

通信要件

今回の通信要件としては、ルータ#1の『10.100.10.0/24』からルータ#2の『10.100.20.0/24』を通すこととします。通信経路としては、ルータ#1⇒ルータ#2が優先経路で、ルータ#1~ルータ#2間のケーブルが断線した際には、ルータ#3経由に切り替わるように設定していきたいと思います。

 

インターフェイスの設定

まずは、構成図通りのアドレス設定しましょう。以下のパラメータ通りになっていることを確認しながらせっていを投入していきましょうね!

【RT1】

 

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.100.10.1 255.255.255.0

RT1(config-if)#exit

RT1(config)#interface FastEthernet0

RT1(config-if)#ip address 10.10.10.1 255.255.255.0

RT1(config-if)#no shutdown

RT1(config-if)#exit

RT1(config)#interface FastEthernet1

RT1(config-if)#ip address 10.10.20.1 255.255.255.0

RT1(config-if)#no shutdown

 

 

【RT2】

 

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.100.20.1 255.255.255.0

RT2(config-if)#no shutdown

RT2(config)#exit

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.10.30.2 255.255.255.0

RT2(config-if)#no shutdown

RT2(config-if)#exit

RT2(config)#interface FastEthernet1

RT2(config-if)#ip address 10.10.10.2 255.255.255.0

RT2(config-if)#no shutdown

RT2(config-if)#exit

 

 

【RT3】

 

RT3(config-if)#interface FastEthernet0

RT3(config-if)#ip address 10.10.20.3 255.255.255.0

RT3(config-if)#no shutdown

RT3(config-if)#exit

RT3(config)#interface FastEthernet1

RT3(config-if)#ip address 10.10.30.3 255.255.255.0

RT3(config-if)#no shutdown

RT3(config-if)#exit

 

 

スタティックルートの設定

今回の通信要件に合うようにスタティックルートをそれぞれのルータに設定していこうと思います。

 

【RT1】

ip route 10.100.20.0 255.255.255.0 10.10.10.2

ip route 10.100.20.0 255.255.255.0 10.10.20.3 200

ここに出てくる『200』の値がAD(アドミニストレーティブディスタンス)値というものです。これは、ルータで使用するルーティングプロトコル毎に値が決まっており、小さい値ほど優先されるルールとなっています。今回はルータ#3経由のルートを、スタティックルートのAD値『1』よりも大きい値(非優先の値)である『200』を設定しておきます。

 

AD値のリストを一部抜粋して紹介させていただきます。

 

【AD値】

コネクトルート ・・・ 0

スタティックルート ・・・ 1

EIGRP(内部) ・・・ 90

OSPF ・・・ 110

RIP ・・・ 120

EIGRP(外部) ・・・ 170

 

 

このようにスタティックルートの本来のAD値は「1」となっておりますが、先程の設定で明示的にAD値を「200」に変更しています。これによりAD値「200」にしたルートは非優先とされ、優先ルートがなくなると浮かび上がってくるようになっています。このような設定をフローティングスタティックルートと呼びます。

 

【RT2】

ip route 10.100.10.0 255.255.255.0 10.10.10.1

ip route 10.100.10.0 255.255.255.0 10.10.30.3 200

 

【RT3】

ip route 10.100.10.0 255.255.255.0 10.10.20.1

ip route 10.100.20.0 255.255.255.0 10.10.30.2

 

 

ルーティングテーブルの確認

設定が完了したら、ルーティングテーブルの確認をしましょう!先ほどの設定が反映されていることが確認できるでしょうか?

 

【RT1】

  10.0.0.0/24 is subnetted, 4 subnets
 C 10.10.10.0 is directly connected, FastEthernet0
 C 10.10.20.0 is directly connected, FastEthernet1
 C 10.100.10.0 is directly connected, Loopback0
 S 10.100.20.0 [1/0] via 10.10.10.2

 

【RT2】

  10.0.0.0/24 is subnetted, 4 subnets
 C 10.10.10.0 is directly connected, FastEthernet1
 C 10.10.30.0 is directly connected, FastEthernet0
 S 10.100.10.0 [1/0] via 10.10.10.1
 C 10.100.20.0 is directly connected, Loopback0

 

【RT3】

  10.0.0.0/24 is subnetted, 4 subnets
 C 10.10.20.0 is directly connected, FastEthernet0
 C 10.10.30.0 is directly connected, FastEthernet1
 S 10.100.10.0 [1/0] via 10.10.20.1
 S 10.100.20.0 [1/0] via 10.10.30.2

 

正常性の疎通確認

それでは、ルータ#1のLoopback0(10.100.10.0/24)をソースに『10.100.20.1』に疎通確認を実行してみましょう。以下のようの結果が得られればOKです。

 

RT1#ping 10.100.20.1 source loopback 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.100.20.1, timeout is 2 seconds:
Packet sent with a source address of 10.100.10.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

障害試験

正常時の疎通確認だけでなく、ちゃんと迂回の確認もしましょう。Ciscoのpingはデフォルト5発で、あっという間に終わってしまうので、今回は1000発で実行し、実行中にルータ#1~ルータ#2間のケーブルを抜線してみたいと思います。ちゃんと迂回できたことを確認しておきましょうね!

 

RT1#ping 10.100.20.1 source loopback 0 repeat 1000

Type escape sequence to abort.
Sending 1000, 100-byte ICMP Echos to 10.100.20.1, timeout is 2 seconds:
Packet sent with a source address of 10.100.10.1
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!……!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!
Success rate is 99 percent (994/1000), round-trip min/avg/max = 1/1/8 ms
RT1#

6発断が発生したもののちゃんと迂回できたことがわかりますね!ネットワークの機器は故障したりするものです。ちゃんと迂回時間も考えて障害試験を実施しておくことが重要となります。

 

まとめ

ベル

今回の授業はいかがだったでしょうか?同じスタティックルートでも優先、非優先を付けることが出来るのです。フローティングスタティックルートの設定は他のルーティングプロトコル(EIGRPやOSPF等)でも設定できます。今後の動的ルーティングでも出てきますので、ちゃんと理解しておきましょうね!

 

その他のルーティング

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

OSPFの概要 ~基礎編①~

OSPFの設定 ~シングルエリア編①~

BGPの概要 ~基礎編①~

Follow me!

静的ルーティング(スタティックルート) ~設定編①~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です