HSRP(Hot Standby Router Protocol) ~設定編②~

ベル

今回の授業は、『HSRPの設定 ~Track設定との組み合わせ~』です。基礎編②でTrackを紹介させていただきましたが、組み合わせることで、より高度な設計が出来るようになります。

 

お勉強構成

今回、使用する構成は以下の構成となります。

【物理構成】

 

【論理構成】

 

前回の授業を受けていただけていたら、以下の設定が入っていると思います。受けられていない方はこちらから。

 

HSRP(Hot Standby Router Protocol) ~設定編①~

 

 

【RT1】

!
interface FastEthernet2

switchport access vlan 10

!

interface Vlan10

ip address 10.0.0.252 255.255.255.0

standby 10 ip 10.0.0.254

standby 10 priority 110

standby 10 preempt

!

 

【RT2】

!

interface FastEthernet2

switchport access vlan 10

!

interface Vlan10

ip address 10.0.0.253 255.255.255.0

standby 10 ip 10.0.0.254

standby 10 preempt
!

 

※インターフェイスの番号は、お使いになっている機器に置き換えて設定してもらえればと思います。

 

障害試験

 

追加の設定

今回の授業で、追加する設定は以下になります。

 

WAN側インターフェイスの設定

以前の授業から追加すべき設定をルータ#1とルータ#2に入れていきましょう。まずは、WAN側のインターフェイスにアドレスを設定します。ルータ#1に『10.11.1.1/24』を、ルータ#2に『10.11.2.1/24』を設定していきます。ちなみにルータのスイッチポートはデフォルトで開放されていますが、ルーテッドポートはデフォルトで閉塞されています。そのため、忘れずに『no shutdown』を入れるようにしましょうね!

 

【RT1】

RT1(config)#interface fastEthernet 0

RT1(config-if)#ip address 10.11.1.1 255.255.255.0

RT1(config-if)#no shutdown

 

【RT2】

RT2(config)#interface fastEthernet 0

RT2(config-if)#ip address 10.11.2.1 255.255.255.0

RT2(config-if)#no shutdown

 

スタティックルートの追加

ルータ#1、ルータ#2からルータ#11に向けてデフォルトルートを設定します。この設定がないと自分のインターフェイスに設定されているセグメント以外と通信することが出来ません。ダイナミックルーティングでも出来ますが、今回は簡単なスタティックルートで設定しておきます。

 

【RT1】

!

RT1(config)#ip route 0.0.0.0 0.0.0.0 10.11.1.254

!

 

【RT2】

!

RT2(config)#ip route 0.0.0.0 0.0.0.0 10.11.2.254

!

 

これにより、ルータ#1、ルータ#2からルータ#11が所有するルートへも抜けていくことが出来るようになりました。次は、ルータ#11に設定をしてパケットを戻せるようにしていきます。

 

ルータ#11の基礎設定

さて、新しくルータ#11が出てきたので、こちらの設定をしていきましょう!

 

物理インターフェイスの設定追加

まずは、インターフェイスの設定ですね。今回は、通信先である『10.11.11.1/32』をLoopback0インターフェイスに設定したいと思います。Loopbackインターフェイスとは、ネットワーク機器が永続的に保持することが出来るインターフェイスで、管理用として設定したりします。今回は、このLoopbackインターフェイスを疎通先に設定します。

 

 

ルータ#1、ルータ#2と接続するインターフェイスは、それぞれFastEthernet0、1を使用したいと思います。このインターフェイスは、ルーテッドポートであるため直接IPアドレスの設定が可能となります。設定値はFastEthernet0に『10.11.1.254/24』、FastEthernet1に『10.11.2.254/24』を設定し、それぞれをルータ#1、ルータ#2と接続します。設定例は以下の通りです。

 

RT11(config)#interface loopback 0

RT11(config-if)#ip address 10.11.11.1 255.255.255.255

!

RT11(config)#interface FastEthernet0

RT11(config-if)#ip address 10.11.1.254 255.255.255.0

RT11(config-if)#no shutdown

!

RT11(config)#interface fastEthernet 1

RT11(config-if)#ip address 10.11.2.254 255.255.255.0

RT11(config-if)#no shutdown

 

スタティックルートの設定

今回の構成では、ルータ#1を優先経路、ルータ#2を非優先経路として選定するように、AD値という値を設定します。ルータ#2を経由する経路にAD値『200』を設定しておきます。

(スタティックルートの設定については、別の機会で解説させていただきます。)

 

RT11(config)#ip route 0.0.0.0 0.0.0.0 10.11.1.1

RT11(config)#ip route 0.0.0.0 0.0.0.0 10.11.2.1 200

 

迂回試験

それでは、早速、障害試験を実施してみましょう。

迂回の失敗

この設定だけで試験をしてみると以下のような結果になります。

 

障害が発生してしまうとPingが途絶えてしまって、迂回できていないことがわかりますね。原因は何のかshowコマンドで確認していきましょう。HSRPのステータスを確認するコマンドは『show standby brief』だったのを覚えていますか?今回もこのコマンドで見ていきましょう。

 

RT1#show standby brief

P indicates configured to preempt.

!

Interface Grp Pri P State Active Standby Virtual IP

Vl10 10 110 P Active local 10.0.0.253 10.0.0.254

 

RT2#show standby brief

P indicates configured to preempt.

!

Interface Grp Pri P State Active Standby Virtual IP

Vl10 10 100 P Standby 10.0.0.252 local 10.0.0.254

 

この結果から、ルータ#1がActiveルータ#2がStandbyになっていることがわかりますか?これでは、ルータ#1~ルータ#11間で障害が発生しているのに、Pingのパケットがルータ#1に吸い込まれてしまう結果になってしまいます。これでが通信が出来ません。理想的な結果としては、ルータ#2がActiveなっていることなので、設定を修正していきましょう。

 

設定の修正

それでは、ルータ#1~ルータ#11間で障害が発生した際に、ルータ#2がActiveルータになれるように『Track』設定を追加していこうと思います。

 

【RT1】

RT1(config)#track 1 interface fastEthernet 0 line-protocol

RT1(config)#interface vlan 10

RT1(config-if)#standby 10 track 1 decrement 20

 

『track 1 interface fastEthernet 0 line-protocol』でFastEthernet0のステータス監視が始まります。このステータスの変化により様々な変更を加えることが出来ます。今回はHSRPのPriority値を『20』下げるように設定します。それが『standby 10 track 1 decrement 20』になります。

 

元々がルータ#1のPriority値が『110』で、ルータ#2が『100』であったため、ルータ#1のPriority値から『20』引くことでルータ#2をActiveルータに昇格させることが可能となるのです。

 

迂回の再試験

それでは、修正が完了したので再度試験を実施してみましょう。

 

 

ちゃんと10秒程度で迂回できていることがわかりますね!

 

【RT1】

RT1#show standby brief

P indicates configured to preempt.

!

Interface Grp Pri P State Active Standby Virtual IP

Vl10 10 90 P Standby 10.0.0.253 local 10.0.0.254

 

ルータ#1のPriority値が『90』に下がって、『Standby』にステータスが変化していることがわかるでしょうか。これにより、ルータ#2がActiveに昇格されているのです。

 

【RT2】

RT2#show standby brief

P indicates configured to preempt.

!

Interface Grp Pri P State Active Standby Virtual IP

Vl10 10 100 P Active local 10.0.0.252 10.0.0.254

 

まとめ

ベル

いかがだったでしょうか?今回の授業でHSRPにTrack設定を組み合わせて、上位回線の障害を検知しPriority値を下げることが出来ました。これ以外にもルーティングテーブルの状態などを監視して、Priority値を下げるなどの設定もありますので、いろいろ試してみてください。

 

Follow me!

HSRP(Hot Standby Router Protocol) ~設定編②~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です