HSRP(Hot Standby Router Protocol) ~設定編①~

ベル

今回の授業は、『HSRPの設定』を学びましょう!ここまで学んできたことを実際のCisco機器に設定する場合のコマンドと確認方法について教えていきますので、自宅ラボがある方は同じように設定してもらえればと思います。

 

HSRPの基礎編を学んでいない方は、こちらから勉強してください。

 

HSRP(Hot Standby Router Protocol) ~基礎編①~

 

お勉強構成

今回、使用する構成は以下の構成となります。

【物理構成】

【論理構成】

 

今回は、初めてHSRPのコマンドを勉強していくので、まずはシンプルな構成をベースに勉強していこうと思います。使用するセグメントは、『10.0.0.0/24』だけでデフォルトゲートウェイの『10.0.0.254』の切り替わりについて確認していきましょう。

 

 

設計値

それでは今回の設計値について紹介しておきます。今回は、以下のような設計値にしてみようと思います。

それでは、設計値であるパラメータについて解説と設定コマンドを教えていこうと思います。

 

設定コマンド

それでは実際に設定していきますので、機器が手元にある人は、コンソール接続しておいてくださいね!

実IPアドレス

実IPアドレスと言うとわかりづらいかもしれませんが、単純なるIPアドレスのことです。今回はルータ#1で『10.0.0.252/24』とルータ#2で『10.0.0.253/24』を使用したいと思います。実際に使用するコマンドが以下になります。

 

【ルータ#1】

RT1(config)#interface vlan 10

RT1(config-if)#ip address 10.0.0.252 255.255.255.0

 

【ルータ#2】

RT2(config)#interface vlan 10

RT2(config-if)#ip address 10.0.0.253 255.255.255.0

 

Standby ID(スタンバイID)

スタンバイIDとは、HSRPの構成を組んだ時にセグメント内で管理する番号みたいなものです。そのスタンバイID単位でPriority値や仮想IPアドレス(VIP)を設定することが出来ます。使用できる数値はHSRPのversionによって異なります。version 1であれば『0~255』の範囲で、version 2であれば『0~4095』の範囲で指定することが出来ます。ちなみにデフォルトではversion 1となっています。今回はデフォルトのまま使用しようと思います。

 

【ルータ#1】

RT1(config)#interface vlan 10

RT1(config-if)#standby 10 ip 10.0.0.254

 

【ルータ#2】

RT2(config)#interface vlan 10

RT2(config-if)#standby 10 ip 10.0.0.254

 

Priority値

Priority値とは、HSRPを組んでいるルータ間でActiveルータを選定する際に使用する数値となります。この数値が大きいほど優先されます。デフォルトのPriority値は100になっています。そのため今回は、ルータ#1だけをPriority値を110にへんこうしていこうと思います。

 

【ルータ#1】

RT1(config)#interface vlan 10

RT1(config-if)#standby 10 priority 110

 

Preempt設定

Preempt設定を追加することで、Activeルータが故障から復旧した際にStandbyルータから自動的にActiveに昇格することが出来ます。今回は、Preempt設定を有効にしておこうと思います。

 

【ルータ#1】

RT1(config)#interface vlan 10

RT1(config-if)#standby 10 preempt

 

【ルータ#2】

RT2(config)#interface vlan 10

RT2(config-if)#standby 10 preempt

 

インターフェイスへのVLANアサイン

それでは最後にスイッチポートへVLANをアサインしていきましょう。今回はCisco1812Jを使用するためFa2を使用しますが、使用する環境に応じてインターフェイスの設定を変えてもらえればと思います。

 

【ルータ#1】

RT1(config)#interface fastEthernet 2

RT1(config-if)#switchport mode access

RT1(config-if)#switchport access vlan 10

 

 

【ルータ#2】

RT2(config)#interface fastEthernet 2

RT2(config-if)#switchport mode access

RT2(config-if)#switchport access vlan 10

 

これで構成図通りに配線すれば、完了となります。

 

確認コマンド

設定が完了したらステータス確認になります。

 

【ルータ#1】

RT1#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Vl10 10 110 P Active local 10.0.0.253 10.0.0.254

 

【ルータ#2】

RT2#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Vl10 10 100 Standby 10.0.0.252 local 10.0.0.254

 

ルータ#1のステータスがActiveルータ#2のステータスがStandbyになっていれば問題なしですが、それ以外のパラメータについてもちゃんと確認しておきましょうね!

 

疎通確認

それでは、ExPingを使って疎通確認を実施してみたいと思います。それではパソコンでExPingを立ち上げて『10.0.0.254』に疎通確認を実行してください。パラメータは以下の内容にしてみましょう。

 

 

パラメータでPingを実行した状態で障害を起こして迂回することを確認しましょう!障害箇所は以下の場所となります。

 

以下のような結果になっていれば迂回できてることになります。

 

障害時のステータス確認

それでは障害が発生した時のステータスをルータ#2で確認してみましょう。

RT2#show standby brief
P indicates configured to preempt.
|
Interface Grp Pri P State Active Standby Virtual IP
Vl10 10 100 Active local unknown 10.0.0.254

ルータ#2がActiveステータスに変更されていることがわかりますね。またStandbyルータがunknownになっているのは、ルータ#1とのHelloパケットが途絶えたためとなります。このようなステータスになっていれば問題なく迂回できたと言えます。

 

まとめ

ベル

いかがだったでしょうか?HSRPの設定について教えてきましたが、わかってもらえましたか?少しでも手を動かしてみることが、エンジニアには大切なことです。是非、実際に試してみてください。

 

次回の授業は、ちょっと高度な切替りについて授業しますので、マスター出来た方はこちらへ。

HSRP(Hot Standby Router Protocol) ~設定編②~

 

ルーティングの授業

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

OSPFの概要 ~基礎編①~

OSPFの概要 ~設定編①~

Follow me!

HSRP(Hot Standby Router Protocol) ~設定編①~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です