EIGRPの設定 ~ルートマップによる経路制御編~

ベル

今回の授業は、「ルートマップによるEIGRPの経路制御」について教えていこうと思います。EIGRPの基本的な設定は前回までの授業で教えていますので、忘れてしまった方は、こちらでしっかりと復習しておきましょう。

 

EIGRPの授業

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~基礎編②~

EIGRPの概要 ~基礎編③~

EIGRPの概要 ~基礎編④~

EIGRPの設定 ~基礎編~

EIGRPの設定 ~ルート制御編~

EIGRPの設定 ~メトリック制御編~

 

 

お勉強構成

今回のお勉強構成は、以下の通りとなります。自宅ラボをお持ちの方は自分でお持ちの機器構成に合わせ描いてみましょうね!

 

 

このスイッチ4のLoopback0(10.10.1.0/24)のアドレスはルータ1を優先して、Loopback1(10.10.2.0/24)のアドレスはルータ2を優先に通るように制御してみたいと思います。以前までのメトリック調整ですと、Loopback0(10.10.1.0/24)とLoopback1(10.10.2.0/24)のアドレス両方がルータ1を経由するようになってしまいます。そうならないように、メトリック調整してみたいと思います。前回の授業を忘れてしまった方は、こちらでしっかりと復習しておきましょうね。

 

ここで、今回使用している機器を紹介しておきます。これじゃなければいけないというわけではないですが、コストパフォーマンスが高い機器だと思いますので、参考にしてもらえればと思います。

CISCO 1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2019/5/15 18:58時点)

Catalyst 3560-8PC-S

CISCO Catalyst 3560-8PC-S マルチレイヤ イーサネット PoE対応 スイッチ WS-C3560-8PC-S

中古価格
¥10,480から
(2019/5/15 19:01時点)

CISCO コンソールケーブル

【CISCO互換ケーブル】FTDI chipset USB RJ45 コンソールケーブル

新品価格
¥850から
(2019/5/15 19:02時点)

 

 

事前設定

それでは事前設定をしていきたいと思います。

 

インターフェイス設定

それでは、インターフェイス設定から実施していきます。今までに何度か授業を受けられている方は、難しくないと思います。どんどん設定していきましょう。

 

【RT1】

RT1(config)#interface FastEthernet0/0

RT1(config-if)#ip address 10.1.1.1 255.255.255.0

RT1(config-if)#!

RT1(config-if)#interface FastEthernet0/1

RT1(config-if)#ip address 10.1.3.1 255.255.255.0

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip address 10.1.2.1 255.255.255.0

RT2(config-if)#!

RT2(config-if)#interface FastEthernet1

RT2(config-if)#ip address 10.1.4.1 255.255.255.0

 

【RT3】

RT3(config)#interface FastEthernet0

RT3(config-if)#ip address 10.1.3.254 255.255.255.0

RT3(config-if)#!

RT3(config-if)#interface FastEthernet1

RT3(config-if)#ip address 10.1.4.254 255.255.255.0

RT3(config-if)#!

RT3(config-if)#interface Vlan10

RT3(config-if)#ip address 10.10.11.254 255.255.255.0

RT3(config-if)#!

RT3(config-if)#interface Vlan20

RT3(config-if)#ip address 10.10.12.254 255.255.255.0

 

【SW4】

SW4(config)#interface Loopback0

SW4(config-if)#ip address 10.10.1.1 255.255.255.0

SW4(config-if)#!

SW4(config)#interface Loopback1

SW4(config-if)#ip address 10.10.2.1 255.255.255.0

SW4(config-if)#!

SW4(config-if)#interface FastEthernet0/1

SW4(config-if)#no switchport

SW4(config-if)#ip address 10.1.1.254 255.255.255.0

SW4(config-if)#!

SW4(config-if)#interface FastEthernet0/2

SW4(config-if)#no switchport

SW4(config-if)#ip address 10.1.2.254 255.255.255.0

 

今回はL3スイッチも使用します。設定内容がルータと比べて少し異なります。あまりL3スイッチを設定したことがない方は、以前の授業で復習しておきましょうね!

 

CiscoのL3スイッチを使ってみよう!

CiscoのL3スイッチを使ってみよう!

 

EIGRPの基本設定

それではEIGRPの基本的な設定をしていきたいと思います。ここでは、EIGRPのネットワーク設定までとなります。ネットワーク設定は、ざっくりと『10.0.0.0/8』で設定しておきます。また、本来ネイバーを構築する必要がないインターフェイスには『passive』設定をしておくのが一般的ですが、今回は割愛しておきます。それでは、実際に設定していきます。

 

【RT1】

RT1(config)#router eigrp 10

RT1(config-router)#no auto-summary

RT1(config-router)#network 10.0.0.0

 

ルータ2、ルータ3、スイッチ4でも同じ設定となりますので、設定内容は割愛します。これにより構成図の通りのインターフェイス設定と、EIGRPの基本的な設定は完了となります。ここまでは前回の授業を受けていれば、わかってもらえると思います。間違ってしまった方は復習しておきましょうね。

 

EIGRPのメトリック設定

それでは本題となるEIGRPのメトリック設定をしていきたいと思います。現時点では、メトリック制御もしていませんのでルータ3では、スイッチ4のLoopback0(10.10.1.0/24)およびLoopback1(10.10.2.0/24)が等コストで以下のようにネクストホップ見えていると思います。

 

【RT3】

RT3#show ip route

D 10.10.1.0/24 [90/158720] via 10.1.4.1, 00:02:20, FastEthernet1
                       [90/158720] via 10.1.3.1, 00:02:20, FastEthernet0
D 10.10.2.0/24 [90/158720] via 10.1.4.1, 00:02:20, FastEthernet1
                       [90/158720] via 10.1.3.1, 00:02:20, FastEthernet0

 

これはルータ1とルータ2の2つの経路が見えていることとなります。これに対してインターフェイスに『delay』『Bandwidth』設定をすることで経路制御できることは以前の授業でやりましたね。しかし最初にも書いた通りこの設定をしてしまうと、スイッチ4のLoopback0(10.10.1.0/24)とLoopback1(10.10.2.0/24)の両方が片寄せしてしまいます。今回は、そうではなくLoopback0(10.10.1.0/24)はルータ1経由でLoopback1(10.10.2.0/24)はルータ2経由になるようにしたいと思います。

 

 

ルーティング制御するポイントはいくつかあるのですが、今回は、シンプルにルータ3で設定してみたいと思います。

 

アクセスリストの設定

今回は、アクセスリスト1でスイッチ4のLoopback0(10.10.1.0/24)を、アクセスリスト2でLoopback1(10.10.2.0/24)を定義しておきたいと思います。こちらもシンプルに標準アクセスリストで設定していきます。

 

【RT3】

RT3(config)#access-list 1 permit 10.10.1.0 0.0.0.255
RT3(config)#access-list 2 permit 10.10.2.0 0.0.0.255

 

アクセスリストの設定を忘れてしまった方は、以前の授業で振り返っておきましょうね。

 

ルートマップの設定

続ていルートマップを作成してみたいと思います。PBRでも扱いましたが、今回は先程作成したアクセスリストにメトリックをマッチさせるために使用します。

 

【RT3】

RT3(config)#route-map SW4-Lo0 permit 10
RT3(config-route-map)#match ip address 1
RT3(config-route-map)#set metric 100000 1000 255 1 1500
RT3(config-route-map)#!
RT3(config-route-map)#route-map SW4-Lo0 permit 20
RT3(config-route-map)#!
RT3(config-route-map)#route-map SW4-Lo1 permit 10
RT3(config-route-map)#match ip address 2
RT3(config-route-map)#set metric 100000 1000 255 1 1500
RT3(config-route-map)#!
RT3(config-route-map)#route-map SW4-Lo1 permit 20

 

これによりルートマップ『SW4-Lo0』でACL1(10.10.1.0/24)にメトリックルートマップ『SW4-Lo1』でACL2(10.10.2.0/24)にメトリックを追加することが出来ます。同じメトリック値を設定していますが、それぞれ適用するインターフェイスを変更することで、別のインターフェイスに片寄せすることが出来ます。

 

また、『permit 20』の空打ちが入っていますが、この定義がないと指定したアクセスリスト以外のルートが配布されなくしまいます。アクセスリストで定義したルート以外はデフォルトのメトリックで配布するため、この定義を入れておきます。

 

 

メトリックの適用

それでは、実際にメトリックを追加していきたいと思います。今回、メトリック設定したルートマップを非優先となるインターフェイスに関連付ける必要があります。紛らわしいですが、間違えないようにしましょうね。わからなくなってしまいそうでしたら、一旦、以下のように書き出してみるといいと思います。

 

【頭の整理】

『10.10.1.0/24』のルートは、ルートマップ『SW4-Lo0』でFastEthernet1を非優先する。

『10.10.2.0/24』のルートは、ルートマップ『SW4-Lo1』でFastEthernet0を非優先する。

 

それでは、設定していきましょう!

 

【RT3】

RT3(config)#router eigrp 10
RT3(config-router)#distribute-list route-map SW4-Lo0 in fastEthernet 1
RT3(config-router)#distribute-list route-map SW4-Lo1 in fastEthernet 0

 

これでEIGRPのメトリック設定は完了となります。実際にどのようにルーティングテーブルが見えているかを確認してみましょう。

 

ステータス確認

それでは、スタータス確認をしていきたいと思います。今回は、授業も長くなってしまったので確認を最小限にさせてもらいます。特にポイントとなるのが、ルータ3のルーティングテーブルとなりますので、そこだけ確認させてもらいます。メトリック設定をする前とした後でどのようになったのかを確認しておきましょう。メトリック設定を追加する前は、以下の通りでした。(途中で載せたのを再掲します。)

 

【RT3】

RT3#show ip route

D 10.10.1.0/24 [90/158720] via 10.1.4.1, 00:02:20, FastEthernet1
                       [90/158720] via 10.1.3.1, 00:02:20, FastEthernet0
D 10.10.2.0/24 [90/158720] via 10.1.4.1, 00:02:20, FastEthernet1
                       [90/158720] via 10.1.3.1, 00:02:20, FastEthernet0

 

そこからメトリック設定を追加すると以下のようになるはずです。

【RT3】

RT3#show ip route

D 10.10.1.0/24 [90/158720] via 10.1.3.1, 00:00:06, FastEthernet0
D 10.10.2.0/24 [90/158720] via 10.1.4.1, 00:00:06, FastEthernet1

 

見てもわかるように最初は2つの経路が見えていましたが、メトリック追加することでそれぞれ優先させる経路が出来ています。このように明確に経路をバランシングしたい際には、ルートマップで条件付けしてメトリックを設定する必要があります。

 

まとめ

ベル

今回の授業は、ここまでとなります。ここまでルートの制御をする機会は、あまり多くないかもしれません。だからこそ、自宅ラボで実際に設定しておくと、実際に要件が出てきた際に焦らずに済みます。知ると知らないは大きな差がありますが、知っているだけとやったことあるは、もっと大きな差があると思います。ぜひ試してみてくださいね!

 

自宅ラボのススメ

自宅ラボのススメ

 

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です