PBR(Policy-Based Routing)の設定 〜基礎編〜

ベル

今回の授業は、「PBR(Policy-Based Routing)の基礎設定」を教えていきます。前回の授業まででPBRの基本的な概念は学んでもらったと思いますので、実際に設定してみて理解を深めていきましょう。前回までの授業を受けていない方は、以下から学んでおきましょう。

 

PBR(Policy-Based Routing)の授業

PBR(Policy-Based Routing)の概要 ~基礎編①~

PBR(Policy-Based Routing)の概要 ~基礎編②~

 

 

お勉強構成

今回は、PBRのコマンドを覚えてもらうためシンプルな構成とします。実際に構成を組んで設定してみましょう。

 

 

基本的なルーティングは、すべてスタティックルートで設定し、ルータ2でPBRを送信元がセグメントB(10.1.2.0/24)の場合は、ルータ1に転送するというポリシーを作成してみたいと思います。

 

Cisco 1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2019/10/5 23:10時点)

事前設定

それでは、PBRを学ぶ前に基本的な設定を入れていきます。

 

インターフェース設定

それではインターフェースの設定をしていきます。今回はルータ3台ですので、お勉強構成を見ながら設定していきましょう!

 

【RT1】

RT1(config)#interface loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.0

RT1(config-if)#interface fastEthernet 0/0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

【RT2】

RT2(config)#interface fastEthernet 0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

RT2(config-if)#interface fastEthernet 1

RT2(config-if)#ip address 10.10.2.1 255.255.255.0

 

【RT3】

RT3(config)#interface loopback0

RT3(config-if)#ip address 10.1.2.1 255.255.255.0

RT3(config-if)#interface fastEthernet 0

RT3(config-if)#ip address 10.10.2.2 255.255.255.0

 

これでインターフェイスの設定は完了となります。

 

ルーティング設定

続いてルーティング設定をしていきます。PBRと関係しないルーティングはすべてスタティックルートの設定をしてきます。設定方法がわからない方は、以前のスタティックルートの授業を参考にしてください。それでは設定していきます。

 

【RT1】

RT1(config)#ip route 10.1.2.0 255.255.255.0 10.10.1.2

 

【RT2】

RT2(config)#ip route 10.1.2.0 255.255.255.0 10.10.2.2

 

【RT3】

RT3(config)#ip route 10.1.1.0 255.255.255.0 10.10.2.1

 

これだけです。この設定によってルータ1からルータ3のLoopback0(10.1.2.0/24)向けのルーティングは、ルータ1、ルータ2のともに設定されたため到達性が確保されますが、ルータ3からルータ1のLoopback(10.1.1.0/24)向けのルーティングはルータ3には設定されますが、ルータ2に設定されていないため、到達することが出来ません。気になる方は、ルータ2のルーティングテーブルを確認してみてください。『10.1.1.0/24』の載っていないはずですよ。(後でも確認しますが。)

 

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~基礎編①~

 

 

PBR設定

それではPBRの設定をしていきましょう。PBRの基本的な設定は、3つの部品にわかれます。

 

 

アクセスリストでパケットの特定

それではアクセスリストの設定をしていきます。ここで送信元となるセグメントや対象となるプロトコルなどを定義することが出来ますが、今回はわかりやすく送信元だけを定義します。アクセスリストの書き方を忘れてしまった方は、以前のアクセスリストの授業で確認しておきましょう。

 

【RT2】

R2(config)# access-list 1 permit 10.1.2.0 0.0.0.255

 

これで10.1.2.0/24のセグメントが送信元となるパケットが対象となります。

 

ルートマップで処理の決定

次にルートマップを設定していきます。「10.1.2.0/24」を送信元とするパケットをPBRのマッチ条件にし、マッチしたパケットのネクストホップをルータ1のFastEthernet0(10.10.1.1)に指定したいと思います。

 

【RT2】

RT2(config)# route-map TEST_PBR permit 10

RT2(config-route-map)# match ip address 1

RT2(config-route-map)# set ip next-hop 10.10.1.1

 

上記の設定でACL(Access Control List)で定義した送信元(10.1.2.0/24)から送られてきたパケットを、10.10.1.1に転送するように紐付けをしました。

 

アクセスリストによる通信制御 ~基礎編~

アクセスリストによる通信制御 ~基礎編~

 

入力インターフェースの指定

続いて入力インターフェースの指定をします。これは、ルータに飛んできたパケットすべてをPBR対象とするのではなく、入ってくるインターフェースを決めて、そのインターフェースから入ってきたパケットのみPBRの対象とします。それでは具体的な設定を見てみましょう。

 

 

このようにインターフェイスコンフィグレーションモードに入って、『ip policy route-map』コマンドでPBRのトリガーとなるインターフェイスを指定していきます。では、今回の構成に合わせると、ルータ2のFastEthernet1から入ってくるパケットを対象とすると以下のようになります。

 

【RT2】

RT2(config)#interface FastEthernet1

RT2(config-if)#ip policy route-map TEST_PBR

 

これでPBRの設定は終了となります。実際にステータス、疎通の確認をしていきたいと思います。

 

正常性確認(ステータス確認)

それでは正常性確認をしていきます。今回も必要最低限のコマンドに絞って確認していきます。今回はルーティングテーブルと疎通確認だけになりますが、気になるステータスがあれば合わせて確認しておきましょうね。

 

ルーティングテーブルの確認

今回のルーティング確認は、以下のポイントで確認しておきたいと思います。

 

【ルータ1】

以下のルートがあること

10.1.1.0/24

10.1.2.0/24

 

【ルータ2】

以下のルートがあること

10.1.2.0/24

以下のルートがないこと

10.1.1.0/24

 

【RT3】

以下のルートがあること

10.1.1.0/24

10.1.2.0/24

 

ここでポイントとなるのが、先にも記載した通りルータ2に『10.1.1.0/24』がないことです。それではルータ2だけルーティングテーブルを確認してみます。皆さんは他のルータも確認しておきましょうね。

 

【RT2】

RT2#show ip route

Gateway of last resort is not set

S 10.1.2.0/24 [1/0] via 10.10.2.2
C 10.10.1.0/24 is directly connected, FastEthernet0
L 10.10.1.2/32 is directly connected, FastEthernet0
C 10.10.2.0/24 is directly connected, FastEthernet1
L 10.10.2.1/32 is directly connected, FastEthernet1

 

このようにルータ2には『10.1.1.0/24』が載っていないですよね。これでは、『10.1.1.0/24』から『10.1.2.0/24』間では疎通が出来ないように見えますが、先程の設定したPBRによって疎通が可能になっています。続けて疎通確認をしてみましょう。

 

疎通確認

それでは疎通確認をしてみましょう。ルータ3のLoopback0(10.1.2.1)からルータ1のLoopback0(10.1.1.1)にPingをうってみます。

 

【RT3】

RT3#ping 10.1.1.1 source loopback 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

このように疎通が出来ていることが確認できると思います。ルーティングがないのに疎通が出来ているのはルータ2でPBR設定をしたからになります。

 

まとめ

ベル

今回の授業はここまでとしますが、いかがでしたか?前回までの座学だけではわからないこともあったと思いますが、実際に設定してみて少しイメージできたと思います。やはり書籍やサイトを読むだけではなく実際に設定してみて、深くわかるものだと思います。ぜひ試してみてください。

 

PBR(Policy-Based Routing)の授業

PBR(Policy-Based Routing)の概要 ~基礎編①~

PBR(Policy-Based Routing)の概要 ~基礎編②~

 

 

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です