GRE Tunnel の設定 〜ダイナミックルート編〜

ベル

今回の授業は、「GREトンネルでマルチキャストパケットを通してみたい」と思います。前回の授業でGREトンネルの作り方を解説していますので、まだ読まれていない方は、こちらの授業から読んでくださいね。

 

GRE Tunnel の設定 〜基礎編〜

GRE Tunnel の設定 〜基礎編〜

 

 

 

お勉強構成

それでは、お勉強構成から紹介していきます。前回のお勉強構成と物理的な構成は同じになりますので、構成を組んだままの方は、そのまま出来ますね!

 

 

ルータ1とルータ2でGREトンネルを構築して、その上をEIGRPのマルチキャストパケットを通してネイバーを確立したいと思います。また、互いのLoopback1のアドレスを交換してみます。やることをイメージしながら、設定していきましょうね!

 

CISCO1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,280から
(2019/5/29 22:31時点)

Cat3560-8PC

CISCO Catalyst 3560-8PC-S マルチレイヤ イーサネット PoE対応 スイッチ WS-C3560-8PC-S

中古価格
¥12,800から
(2019/5/29 22:33時点)

 

事前設定

それでは事前設定をしていきます。今回は、インターフェースとルーティング(スタティックルート)を設定していきたいと思います。

 

インターフェース設定

それでは、インターフェース設定をしていきます。お勉強構成を見ながら設定していきましょうね。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

RT1(config-if)#!

RT1(config)#interface Loopback1

RT1(config-if)#ip address 10.1.1.11 255.255.255.255

RT1(config-if)#!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.10.1 255.255.255.0

RT1(config-if)#no shutdown

 

【RT2】

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

RT2(config-if)#!

RT2(config)#interface Loopback1

RT2(config-if)#ip address 10.1.1.12 255.255.255.255

RT2(config-if)#!

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.10.20.1 255.255.255.0

RT2(config-if)#no shutdown

 

【WAN】

WAN(config)#ip routing

WAN(config)#!

WAN(config)#interface FastEthernet0/1

WAN(config-if)#no switchport

WAN(config-if)#ip address 10.10.10.2 255.255.255.0

WAN(config-if)#!

WAN(config-if)#interface FastEthernet0/2

WAN(config-if)#no switchport

WAN(config-if)#ip address 10.10.20.2 255.255.255.0

 

今回は、Loopback0インターフェイスをGREトンネルの構築に使用し、Loopback1インターフェイスをEIGRPのルート交換で使用してみたいと思います。

 

ルーティング設定(スタティックルート)

続いてルーティング設定を行っていきたいと思います。事前設定ではスタティックルートだけ設定していきます。Loopback1インターフェイスに向けて設定はしないでおきましょうね。後でEIGRPでルート配布させるので大丈夫です。

 

【RT1】

RT1(config)#ip route 10.1.1.2 255.255.255.255 10.10.10.2

RT1(config)#ip route 10.10.20.0 255.255.255.0 10.10.10.2

 

【RT2】

RT2(config)#ip route 10.1.1.1 255.255.255.255 10.10.20.2

RT2(config)#ip route 10.10.10.0 255.255.255.0 10.10.20.2

 

【WAN】

WAN(config)#ip route 10.1.1.1 255.255.255.255 10.10.10.1

WAN(config)#ip route 10.1.1.2 255.255.255.255 10.10.20.1

 

ここまでで事前設定は終了となります。ここまでは前回の設定とほとんど同じになりますので、問題なくできたと思います。難しかった方は、前回の授業を復習しておきましょう。

 

GREトンネルの設定

それでは、GREトンネルを作っていきます。これも前回の授業と同じになりますが、今一度、お勉強構成を見て設定してみましょう。

 

お勉強構成

 

 

【RT1】

RT1(config-if)#interface Tunnel1

RT1(config-if)#ip address 10.10.100.1 255.255.255.0

RT1(config-if)#tunnel source Loopback0

RT1(config-if)#tunnel destination 10.1.1.2

 

【RT2】

RT2(config-if)#interface Tunnel1

RT2(config-if)#ip address 10.10.100.2 255.255.255.0

RT2(config-if)#tunnel source Loopback0

RT2(config-if)#tunnel destination 10.1.1.1

 

これでGREトンネルの確立が出来たはずです。ステータス確認をしていきたいところですが、とりあえず続けてルーティング設定までやってしまいます。

 

ルーティング設定(EIGRP)

それでは、EIGRP(Enhanced Interior Gateway Routing Protocol)の設定を行っていきたいと思いますが、EIGRPの授業を受けられていることが前提となりますので、受けられていない方や忘れてしまった方は、こちらで復習しておきましょう。

 

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~基礎編①~

 

それでは、設定していきますよ。

 

ネイバー関係の構築

まずは、ネイバー関係の構築から設定していきたいと思います。

 

【RT1】

RT1(config)#router eigrp 10

RT1(config-router)#no auto-summary

RT1(config-router)#network 10.1.1.11 0.0.0.0

RT1(config-router)#network 10.10.100.0 0.0.0.255

 

【RT2】

RT2(config)#router eigrp 10

RT2(config-router)#no auto-summary

RT2(config-router)#network 10.1.1.12 0.0.0.0

RT2(config-router)#network 10.10.100.0 0.0.0.255

 

 

これでトンネルを介してEIGRPのネイバーが確立し、Loopback1のIPアドレスをネイバーに配布できるようになりましたが、これではEIGRPの設定雑すぎるので、もう少し設定を整理していきたいと思います。

 

Passive-interfaceの設定

EIGRPのクエリ検索が不要となるインターフェイスに対してPassive-interfaceの設定をしていきます。今回で言うと、Loopbackインターフェイスの先にネイバーがいるはずがないので、パッシブインターフェイスにしてしまいましょう。

 

【RT1】

RT1(config)#router eigrp 10

RT1(config-router)#passive-interface loopback1

 

【RT2】

RT2(config)#router eigrp 10

RT2(config-router)#passive-interface loopback1

 

これで無駄なクエリを出さないようにできますね。それでは、設定完了となるのでステータス確認していきましょう!

 

 

ステータス確認

それでは、ステータス確認を行っていきたいと思います。今回は、以下のコマンドで確認していこうと思います。

 

確認コマンド

show ip interface brief

show ip eigrp neighbors

show ip route

 

show ip interface brief

それでは、インターフェースのステータスから確認していきましょう!今回、ルータ1とルータ2で使用しているインターフェースがアップしていることを確認していきますよ。(WANのL3スイッチも必要に応じて、確認してくださいね。)

 

【RT1】

RT1#show ip interface brief

・・・

FastEthernet0 10.10.10.1 YES manual up up

・・・

Loopback0 10.1.1.1 YES manual up up

Loopback1 10.1.1.11 YES manual up up

Tunnel1 10.10.100.1 YES manual up up

 

【RT2】

RT2#show ip interface brief

・・・

FastEthernet0 10.10.20.1 YES NVRAM up up

・・・

Loopback0 10.1.1.2 YES NVRAM up up

Loopback1 10.1.1.12 YES manual up up

Tunnel1 10.10.100.2 YES manual up up

 

想定通りのステータスになっていない場合は、物理的な配線から確認していくことが大切になります。丁寧に確認してみましょう。

 

show ip eigrp neighbors

続いて、EIGRPのネイバーが、確立出来てているかを確認していきましょう。今回の想定としては、ルータ1とルータ2のGREトンネルを使ってネイバーが確立出来ているはずです。その場合、以下のように表示されます。

 

【RT1】

RT1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(10)
H      Address           Interface  Hold Uptime    SRTT   RTO    Q    Seq
                                              (sec)              (ms)            Cnt   Num
0      10.10.100.2     Tu1          13 00:03:54        4   1434   0     9

 

【RT2】

RT2#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(10)
H      Address           Interface  Hold Uptime    SRTT   RTO    Q    Seq
                                              (sec)              (ms)            Cnt   Num

0      10.10.100.1     Tu1          13 00:04:14        4   1434   0     9

 

『Tu』と言うのは、『Tunnel』の略で、今回はトンネルインターフェース1でネイバーが確立されていることがわかります。

 

show ip route

最後にルーティングテーブルを確認しましょう。それぞれのLoopback1のインターフェイスアドレスが、EIGRPのネイバーから受け取れていればOKです。

 

【RT1】

RT1#show ip route

・・・

C 10.1.1.1/32 is directly connected, Loopback0

S 10.1.1.2/32 [1/0] via 10.10.10.2

C 10.1.1.11/32 is directly connected, Loopback1

D 10.1.1.12/32 [90/27008000] via 10.10.100.2, 00:01:48, Tunnel1

C 10.10.10.0/24 is directly connected, FastEthernet0

S 10.10.20.0/24 [1/0] via 10.10.10.2

C 10.10.100.0/24 is directly connected, Tunnel1

 

 

【RT2】

RT2#show ip route

・・・

S 10.1.1.1/32 [1/0] via 10.10.20.2

C 10.1.1.2/32 is directly connected, Loopback0

D 10.1.1.11/32 [90/27008000] via 10.10.100.1, 00:00:09, Tunnel1

C 10.1.1.12/32 is directly connected, Loopback1

S 10.10.10.0/24 [1/0] via 10.10.20.2

C 10.10.20.0/24 is directly connected, FastEthernet0

C 10.10.100.0/24 is directly connected, Tunnel1

 

このようにネイバーのLoopback1アドレスがTunnel1から受け取れていないようであれば、EIGRPの『network』コマンドのアドレスを確認してみましょう。凡ミスで設定が誤っていることもありますよ。

 

まとめ

ベル

今回の授業はここまでとなります。このように、GREを使うことでEIGRPなどのマルチキャストパケットを交換することができるようになります。これによって拠点間でもダイナミックルーティングが使えるようになり、より耐障害性を向上させることが可能となります。ただし以前の授業でも教えましたが、GREトンネルでは暗号化はされていないため、盗聴されてしまうとデータの中身は見られてしまいます。IPsecなどの暗号化技術と併用して使用されることが一般的となります。

 

EIGRPの授業

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~基礎編②~

EIGRPの概要 ~基礎編③~

EIGRPの概要 ~基礎編④~

EIGRPの概要 ~設定編①~

EIGRPの概要 ~設定編②~

EIGRPの設定 ~メトリック制御編~

 

Nature Remo mini

Nature Remo mini 家電コントロ-ラ- REMO2W1

新品価格
¥6,458から
(2019/6/6 22:35時点)

 

 

Follow me!

GRE Tunnel の設定 〜ダイナミックルート編〜” に対して1件のコメントがあります。

  1. misyo より:

    RT2(config-if)#tunnel source Loopback0

    RT2(config-if)#tunnel source Loopback0
    になっています

    1. ベル より:

      ご指摘ありがとうございます。
      修正させていただきます。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です