GRE Tunnel の設定 〜基礎編〜

ベル

今回の授業は、「GREトンネルの設定」について教えていきたいと思います。前回の授業で概要を解説していますので、まだ読まれていない方は、こちらの授業から読んでくださいね。

 

GRE Tunnel の概要 〜基礎編〜

GRE Tunnel の概要 〜基礎編〜

 

 

お勉強構成

それでは、お勉強構成を紹介させていただきます。今回は、ルータを2台とL3SWを1台で構成を組んでみたいと思います。

 

 

CISCO1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,280から
(2019/5/29 22:31時点)

Cat3560-8PC

CISCO Catalyst 3560-8PC-S マルチレイヤ イーサネット PoE対応 スイッチ WS-C3560-8PC-S

中古価格
¥12,800から
(2019/5/29 22:33時点)

事前設定

それでは、事前設定をしていきたいと思います。今回は、インターフェイス設定とルーティング設定(スタティックルート)をしておきたいと思います。

 

インターフェイス設定

まずはインターフェイス設定から。お勉強構成図を見ながら設定していきましょう。今回使用するルータのインターフェイスはルーテッドポートとなりますので、開放されていない場合は、忘れずに「no shutdown」を入れましょうね。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

RT1(config-if)#!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.10.1 255.255.255.0

RT1(config-if)#no shutdown

 

【RT2】

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

RT2(config-if)#!

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.10.20.1 255.255.255.0

RT2(config-if)#no shutdown

 

擬似WAN環境として、L3SW(Cat3560-8PC)を使用します。そのため、ルーティング処理をさせる場合、「ip routing」の設定が必要になります。詳しくは、以前の授業でL3SWの初期設定を学んでおいてください。

 

CiscoのL3スイッチを使ってみよう!

CiscoのL3スイッチを使ってみよう!

 

それでは、擬似WAN機器の設定をしていきましょう。

 

【WAN】

WAN(config)#ip routing

WAN(config)#!

WAN(config)#interface FastEthernet0/1

WAN(config-if)#no switchport

WAN(config-if)#ip address 10.10.10.2 255.255.255.0

WAN(config-if)#!

WAN(config-if)#interface FastEthernet0/2

WAN(config-if)#no switchport

WAN(config-if)#ip address 10.10.20.2 255.255.255.0

 

これだけです。L3SWのインターフェイスに直接IPアドレスを設定する場合は、アドレス設定する前に「no switchport」設定を入れて、ルーテッドポートとして使用することを宣言する必要がありましたね。これも忘れないようにしましょうね!

 

ルーティング設定

それではルーティングの設定をしていきますが、今回は最初ですのでスタティックルートで設定してみたいと思います。GREトンネルの設定に関係ありませんが、ルータ1とルータ2間のすべてのインターフェイスに対して、お互いに通信ができるようにしておきます。

 

【RT1】

RT1(config)#ip route 10.1.1.2 255.255.255.255 10.10.10.2

RT1(config)#ip route 10.10.20.0 255.255.255.0 10.10.10.2

 

【RT2】

RT2(config)#ip route 10.1.1.1 255.255.255.255 10.10.20.2

RT2(config)#ip route 10.10.10.0 255.255.255.0 10.10.20.2

 

【WAN】

WAN(config)#ip route 10.1.1.1 255.255.255.255 10.10.10.1

WAN(config)#ip route 10.1.1.2 255.255.255.255 10.10.20.1

 

これで事前設定は完了です。スタティックルートの設定なので、それほど難しくなく設定できましたか?それでは次に進みます。

 

GREトンネルの設定

それでは、今回のメインとなるGREトンネルの設定に入っていきたいと思います。まずは、GREトンネルとして使用する仮想インターフェイスを作成し、使用するIPアドレスを定義します。そのトンネルインターフェイスの接続元と接続先を定義してあげるだけでGREトンネルは構築されるようになります。それでは下記の構成図を見ながら、実際の環境を使って設定してみましょう。

 

 

 

【RT1】

RT1(config-if)#interface Tunnel1

RT1(config-if)#ip address 10.10.100.1 255.255.255.0

RT1(config-if)#tunnel source Loopback0

RT1(config-if)#tunnel destination 10.1.1.2

 

【RT2】

RT2(config-if)#interface Tunnel1

RT2(config-if)#ip address 10.10.100.2 255.255.255.0

RT2(config-if)#tunnel source Loopback0

RT2(config-if)#tunnel source Loopback0

 

ここで注意してもらいたいのが、RT1のtunnel destination 10.1.1.2」がRT2のtunnel source Loopback0」とイコールになっていること、RT2のtunnel source Loopback0」とRT1のtunnel source Loopback0」がイコールになっていることが条件となります。このルールが守られていれば、基本的にはGREトンネルはアップされるはずです。それでは、ステータス確認をしていきましょう。

 

ステータス確認

それでは、ステータス確認をしていきます。今回使用するコマンドは、以下になります。

 

確認コマンド

show ip interface brief

show ip route

 

 

show ip interface brief

まずは、「show ip interface brief」でトンネルインターフェイスがアップされているかを確認していきます。

 

【RT1】

RT1#show ip interface brief

Interface           IP-Address      OK?   Method    Status    Protocol

FastEthernet0    10.10.10.1      YES    NVRAM    up         up

Loopback0         10.1.1.1         YES    NVRAM    up         up

Tunnel1            10.10.100.1  YES    NVRAM   up         up

 

【RT2】

RT2#show ip interface brief

Interface           IP-Address      OK?   Method    Status    Protocol

FastEthernet0    10.10.20.1      YES    NVRAM    up         up

Loopback0         10.1.1.2         YES    NVRAM    up         up

Tunnel1            10.10.100.2  YES    NVRAM   up         up

 

このようにトンネルインターフェイスがアップされていればOKですが、もしアップされていないようでしたら、設定したTunnel sourceインターフェイスからtunnel destinationアドレスに向けて疎通確認をしてみてください。このリーチャビリティが確保されていないと、トンネルはアップしません。

 

show ip route

それでは、「show ip route」でルーティングテーブルを確認してみましょう。以下のようにルーティングテーブルが見えていたらOKですね。ポイントとなるのが、10.10.100.0/24がConnectで見えていることですね。

 

【RT1】

RT1#show ip route

・・・

C 10.1.1.1/32 is directly connected, Loopback0

S 10.1.1.2/32 [1/0] via 10.10.10.2

C 10.10.10.0/24 is directly connected, FastEthernet0

S 10.10.20.0/24 [1/0] via 10.10.10.2

C 10.10.100.0/24 is directly connected, Tunnel1

 

 

【RT2】

RT2#show ip route

・・・

S 10.1.1.1/32 [1/0] via 10.10.20.2

C 10.1.1.2/32 is directly connected, Loopback0

S 10.10.10.0/24 [1/0] via 10.10.20.2

C 10.10.20.0/24 is directly connected, FastEthernet0

C 10.10.100.0/24 is directly connected, Tunnel1

 

このようにTunnelが確立されると物理的に間にあるWANの機器を飛ばしてルーティングされるようになります。

 

疎通確認

それでは疎通確認をしてみましょう。GREトンネルの対向側のIPアドレスにPingが通ればOKになります。実際に試してみましょう。

 

ルータ1からルータ2への疎通確認

RT1#ping 10.10.100.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.100.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

ルータ2からルータ1への疎通確認

RT2#ping 10.10.100.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.10.100.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

 

このようにトンネルインターフェイスに設定したアドレス間で、通信できていることが確認できましたか?

 

まとめ

ベル

今回の授業はここまでとします。いかがだったでしょうか?まずはGREトンネルを作るところまでとしましたが、一緒に設定することができましたでしょうか?次回は、GREトンネルを介してダイナミックルーティングを動かしてみたいと思います。

 

静的ルーティング(スタティックルート)の授業

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

 

 

Follow me!

GRE Tunnel の設定 〜基礎編〜” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です