EIGRPの設定 ~メトリック制御編~

ベル

今回の授業は、「EIGRPのメトリック制御」について教えていこうと思います。EIGRPの基本的な設定は前回までの授業で教えていますので、今回は前回に続いてメトリック設定を追加して検証してみたいと思います。忘れてしまった方は、こちらで復習しておきましょう。

 

これまでのEIGRPの授業

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~基礎編②~

EIGRPの概要 ~基礎編③~

EIGRPの概要 ~基礎編④~

EIGRPの設定 ~基礎編~

EIGRPの設定 ~ルート制御編~

 

 

お勉強構成

今回の授業では以下のような構成を組んで勉強してもらいたいと思います。使用するネットワーク機器は4台ですので、是非用意して実際にコマンドを打ち込んでもらえると理解が深まると思います。

 

 

 

構成自体は、それほど複雑ではなくどこにもでありそうな構成ですね。

 

CISCO 1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2019/5/15 18:58時点)

Catalyst 3560-8PC-S

CISCO Catalyst 3560-8PC-S マルチレイヤ イーサネット PoE対応 スイッチ WS-C3560-8PC-S

中古価格
¥10,480から
(2019/5/15 19:01時点)

CISCO コンソールケーブル

【CISCO互換ケーブル】FTDI chipset USB RJ45 コンソールケーブル

新品価格
¥850から
(2019/5/15 19:02時点)

事前設定

それでは事前設定をしていきたいと思います。やることとしては、インターフェイスの設定だけですね。お勉強構成を見ながら設定してみましょう。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.12.1.1 255.255.255.0

!

RT1(config-if)#interface FastEthernet1

RT1(config-if)#ip address 10.13.1.1 255.255.255.0

 

【RT2】

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

!

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.12.1.2 255.255.255.0

!

RT2(config-if)#interface FastEthernet1

RT2(config-if)#ip address 10.24.1.2 255.255.255.0

 

【RT3】

RT3(config)#interface Loopback0

RT3(config-if)#ip address 10.1.1.3 255.255.255.255

!

RT3(config-if)#interface FastEthernet0/0

RT3(config-if)#ip address 10.13.1.3 255.255.255.0

!

RT3(config-if)#interface FastEthernet0/1

RT3(config-if)#ip address 10.34.1.3 255.255.255.0

 

【SW4】

SW4(config)#interface Loopback0

SW4(config-if)#ip address 10.1.1.4 255.255.255.255

!

SW4(config-if)#interface FastEthernet0/1

SW4(config-if)#no switchport

SW4(config-if)#ip address 10.24.1.4 255.255.255.0

!

SW4(config-if)#interface FastEthernet0/2

SW4(config-if)#no switchport

SW4(config-if)#ip address 10.34.1.4 255.255.255.0

 

インターフェイスの設定は完了です。ここまは問題ないでしょうか?

 

EIGRPの基本設定

それではEIGRPの基本設定をしていきたいと思います。基本設定と言っているのは、まずはEIGRPのネイバーが確立できて、ルート交換が出来るところまでを設定・確認してみたいと思います。『network』の設定は、使用しているインターフェイスのサブネットマスク長に合わせて設定しておきたいと思います。

 

【RT1】

RT1(config)#router eigrp 10

RT1(config-router)#no auto-summary

RT1(config-router)#network 10.1.1.1 0.0.0.0

RT1(config-router)#network 10.12.1.0 0.0.0.255

RT1(config-router)#network 10.13.1.0 0.0.0.255

 

 

【RT2】

RT2(config)#router eigrp 10

RT2(config-router)#no auto-summary

RT2(config-router)#network 10.1.1.2 0.0.0.0

RT2(config-router)#network 10.12.1.0 0.0.0.255

RT2(config-router)#network 10.24.1.0 0.0.0.255

 

 

【RT3】

RT3(config)#router eigrp 10

RT3(config-router)#no auto-summary

RT3(config-router)#network 10.1.1.3 0.0.0.0

RT3(config-router)#network 10.13.1.0 0.0.0.255

RT3(config-router)#network 10.34.1.0 0.0.0.255

 

 

【SW4】

SW4(config)#router eigrp 10

SW4(config-router)#no auto-summary

SW4(config-router)#network 10.1.1.4 0.0.0.0

SW4(config-router)#network 10.24.1.0 0.0.0.255

SW4(config-router)#network 10.34.1.0 0.0.0.255

 

 

ここまでの設定は問題ないでしょうか?少しだけ解説しておくと、最初に『router eigrp 10』でEIGRPのAS10を起動させて、『network』コマンドでEIGRP AS10のネットワークに含めるインターフェイスを指定していきます。これでEIGRPのネットワークが構築できたと思いますのでステータスを確認していきましょう。

 

ステータス確認①

それでは、ここまでのEIGRPのステータスを確認していきたいと思います。いつものように必要なところだけをピックアップして確認していきますが、必要に応じてコマンドを追加して確認するようにしてくださいね。今回使用するコマンドは以下です。

 

・show ip route

・show ip eigrp topology

 

特に『show ip route』『show ip eigrp topology all』の2つを重点的に見てみたいと思います。

 

show ip route

それでは『show ip route』でルーティングテーブルを確認してみたいと思います。ここで確認のポイントとなってくるのが、ルータ1とスイッチ4のルーティングになります。お互いのLoopbackインターフェイスのアドレスがどのように見えているでしょうか?

 

【RT1】

D 10.1.1.4/32 [90/158720] via 10.13.1.3, 00:02:51, FastEthernet1
                       [90/158720] via 10.12.1.2, 00:02:51, FastEthernet0

 

【SW4】

D 10.1.1.1/32 [90/158720] via 10.34.1.3, 00:00:09, FastEthernet0/2
                        [90/158720] via 10.24.1.2, 00:00:09, FastEthernet0/1

 

 

赤字にマーキングしている部分を注意して確認してもらえますでしょうか?経路制御の設定を指定ない場合、バランシングされて2経路が見えているのが分かりますか?これは、ルータ2を通る経路とルータ3を通る経路が等コスト(同じメトリック)で見えているからなのです。『show ip eigrp topology』でも確認してみましょう。

 

 

show ip eigrp topology

それでは、『show ip eigrp topology』でEIGRPのトポロジーテーブルを確認してみたいと思います。これにより最優先経路ではないが、EIGRPのネイバーからもらった他のルートも確認出来るようになります。このようなテーブルを持つことで優先経路に障害が発生しても、速やかに迂回経路に切り替えることが出来るようになります。

 

【RT1】

P 10.1.1.4/32, 2 successors, FD is 158720
            via 10.12.1.2 (158720/156160), FastEthernet0
            via 10.13.1.3 (158720/156160), FastEthernet1

 

【SW4】

P 10.1.1.1/32, 2 successors, FD is 158720
            via 10.34.1.3 (158720/156160), FastEthernet0/2
            via 10.24.1.2 (158720/156160), FastEthernet0/1

 

 

現時点では、お互いのLoopbackインターフェイスのアドレスは等コスト(同じメトリック)で見えているため、他の経路が追加で見えることはありませんが、他の経路はルーティングテーブル以外のルートが載っていることが確認できると思います。

 

実際の現場でも等コストで2経路がアクティブで使用する場面もありますが、明示的に通信経路を指定する場合もあります。今回は、ルータ2を経由すようにメトリックを明示的に設定してみたいと思います。今回は、『遅延(Delay)』の変更をしてみますが、『帯域幅(BandWidth)』でも基本的な考え方は同じになりますので、試してみてもらえればと思います。

 

 

EIGRPの経路制御設定

それでは、EIGRPの経路制御設定をしていきたいと思います。以前の授業でも解説してありますが、メトリックにはデフォルト値と言うものがあります。そのデフォルト値から変更することで優先/非優先を決めることが出来ます。今回は、ルータ2経由になるように制御してみたいと思います。

 

 

今回、設定変更するのは、ルータ2とルータ3となります。RT2のインターフェイスdelay値を『500』にして、RT3のインターフェイスには『501』を設定してみたいと思います。

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#delay 500

RT2(config-if)#!

RT2(config-if)#interface FastEthernet1

RT2(config-if)#delay 500

 

【RT3】

RT3(config)#interface FastEthernet0/0

RT3(config-if)#delay 501

RT3(config-if)#!

RT3(config-if)#interface FastEthernet0/1

RT3(config-if)#delay 501

 

このメトリック設定によって通信経路が変化したはずです。ステータスの確認を行っていきましょう。

※今回は、代替ルートを作るためにDelay値の差を小さくしています。

 

ステータス確認②

それではステータス確認をしていきます。先程と同様のコマンドで出力結果を比較していきましょう。

 

show ip route

それでは『show ip route』で確認していきます。先程までは、ルータ1でスイッチ4のLoopbackアドレスがルータ2経由とルータ3経由の2つの経路見えたと思います。また、スイッチ4から見たルータ1のLoopbackアドレスも同様だったかと思います。今回の設定変更で、先に想定した通りルータ2が優先経路として選択されているかを確認してみましょう。

 

【RT1】

D 10.1.1.1/32 [90/284160] via 10.24.1.2, 00:01:24, FastEthernet0/1

 

【SW4】

D 10.1.1.4/32 [90/284160] via 10.12.1.2, 00:05:06, FastEthernet0

 

 

どちらもルータ2経由になっていることがわかりますね。また、メトリック値も変更前と比較して「158720」から「284160」に変化していることがわかります。これは、100MbpsインターフェイスのデフォルトDelay値が『100』だったものに対して、明示的に『500』に変更したことが理由となります。ちなみにメトリック計算する際の値は、設定した値を10倍した数値となります。そのため、『delay 500』と設定したのであれば、計算時は『5000』で計算されるようになります。

 

実際の値を確認したい場合は、『show interface』で対象となるインターフェイスのステータスを確認してもらえれば、以下のように表示されていると思います。

 

【出力例】

RT2#show interfaces fastEthernet 0
FastEthernet0 is up, line protocol is up

・・

Internet address is 10.12.1.2/24
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255

・・

 

 

show ip eigrp topology

続いて、『show ip eigrp topology』で迂回経路がどのようになっているかを確認してみましょう。先程の設定でルータ3経由の経路は、優先的に選ばれなくなりましたが、迂回経路としてトポロジーテーブルには載っているはずです。確認してみましょう。

 

【RT1】

P 10.1.1.4/32, 1 successors, FD is 284160
            via 10.12.1.2 (284160/281600), FastEthernet0
            via 10.13.1.3 (284416/281856), FastEthernet1

 

【SW4】

P 10.1.1.1/32, 1 successors, FD is 284160
            via 10.24.1.2 (284160/281600), FastEthernet0/1
            via 10.34.1.3 (284416/281856), FastEthernet0/2

 

ここで注意してもらいたいのが、このトポロジーテーブルにきさいされる条件です。バックアップ経路のAD値(アドバタイズドディスタンス値)がメイン経路のFD値(フィージブルディスタンス値)を下回ている場合のみ、このトポロジーテーブルに記載されます。過去の授業でも紹介していますので、こちらで復習もしておきましょうね。

 

EIGRPの概要 ~基礎編②~

EIGRPの概要 ~基礎編②~

 

ここまで確認が出来たらおしまいです。

 

まとめ

ベル

今回の授業は、ここまでとなります。いかがだったでしょうか?実際にメトリックを変更することで、意図した経路を優先的に通すことが出来ます。遅延値(Delay)だけでなく帯域幅(BandWidth)を変更したりして、たくさん方法を学んでみてください。

 

EIGRPの授業

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~基礎編②~

EIGRPの概要 ~基礎編③~

EIGRPの概要 ~基礎編④~

EIGRPの概要 ~設定編①~

EIGRPの概要 ~設定編②~

 

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です