Auto Stateで安定したネットワーク構築

ベル

今回の授業は、「Auto Stateで安定したネットワーク構築」する方法ついて教えていきたいと思います。この機能を初めて聞くって方もいるかもしれませんが、しっかり学んでおくと結構便利ですよ。

 

お勉強構成

冒頭でも言いましたが、インターフェイスがダウンすると当たり前ですが、インターフェイスのステータスが変化します。しかしそれ以外に変化してしまうことがありますので、これを理解した上で設計・構築をするようにしましょう。そのための実験をしてみたいと思います。以下のようなお勉強構成を組んでみてください。

 

 

事前設定

それでは、事前設定をしていこうと思います。Vlan設定・インターフェイス設定・ルーティング設定の3つに分けて設定していきます。ルーティングプロトコルはEIGRPを出来るだけでシンプルに設定しておきたいと思います。

 

Vlan設定

まずは、Vlan設定からいきます。ルータ1のVlanデータベースにVlan10を登録する設定からになりますね。

 

【RT1】

RT1(config)#vlan 10

 

 

インターフェイス設定

次にインターフェイス設定をします。先程作ったVlan10も使っていきますよ。

 

【RT1】

RT1(config)#interface fastEthernet 0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

RT1(config-if)#no shutdown

RT1(config-if)#!

RT1(config-if)#interface vlan 10

RT1(config-if)#ip address 10.1.1.254 255.255.255.0

RT1(config-if)#!

RT1(config-if)#interface fastEthernet 2

RT1(config-if)#switchport mode access

RT1(config-if)#access vlan 10

 

 

【RT2】

SW1(config)#interface fastEthernet 0/1

SW1(config-if)#ip address 10.10.1.2 255.255.255.0

SW1(config-if)#no shutdown

 

今回は、使用するネットワーク機器が2台なので簡単ですよね。

 

ルーティング設定

それでは最後にルーティング設定をしていきます。使用する全てのインターフェイスを、ネットワーク設定に含めておきたいと思います。

 

【RT1】

RT1(config)#router eigrp 10

RT1(config-router)#network 10.10.1.0 0.0.0.255

RT1(config-router)#network 10.1.1.0 0.0.0.255

 

【RT2】

SW1(config)#router eigrp 10

SW1(config-router)#network 10.10.1.0 0.0.0.255

 

事前設定はここまでです。ここまで出来たら、お勉強構成を参考にLAN配線を実施しましょう。接続間違いなどがないように気を付けましょうね!

 

ステータス確認

それではステータス確認を実施していきます。今回は、インターフェイスダウンが与える影響を調査するための実験となりますので、以下のコマンドを使って確認していこうと思います。

 

・show ip interface brief

・show ip route

 

もちろん、他にも『show interface status』や『show ip eigrp neighbor』など、確認すべきコマンドもあるのですが、今回の実験に関係がないの割愛します。

 

show ip interface brief

それでは、使用しているインターフェイスの状態を確認していきましょう。お勉強構成を参考に使用しているインターフェイスがすべてUP/UPであることを確認しましょうね。物理インターフェースだけではなく、Vlan10もUP/UPになっていることも確認しましょう!以下のようなステータスになっていればOKです。

 

【RT1】

RT1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
BRI0 unassigned YES NVRAM administratively down down
BRI0:1 unassigned YES unset administratively down down
BRI0:2 unassigned YES unset administratively down down
FastEthernet0 10.10.1.1 YES NVRAM up up
FastEthernet1 unassigned YES NVRAM down down
FastEthernet2 unassigned YES unset up up
FastEthernet3 unassigned YES unset up down

・・・

Vlan1 unassigned YES NVRAM up down
Vlan10 10.1.1.254 YES manual up up

 

【SW1】

SW1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
Vlan1 unassigned YES NVRAM administratively down down
FastEthernet0/1 10.10.1.2 YES manual up up
FastEthernet0/2 unassigned YES unset down down
FastEthernet0/3 unassigned YES unset down down
・・・

 

show ip route

それでは、ルーティングテーブルも確認していきましょう。スイッチ1で、ルータ1のVLAN10(10.1.1.0/24)がEIGRPの内部ルートで受け取れていたらOKですね。

 

【RT1】

RT1#show ip route

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.0/24 is directly connected, Vlan10
L 10.1.1.254/32 is directly connected, Vlan10
C 10.10.1.0/24 is directly connected, FastEthernet0
L 10.10.1.1/32 is directly connected, FastEthernet0

 

【SW1】

SW1#show ip route

10.0.0.0/24 is subnetted, 2 subnets
C 10.10.1.0 is directly connected, FastEthernet0/1
D 10.1.1.0 [90/30720] via 10.10.1.1, 00:05:40, FastEthernet0/1

 

 

実験開始

それでは実際にインターフェイスをダウンさせて影響を調べてみたいと思います。今回、ダウンさせるインターフェイスは、ルータ#1のFastEthernet2となります。これは、LANケーブルの故障だけではなく接続している端末のシャットダウンなどが行われた際に発生する事象となります。それでは、LANケーブルを抜線してみましょう。

 

影響確認①

それでは、抜染した結果、ルータ1のインターフェースがちゃんとダウンしているかを確認してみましょう。

 

【RT1】

RT1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
BRI0 unassigned YES NVRAM administratively down down
BRI0:1 unassigned YES unset administratively down down
BRI0:2 unassigned YES unset administratively down down
FastEthernet0 10.10.1.1 YES NVRAM up up
FastEthernet1 unassigned YES NVRAM down down
FastEthernet2 unassigned YES unset down down
・・・
Vlan1 unassigned YES NVRAM up down
Vlan10 10.1.1.254 YES manual up down
・・・

 

先程、抜染したFastEthernet2がダウンしているのは当たり前ですが、アサインしていたVlan10までダウンしていることがわかるでしょうか?これは、Vlan10を使用しているすべてのインターフェイスがダウンしてしまうと、Vlan10のインターフェイスもダウンしてしまうからなんです。「なんだ~。それだけ~?」って思われるかもしれませんが、そんなことないです。ルータ1のルーティングテーブルを見てみましょう。

 

【SW1】

SW1#show ip route

10.0.0.0/24 is subnetted, 1 subnets
C 10.10.1.0 is directly connected, FastEthernet0/1

 

あれ?EIGRPの内部ルートで受け取っていたルート(10.1.1.0/24)がなくなっていますね。そう!これは、ルータ#1のVlan10がダウンしてしまったからなんです。当然、ルータ#1のルーティングテーブルにもなくなっているはずですので、確認しておいてください。このように、Vlanを収容してる全ての物理インターフェースがダウンしてしまうとルーティングテーブルにも影響が出てしまうことがあるんです。これが頻繁に起きてしまうと、ルーティングテーブルが正常なのかがわかりづらくなってしまうことがあります。

 

インターフェイスダウンを防ぐ設定

このような事態を防ぐための設定は、実は簡単です。たった1行で済みますので、もし知らなかった方は試してみてください。

 

【RT1】

RT1(config)#interface vlan 10

RT1(config-if)#no autostate

 

たったこれだけなんです。インターフェイスのステータスをダウンに変更したくないインターフェイスコンフィグレーションモードで『no autostate』コマンドを実行するだけです。これだけで、インターフェイスをダウンさせなくできます。

 

影響確認②

それでは、影響確認をしてみましょう。先程と同様のコマンドで見ていこうと思います。

 

【RT1】

RT1#show ip interface brief
Interface IP-Address OK? Method Status Protocol
BRI0 unassigned YES NVRAM administratively down down
BRI0:1 unassigned YES unset administratively down down
BRI0:2 unassigned YES unset administratively down down
FastEthernet0 10.10.1.1 YES NVRAM up up
FastEthernet1 unassigned YES NVRAM down down
FastEthernet2 unassigned YES unset down down
・・・
Vlan1 unassigned YES NVRAM up down
Vlan10 10.1.1.254 YES manual up up

 

先程と同様にFastEthernet2はダウンしているが、Vlan10はアップになっていることが確認できるでしょうか?『no autostate』コマンドでステータスの変更を自動で行われないようになったからです。『shutdown』コマンドを実行しない限り、Vlan10はダウンステータスにならなくなりました。もちろんスイッチ2にもルート情報を伝えられているはずですので、確認しておきましょう。

 

【RT2】

SW1#show ip route

10.0.0.0/24 is subnetted, 2 subnets
C 10.10.1.0 is directly connected, FastEthernet0/1
D 10.1.1.0 [90/30720] via 10.10.1.1, 00:06:12, FastEthernet0/1

 

ちゃんとセグメント(10.1.1.0/24)がルーティングテーブルに表示されていることが確認出来ましたか?これにより、頻繁にセグメントがアップ/ダウンを繰り返すようなことが起きなくなりました。

 

まとめ

ベル

今日の授業はここまでです。たった、1行のコマンドだけで安定したネットワークにすることが出来ることもあります。ただし、いきなり本番環境に適用するのではなく、しっかりと検証してから投入するようにしましょうね。機器やIOSのバージョンによっては対応していないこともありますので、ちゃんと調べてからにしましょうね!

 

CISCO1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2019/4/7 21:46時点)

コンソルケーブル

【CISCO互換ケーブル】FTDI chipset USB RJ45 コンソールケーブル

新品価格
¥869から
(2019/4/7 22:00時点)

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です