Link Aggregationの設定 ~PAgP編~

ベル

今回の授業は、Link AggregationPAgP設定」について学んでもらおうと思います。前回の授業でLACPの設定を学んでもらいましたので、実際に設定を入れて確認していこうと思います。前回までの授業を受けられていない方は、こちらから受けてくださいね!

 

Link Aggregationの概要

Link Aggregationの概要 〜基礎編①〜

Link Aggregationの概要 〜基礎編②〜

Link Aggregationの設定 ~LACP編~

 

 

お勉強構成

今回は、前回と同じような構成で勉強したいと思いますが、使用するインターフェイスを変えています。間違わないように注意して設定してみてください。また、前回で使用したLACPのインターフェースも後で使用するの消さないでおいてくださいね!

 

 

 

 

事前設定

それでは、事前設定をしていきたいと思いますが、こちらも前回の設定と基本的には同じになります。サラッと設定していきましょう。

 

【SW1 】

SW1(config)#vlan 10

SW1(config-vlan)#vlan 20

SW1(config-vlan)#interface Vlan10

SW1(config-if)#ip address 10.10.10.1 255.255.255.0

SW1(config-if)#!

SW1(config-if)#interface Vlan20

SW1(config-if)#ip address 10.10.20.1 255.255.255.0

 

【SW2】

SW2(config)#vlan 10

SW2(config-vlan)#vlan 20

SW2(config-vlan)#interface Vlan10

SW2(config-if)#ip address 10.10.10.2 255.255.255.0

SW2(config-if)#!

SW2(config-if)#interface Vlan20

SW2(config-if)#ip address 10.10.20.2 255.255.255.0

 

ここまでは、問題なくできましたか?次の設定にいきますよ。

 

Link Aggregationの設定

それでは、Link Aggregatoinの設定をしていきたいと思います。今回は、PAgPの設定をしてみたいと思います。PAgPの設定をする場合は、modeを「Desirable」か「Auto」のどちらかを選択しなければいけません。最初は、『Desirable-Desirable』で設定してみたいと思いますが、前回と同じような設定ではつまらないので、リンクアグリゲーションで使用するインターファイスをまとめて設定してみます。

 

【SW1】

SW1(config)#interface range FastEthernet0/6 – 7

SW1(config-if-range)#switchport trunk encapsulation dot1q

SW1(config-if-range)#switchport trunk allowed vlan 10,20

SW1(config-if-range)#switchport mode trunk

SW1(config-if-range)#channel-group 2 mode desirable

 

【SW2】

SW2(config)#interface range GigabitEthernet1/0/6 – 7

SW2(config-if-range)#switchport trunk encapsulation dot1q

SW2(config-if-range)#switchport trunk allowed vlan 10,20

SW2(config-if-range)#switchport mode trunk

SW2(config-if-range)#channel-group 2 mode desirable

 

このようにインターファイスの設定にrange』コマンドを使用することで、同一の設定をまとめて行うことが出来ますので、多くのインターファイスでリンクアグリゲーションを組む場合には、覚えておくととても便利ですね。

 

ステータス確認

それでは、ステータスの確認を行っていこうと思います。今回は、show ip interface briefshow etherchannel summaryのコマンドで確認していこうと思います。

 

show ip interface brief

まずは、show ip interface brief』コマンドで使用しているインターファイスがUPしていること、設定したVlanIPアドレスがアサインされていることを確認しておきましょう。

 

【SW1】

SW1#show ip interface brief
Interface                IP-Address      OK?  Method     Status                         Protocol
Vlan1                     unassigned     YES   NVRAM    administratively down  down
Vlan10                  10.10.10.1     YES   NVRAM   up                               up
Vlan20                  10.10.20.1     YES   NVRAM   up                               up

・・・

FastEthernet0/5     unassigned     YES   unset      down                          down
FastEthernet0/6   unassigned   YES   unset      up                               up
FastEthernet0/7   unassigned   YES   unset      up                               up
FastEthernet0/8     unassigned     YES   unset      down                          down
・・・

Port-channel2      unassigned   YES   unset      up                               up

 

【SW2】

SW2#show ip interface brief
Interface                        IP-Address      OK?   Method     Status                         Protocol
Vlan1                             unassigned     YES    NVRAM    administratively down  down
Vlan10                           10.10.10.2     YES   NVRAM   up                               up
Vlan20                           10.10.20.2     YES   NVRAM   up                               up
・・・

GigabitEthernet0/3       unassigned     YES   unset       down                          down
GigabitEthernet0/4   unassigned    YES   unset      up                               up
GigabitEthernet0/5   unassigned    YES   unset      up                               up
GigabitEthernet0/6       unassigned     YES    unset      down                          down

・・・

Port-channel2              unassigned    YES   unset      up                               up

 

ここまでは前回のステータスと同じですね。次の『show etherchannel summary』でリンクアグリゲーションの設定を確認していきましょう。

 

show etherchannel summary

次にshow etherchannel summaryでリンクアグリゲーションがちゃんとできているかを確認してみたいと思います。前回の『LACP』との差分を意識しながら確認していきましょう。

 

【Sw1】

SW1#show etherchannel summary
Flags: D – down             P – in port-channel
          I – stand-alone    s – suspended
          H – Hot-standby (LACP only)
          R – Layer3          S – Layer2
          U – in use           f – failed to allocate aggregator
          u – unsuitable for bundling
          w – waiting to be aggregated
          d – default port

Number of channel-groups in use: 1
Number of aggregators:               1

Group Port-channel Protocol    Ports
——+————-+———–+———————————————–

1        Po1(SD)       LACP        Fa0/4(D)    Fa0/5(D)
      Po2(SU)      PAgP        Fa0/6(P)  Fa0/7(P)

 

【SW2】

SW2#show etherchannel summary
Flags: D – down             P – in port-channel
          I – stand-alone    s – suspended
          H – Hot-standby (LACP only)
          R – Layer3          S – Layer2
          U – in use           f – failed to allocate aggregator
          u – unsuitable for bundling
          w – waiting to be aggregated
          d – default port

Number of channel-groups in use: 1
Number of aggregators:               1

Group Port-channel Protocol    Ports
——+————-+———–+———————————————–

1      Po1(SD)        LACP         Gi0/4(D)    Gi0/5(D)
2      Po2(SU)       PAgP        Gi0/6(P)   Gi0/7(P)

 

ProtocolがPAgPになっていることが分かりますか?ここでPort-Channel1インターファイスでPAgPが使用されていることがわかります。

 

おまけ(LACPとPAgP)

今回は、特別にLACPとPAgPで接続してみたいと思います。構成は以下の通りです。

 

 

このように接続するとshow etherchannel summaryでどのように表示されるかを確認してみましょう。知っているだけで誤った設定で接続されていることが気付けるようになると思います。

 

【Sw1】

SW1#show etherchannel summary
Flags: D – down             P – in port-channel
          I – stand-alone    s – suspended
          H – Hot-standby (LACP only)
          R – Layer3          S – Layer2
          U – in use           f – failed to allocate aggregator
          u – unsuitable for bundling
          w – waiting to be aggregated
          d – default port

Number of channel-groups in use: 1
Number of aggregators:               1

Group Port-channel Protocol    Ports
——+————-+———–+———————————————–

1        Po1(SD)      LACP         Fa0/4(I)    Fa0/5(I)
2        Po2(SD)       PAgP          Fa0/6(D)    Fa0/7(D)

 

【SW2】

SW2#show etherchannel summary
Flags: D – down             P – in port-channel
          I – stand-alone    s – suspended
          H – Hot-standby (LACP only)
          R – Layer3          S – Layer2
          U – in use           f – failed to allocate aggregator
          u – unsuitable for bundling
          w – waiting to be aggregated
          d – default port

Number of channel-groups in use: 1
Number of aggregators:               1

Group Port-channel Protocol    Ports
——+————-+———–+———————————————–

1      Po1(SD)        LACP         Gi0/4(D)    Gi0/5(D)
2      Po2(SD)       PAgP        Gi0/6(I)   Gi0/7(I)

 

やっぱりちゃんとUPされなかったですね。接続しているのに(I)で表示されているということは、stand-aloneになっているということです。つまりネゴシエーションが確立していないということになるので、このような場合は、プロトコルミスマッチがないか確認してみるようにしましょうね。

 

まとめ

ベル

今回の授業はいかがでしたか?前回の授業をちゃんと理解出来ていれば、それほど難しくなかったと思います。また、別のプロトコル同士だとネゴシエーション出来ないこともわかってもらえたと思いますので、対抗の仕様をしっかり確認するようにしましょうね!

 

CISCO 3750-24TS-E

CISCO Catalyst 3750-24TS-E スタッカブル マルチレイヤ イーサネットスイッチ WS-C3750-24TS-E

中古価格

¥5,000から
(2019/2/20 23:40時点)

CISCO 3560-8PC-S

□#Cisco/シスコ Catalyst 3560シリーズ PoE-8 【WS-C3560-8PC-S】 初期化済み【中古】

価格:7,020円
(2019/2/21 23:09時点)
感想(0件)

Cisco LANスイッチ教科書

[第3版] Cisco LANスイッチ教科書【電子書籍】[ シスコシステムズ合同会社 基盤技術グループ ]

価格:4,190円
(2019/2/20 23:45時点)
感想(0件)

 

 

 

 

Follow me!

Link Aggregationの設定 ~PAgP編~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です