Link Aggregationの設定 ~LACP編~

ベル

今回の授業は、Link AggregationLACP設定」について学んでもらおうと思います。前回の授業でLink Aggregationの基礎を学んでもらいましたので、実際に設定を入れて確認していこうと思います。前回までの授業を受けられていない方は、こちらから受けてくださいね!

 

Link Aggregationの概要

Link Aggregationの概要 〜基礎編①〜

Link Aggregationの概要 〜基礎編②〜

 

 

お勉強構成

今回は以下の構成で勉強したいと思います。すごいシンプルな構成ですが、学ぶことはたくさんありますので、実際に機器を用意して試してみてください。

 

 

 

 

事前設定

それでは、事前設定をしていきたいと思います。今回は、それぞれのスイッチにVlan10とVlan20を作成していきたいと思います。お勉強構成を見ながら設定していきましょう。

 

【SW1 】

SW1(config)#vlan 10

SW1(config-vlan)#vlan 20

SW1(config-vlan)#interface Vlan10

SW1(config-if)#ip address 10.10.10.1 255.255.255.0

SW1(config-if)#!

SW1(config-if)#interface Vlan20

SW1(config-if)#ip address 10.10.20.1 255.255.255.0

 

【SW2】

SW2(config)#vlan 10

SW2(config-vlan)#vlan 20

SW2(config-vlan)#interface Vlan10

SW2(config-if)#ip address 10.10.10.2 255.255.255.0

SW2(config-if)#!

SW2(config-if)#interface Vlan20

SW2(config-if)#ip address 10.10.20.2 255.255.255.0

 

 

Link Aggregationの設定

それでは、Link Aggregatoinの設定をしていきたいと思います。今回は、LACPの設定をしてみたいと思います。LACPの設定をする場合は、modeを「Active」か「Passive」のどちらかを選択しなければいけません。今回は『Active-Active』で設定してみたいと思います。

 

【SW1】

SW1(config)#interface FastEthernet0/4

SW1(config-if)#switchport trunk encapsulation dot1q

SW1(config-if)#switchport trunk allowed vlan 10,20

SW1(config-if)#switchport mode trunk

SW1(config-if)#channel-group 1 mode active

SW1(config-if)#!

SW1(config-if)#interface FastEthernet0/5

SW1(config-if)#switchport trunk encapsulation dot1q

SW1(config-if)#switchport trunk allowed vlan 10,20

SW1(config-if)#switchport mode trunk

SW1(config-if)#channel-group 1 mode active

 

【SW2】

SW2(config)#interface GigabitEthernet0/4

SW2(config-if)#switchport trunk encapsulation dot1q

SW2(config-if)#switchport trunk allowed vlan 10,20

SW2(config-if)#switchport mode trunk

SW2(config-if)#channel-group 1 mode active

SW2(config-if)#!

SW2(config-if)#interface GigabitEthernet0/5

SW2(config-if)#switchport trunk encapsulation dot1q

SW2(config-if)#switchport trunk allowed vlan 10,20

SW2(config-if)#switchport mode trunk

SW2(config-if)#channel-group 1 mode active

 

今回は、トランクポート(dot1q)としてインターフェイスを使っています。また、全てのVlanを流すのではなく、事前設定で作成したVlan10と20だけに絞って流すようにしてみましたが、ピンとこない方は以前の授業でトランクを解説しているので、こちらも合わせて読んでもらえればと思います。

 

インターフェースの設定 ~ルーテッドポートとスイッチポート~

インターフェース設定 ~ルーテッドポートとスイッチポート~

 

上記の設定をしてみるとCreating a port-channel interface Port-channel 1のメッセージが表示されたと思います。これは、Port-channel1の仮想インターフェースが作成されたことを意味しています。実際に設定内容を見てみると以下のようになっていると思います。

 

SW2#show running-config
Building configuration…

・・・

interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 10,20
 switchport mode trunk

 

このPort-channel1に表示されている内容は、先程の物理インターフェースに設定したコンフィグがそのまま表示されていますよね。このように、物理インターフェースとPort-channelインターフェースの両方で同じ設定が入っている必要があります。それでは、

 

 

ステータス確認

それでは、ステータスの確認を行っていこうと思います。今回は、show ip interface briefshow etherchannel summaryのコマンドで確認していこうと思います。

 

show ip interface brief

まずは、show ip interface brief』コマンドで使用しているインターファイスがUPしていること、設定したVlanIPアドレスがアサインされていることを確認しておきましょう。

 

【SW1】

SW1#show ip interface brief
Interface                IP-Address      OK?  Method     Status                         Protocol
Vlan1                     unassigned     YES   NVRAM    administratively down  down
Vlan10                  10.10.10.1     YES   NVRAM   up                               up
Vlan20                  10.10.20.1     YES   NVRAM   up                               up

・・・

FastEthernet0/3     unassigned     YES   unset      down                          down
FastEthernet0/4   unassigned   YES   unset      up                               up
FastEthernet0/5   unassigned   YES   unset      up                               up
FastEthernet0/6     unassigned     YES   unset      down                          down
・・・

Port-channel1      unassigned   YES   unset      up                               up

 

【SW2】

SW2#show ip interface brief
Interface                        IP-Address      OK?   Method     Status                         Protocol
Vlan1                             unassigned     YES    NVRAM    administratively down  down
Vlan10                           10.10.10.2     YES   NVRAM   up                               up
Vlan20                           10.10.20.2     YES   NVRAM   up                               up
・・・

GigabitEthernet1/0/3       unassigned     YES   unset       down                          down
GigabitEthernet1/0/4   unassigned    YES   unset      up                               up
GigabitEthernet1/0/5   unassigned    YES   unset      up                               up
GigabitEthernet1/0/6       unassigned     YES    unset      down                          down

・・・

Port-channel1               unassigned    YES   unset      up                               up

 

show etherchannel summary

次にshow etherchannel summaryでリンクアグリゲーションがちゃんとできているかを確認してみたいと思います。

 

【Sw1】

SW1#show etherchannel summary
Flags: D – down             P – in port-channel
          I – stand-alone    s – suspended
          H – Hot-standby (LACP only)
          R – Layer3          S – Layer2
          U – in use           f – failed to allocate aggregator
          u – unsuitable for bundling
          w – waiting to be aggregated
          d – default port

Number of channel-groups in use: 1
Number of aggregators:               1

Group Port-channel Protocol    Ports
——+————-+———–+———————————————–
1        Po1(SU)      LACP        Fa0/4(P) Fa0/5(P)

 

 

【SW2】

SW2#show etherchannel summary
Flags: D – down             P – in port-channel
          I – stand-alone    s – suspended
          H – Hot-standby (LACP only)
          R – Layer3          S – Layer2
          U – in use           f – failed to allocate aggregator
          u – unsuitable for bundling
          w – waiting to be aggregated
          d – default port

Number of channel-groups in use: 1
Number of aggregators:               1

Group Port-channel Protocol    Ports
——+————-+———–+———————————————–
1       Po1(SU)       LACP        Gi1/0/4(P) Gi1/0/5(P)

 

 

このように『(SU)』と表示されているということは、Layer2Port-channelUPしていることを意味しています。このような状態になっていれば、問題なく使えていることが分かります。このステータスは、Active-ActiveActive-Passiveで接続した場合になります。もし誤ってPassive-Passiveで接続してしまうと、以下のようなステータスになるので試してみるといいと思います。

 

【SW1】

SW1#show etherchannel summary
Flags: D – down             P – in port-channel
          I – stand-alone    s – suspended
          H – Hot-standby (LACP only)
          R – Layer3          S – Layer2
          U – in use           f – failed to allocate aggregator
          u – unsuitable for bundling
          w – waiting to be aggregated
          d – default port

Number of channel-groups in use: 1
Number of aggregators:               1

Group Port-channel Protocol    Ports
——+————-+———–+———————————————–
1        Po1(SD)      LACP        Fa0/4(I) Fa0/5(I)

 

このステータスで注目してもらいたいのが『(SD)』となっている点ですね。Downのステータスになっているのが分かりますか?このように、両方が『Passive』モードで接続するとEtherChannelUPしないので間違えないようにしましょうね!

 

まとめ

ベル

今回の授業はいかがでしたか?リンクアグリゲーションの設定を初めてやってみた方でも、それほど難しくなく出来たと思います。次回はPAgPの設定を試してみたいと思いますので、ここまでの復習をしっかりやっておきましょうね。それでは、次のPAgPの授業に進みましょう!

Link Aggregationの設定 ~PAgP編~

Link Aggregationの設定 ~PAgP編~

 

CISCO 3750-24TS-E

CISCO Catalyst 3750-24TS-E スタッカブル マルチレイヤ イーサネットスイッチ WS-C3750-24TS-E

中古価格

¥5,000から
(2019/2/20 23:40時点)

CISCO 3560-8PC-S

□#Cisco/シスコ Catalyst 3560シリーズ PoE-8 【WS-C3560-8PC-S】 初期化済み【中古】

価格:7,020円
(2019/2/21 23:09時点)
感想(0件)

Cisco LANスイッチ教科書

[第3版] Cisco LANスイッチ教科書【電子書籍】[ シスコシステムズ合同会社 基盤技術グループ ]

価格:4,190円
(2019/2/20 23:45時点)
感想(0件)

 

 

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です