ルーテッドポートを論理分割する方法

ベル

今回の授業は、「ルーテッドポートを論理分割する方法」を教えていこうと思います。以前の授業で、スイッチポートに複数のVlanをアサインする『トランクポート』を学びました。これにより1つの物理インターフェースに、複数のIPアドレスをアサインすることが出来るようになったと思います。ルータでも同じようなことが出来るのでやってみたいと思います。以前の授業も読んでおいてくださいね!

インターフェース設定 ~ルーテッドポートとスイッチポート~

インターフェース設定 ~ルーテッドポートとスイッチポート~

 

ルータの特徴

以前の「CiscoL3スイッチを使ってみよう!」の授業で、ルータとL3スイッチの違いを紹介させていただきました。そこで上げさせていただいた特徴でもありますが、ルータはインターフェースの数が少なく作られています。そのため、多くのネットワーク機器とは物理的に接続できないようになっています。

 

ただし、論理的には接続は可能となります。論理的に接続可能と言っているのは、物理のインターフェースを複数の論理インターフェースに分割し、多くのセグメントを終端することが可能となります。それでは、具体的に設定しながら学んでもらおうと思います。

 

お勉強構成

今回は、以下のような構成で組んでみたいと思います。最後には、ステータス確認だけでなく、ルータとスイッチ間で疎通が取れるところまで確認しておきたいと思います。

 

 

Cisco 1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格

¥4,880から
(2019/2/10 21:56時点)

Catalyst 3560-8PC-S

CISCO Catalyst 3560-8PC-S マルチレイヤ イーサネット PoE対応 スイッチ WS-C3560-8PC-S

中古価格

¥14,000から
(2019/2/10 21:58時点)

L3スイッチの設定

それでは、L3スイッチの設定からしていきたいと思います。と言うのは、L3スイッチの設定は、前回のトランク設定をちゃんと学んでいれば出来るはずですので、さらっといきたいと思います。お勉強構成を見なら設定していきましょう。

 

【SW1】

SW1(config)#vlan 10

SW1(config-vlan)#vlan 20

SW1(config-vlan)#interface vlan 10

SW1(config-if)#ip address 10.10.10.1 255.255.255.0

SW1(config-if)#!

SW1(config)#interface vlan 20

SW1(config-if)#ip address 10.10.20.1 255.255.255.0

SW1(config-if)#!

SW1(config-if)#interface FastEthernet0/1

SW1(config-if)#switchport trunk encapsulation dot1q

SW1(config-if)#switchport mode trunk

SW1(config-if)#switchport trunk allowed vlan 10,20

 

どうでした?出来ました?難しく感じるようでしたら、前回の授業を復習しておきましょうね!

 

ルータの設定

それでは、ルータの設定に入っていこうと思います。スイッチでは複数のVLANをアサインするためにトランクポートになるように設定してきましたが、ルータでは『サブインターフェース』という論理インターフェースを作成します。以下のような設定となります。

 

【RT1】

RT1(config)#interface fastEthernet0

RT1(config-if)#no shutdown

RT1(config-if)#!

RT1(config-if)#interface fastethernet0.10

RT1(config-subif)#encapsulation dot1Q 10

RT1(config-subif)#ip address 10.10.10.254 255.255.255.0

RT1(config-subif)#!

RT1(config-subif)#interface fastethernet0.20

RT1(config-subif)#encapsulation dot1q 20

RT1(config-subif)#ip address 10.10.20.254 255.255.255.0

RT1(config-subif)#!

 

まずは、interface fastethernet0.10でFastEthernet0にサブインターフェースを作成します。後半に10と言う数字がついていますが、これはただの論理番号です。その後、encapsulation dot1q 10でトラッキングプロトコルを定義して、タグ番号を紐づけます。まさに『トランクポート』と同じ考え方です。

 

このようにして、2つのサブインターフェースを作成して、1つの物理インターフェースを2つに分割することが出来ました。いよいよ接続して確認していきたいと思います。

 

ステータス確認

それでは、ステータス確認をしてみたいと思います。今回はshow ip interface briefでステータスを確認していきましょう。まずは、L3スイッチからです。今回使用しているインターフェイスは、Vlan1020FastEthernet0/1だけですので、UPUPになっていることを確認しておきます。

 

【SW1】

SW1#show ip interface brief
Interface                     IP-Address       OK?  Method   Status                          Protocol
Vlan1                          unassigned       YES  NVRAM   administratively down   down
Vlan10                        10.10.10.1      YES  NVRAM   up                                up
Vlan20                        10.10.20.1      YES  NVRAM   up                                up
FastEthernet0/1           unassigned       YES  unset     up                                up
FastEthernet0/2           unassigned       YES  unset     down                            down
FastEthernet0/3           unassigned       YES  unset     down                            down
FastEthernet0/4           unassigned       YES  unset     down                            down
FastEthernet0/5           unassigned       YES  unset     down                            down
FastEthernet0/6           unassigned       YES  unset     down                            down
FastEthernet0/7           unassigned       YES  unset     down                            down
FastEthernet0/8           unassigned       YES  unset     down                            down
GigabitEthernet0/1       unassigned       YES  unset     down                            down

 

次にルータ1のステータスを確認していきます。FastEthernet0のサブインターフェースが表示されていることを確認していきましょう。

 

RT1#show ip interface brief
Interface                     IP-Address       OK?  Method   Status                          Protocol
BRI0                           unassigned       YES  NVRAM   administratively down   down
BRI0:1                        unassigned       YES  unset      administratively down   down
BRI0:2                        unassigned       YES  unset      administratively down   down
FastEthernet0            unassigned     YES  TFTP       up                               up
FastEthernet0.10       10.10.10.254  YES  manual   up                               up
FastEthernet0.20       10.10.20.254  YES  manual   up                               up
FastEthernet1             unassigned        YES  TFTP       administratively down   down
FastEthernet2             unassigned        YES  unset       up                               down
FastEthernet3             unassigned        YES  unset       up                               down
FastEthernet4             unassigned        YES  unset       up                               down
FastEthernet5             unassigned        YES  unset       up                               down
FastEthernet6             unassigned        YES  unset       up                               down
FastEthernet7             unassigned        YES  unset       up                               down
FastEthernet8             unassigned        YES  unset       up                               down
FastEthernet9             unassigned        YES  unset       up                               down

 

こんな感じに表示されるはずです。

 

疎通確認

それでは、最後に疎通確認をしていこうと思います。コマンドは、いつも通りの『Ping』となります。2つのセグメント間で疎通確認が取れればOKですね!それでは、せっかく設定したのでルータから疎通確認をしてみましょう。今回は、送信元のインターフェースも指定して疎通確認してみます。以下のような結果になっていればOKですね!

 

【RT1】

RT1#ping 10.10.10.1 source fastEthernet 0.10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.10.254
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
RT1#ping 10.10.20.1 source fastEthernet 0.20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.20.1, timeout is 2 seconds:
Packet sent with a source address of 10.10.20.254
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

 

まとめ

ベル

今回の授業はいかがでしたか?少し難しかったですか?スイッチではトランクポートで論理分割、ルータはサブインターフェースで論理分割出来ることをしっかり学んで、実機で検証しておきましょうね!必ず使われる技術です。

 

自宅ラボのススメ

自宅ラボを作ってみたな~って思われる方は、一度、読んでもらえればと思います。きっと自宅ラボを作るメリットを学んでもらえると思います。

自宅ラボのススメ

 

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です