インターフェース設定 ~ルーテッドポートとスイッチポート~

ベル

今回は、『ルーテッドポートとスイッチポートの設定について教えていきたいと思います。前回の授業でいろんなスイッチポートを教えたので、今度は、実際に設定方法を学んでもらえればと思います。前回の授業を受けていない方は、こちらから読んでくださいね!

スイッチポートの使い方

スイッチポートの使い方

 

授業の復習

前回の授業(スイッチポートの使い方)では、L3スイッチのポートには『ルーテッドポート』『スイッチポート』の2種類あることを教えました。また、スイッチポートとして使用する場合でも、『アクセスポート』としてVlanを1つだけ設定する方法もあれば、『トランクポート』として複数のVlanを設定する方の2種類に分割出来ることも学びましたね。

 

今回は、この『ルーテッドポート』、『スイッチポート_アクセスポート』、『スイッチポート_トランクポート』の3つ設定方法を教えていきますので、しっかり覚えていきましょうね!

 

お勉強構成

今回のお勉強構成は、以下の通りになります。スイッチ1台の3つのインターフェースを使用して、4つのIPアドレスを設定していきたいと思います。構成図には1台しか書いていないですが、リンクアップするために使っていないスイッチがあったら用意しておきましょうね。

 

 

 

ルーテッドポートの設定

それでは、一番簡単な『ルーテッドポート』から。『ルーテッドポート』は、物理のインターフェースに直接IPアドレスを設定することが出来ます。それでは、早速、IPアドレスの設定をしてみましょう。

 

SW1(config)#interface fastEthernet 0/1

SW1(config-if)#ip address 10.10.1.1 255.255.255.0
^
% Invalid input detected at ‘^’ marker.

※省略可(show run)

 

あれ?なんかL3スイッチくんから怒られましたね。このメッセージは、あのーぼくスイッチポートなんで~いきなりIPアドレスって言われてもってなってるんです。

 

L3スイッチのインターフェースは、デフォルトでスイッチポートになっているので、ルーテッドポートにしたい場合は、『routedport』と打ち込みたいところですが、no switchportと投入するのが正解です。これにより、インターフェースにIPアドレスの設定ができるようになるはずです。それでは設定していきましょう。

 

SW1(config)#interface FastEthernet0/1

SW1(config-if)#no switchport

SW1(config-if)#ip address 10.10.1.1 255.255.255.0

 

これで、ルーテッドポートとしてIPアドレスの設定ができました。通常のルータにIPアドレスを設定するより、ひと手間増えましたが、それほど難しくはないですよね?

 

スイッチポート

次にスイッチポートの設定を入っていこうと思います。

 

アクセスポート

それでは、アクセスポートの設定について学んでいきたいと思います。アクセスポートとして使用する場合、流せるVlanは1つだけとなります。今回は、Vlan10IPアドレス『10.10.10.1/24』を設定して、インターフェイスに紐付けてみたいと思います。

 

SW1(config)#vlan 10

SW1(config)#interface vlan 10

SW1(config-if)#ip address 10.10.10.1 255.255.255.0

SW1(config-if)#!

SW1(config-if)#interface FastEthernet0/2

SW1(config-if)#switchport mode access

SW1(config-if)#switchport access vlan 10

 

このようにして、Vlan10という仮想インターフェイスを作成して、関連付けさせることで物理インターフェース(FastEthernet0/2)にIPアドレスを持たせることが出来るようになりました。先程のルーテッドポートにIPアドレスを設定するより、もうひと手間増えましたね。

 

トランクポート

最後にトランクポートの設定をしていきたいと思います。ここでは、Vlan20と30の2つのVlanを物理のインターフェースに適用させてみたいと思います。使用するIPアドレスは、それぞれVlan20が『10.10.20.1/24Vlan30が『10.10.30.1/24としておきます。

 

 

SW1(config)#vlan 20

SW1(config-vlan)#vlan 30

SW1(config-vlan)#interface vlan 20

SW1(config-if)#ip address 10.10.20.1 255.255.255.0

SW1(config-if)#!

SW1(config)#interface vlan 30

SW1(config-if)#ip address 10.10.30.1 255.255.255.0

SW1(config-if)#!

SW1(config-if)#interface FastEthernet0/3

SW1(config-if)#switchport trunk encapsulation dot1q

SW1(config-if)#switchport mode trunk

SW1(config-if)#switchport trunk allowed vlan 20,30

 

VlanにIPアドレスを設定するのは、先程のアクセスポートと同じなので簡単ですね。次に物理のインターフェース設定で、最初に行うのが、トラッキングプロトコルの指定です。前回の授業でも紹介しましたが、トランクポートとして使用する際に指定できるプロトコルはISLIEEE802.1Qの2種類があります。今回は、IEEE802.1Qを使って設定しています。

 

その後にスイッチポートを『アクセスポート』で使用するか、『トランクポート』で使用するかを定義します。アクセスポートでも同じようなコマンドで指定していましたが、今回は、明示的にswitchport mode trunkと入れましょう。と言うのは、スイッチポートのデフォルトは、『アクセスポート』であるため、上記のコマンドを入れないと使えません。

 

その後、物理のインターフェースで流すべきVlanをswitchport trunk allowed vlan 20,30で指定します。指定しない場合、作成しているすべてのVlanが流れてしまいますので、セキュリティ上よくありません。必ず指定するようにしましょう。これで、Vlan20と30だけが流れるようになりましたね!それでは、設定内容の確認をしていきたいと思います。

 

ステータス確認

今回のステータス確認で使用するコマンドは以下です。

 

 

これらのコマンドで確認していきたいと思います。授業の結果を見るだけでなく、実際に構成を組んでコマンドを入力して確認してみましょうね。今回は、それぞれのインターフェイスのリンクを上げるために、別のスイッチと接続しています。また、トランクポートは、同じトラッキングプロトコルで他のスイッチと接続しています。

 

show ip interface brief

まずは、基本的な確認として、show ip interface briefで、インターフェースのステータス確認をします。ただし、今回は確認はUP/UPであることを確認するだけでなく、インターフェースに設定されているIPアドレスまでしっかり確認していきましょう。

 

SW1#show ip interface brief
Interface                 IP-Address      OK?  Method  Status                        Protocol
Vlan1                      unassigned     YES  NVRAM   administratively down down
Vlan10                    10.10.10.1     YES  manual   up                              up
Vlan20                    10.10.20.1     YES  manual   up                              up
Vlan30                    10.10.30.1     YES  manual   up                              up
FastEthernet0/1       10.10.1.1       YES  manual   up                             up
FastEthernet0/2       unassigned     YES  unset      up                              up
FastEthernet0/3       unassigned     YES  unset      up                              up
FastEthernet0/4       unassigned     YES  unset      down                          down
FastEthernet0/5       unassigned     YES  unset      down                          down
FastEthernet0/6       unassigned     YES  unset      down                          down
FastEthernet0/7       unassigned     YES  unset      down                          down
FastEthernet0/8       unassigned     YES  unset      down                          down
GigabitEthernet0/1   unassigned     YES  unset      down                          down

 

スイッチポートで使用しているインターフェイスにはIPアドレスは表示されず、指定したVlanインターフェイスにIPアドレスが設定されていることもポイントとなります!覚えておきましょうね!!

show vlan

次にshow vlanですね。ここでは、アクセスポートとして使用されている物理インターフェースにおけるVlan設定が確認できます。今回では、FastEthernet0/2をアクセスポートとして使用しており、Vlan20を割り当てました。想定通りに割り当てられているかを確認していきましょう。

 

SW1#show vlan

VLAN  Name                                  Status    Ports
——- ——————————– ——— ——————————-
1        default                                 active    Fa0/4, Fa0/5, Fa0/6, Fa0/7
                                                                 Fa0/8, Gi0/1
10      VLAN0010                          active    Fa0/2
20      VLAN0020                            active
30      VLAN0030                            active

・・・

 

上記のように表示されていれば問題ないですね。

show interface trunk

最後にshow interface trunkトランクポートで割り当てたVlan2030がちゃんと割り当てられていることを確認しましょう。今回、確認すべきインターフェースはFastEthernet0/3でしたね。どうなているでしょうか?

 

SW1#show interfaces trunk

Port      Mode          Encapsulation     Status        Native vlan
Fa0/3    on              802.1q               trunking    1

Port      Vlans allowed on trunk
Fa0/3    20,30

Port      Vlans allowed and active in management domain
Fa0/3    20,30

Port      Vlans in spanning tree forwarding state and not pruned
Fa0/3    20,30

 

トランクで使用しているインターフェース(FastEthernet0/3)にVlan20と30がアサインされていることが確認出来ればOKですね。「あれ?なんか右上にいますね。Native Vlanが『1って表示されているけど・・・これなんだろう?」思われた方もいるかと思います。通常のVlanであればVlan10や20などの『タグ』というものが付けられているですが、『タグ』のついていないパケットが流れてきた時に使用されるVlanのことをNative Vlanと言います。

 

このようにタグの付かないNative Vlanを各トランクポートに必ず1つだけ指定することが出来ます。指定しない場合は、デフォルトで『Vlan1』がNative Vlanとして設定されます。そのためスイッチの設計をする場合、Vlanはあまり使わないようにしておくことが大切となりますので、覚えておきましょう。

 

 

まとめ

ベル

今回の授業はいかがでしたか?意外と知らずにスイッチポートを使っていると、落とし穴にはまってしまうことがありますので、今回の授業でしっかり理解しておきましょうね。

 

Catalyst 3560-8PC-S

CISCO Catalyst 3560-8PC-S マルチレイヤ イーサネット PoE対応 スイッチ WS-C3560-8PC-S

新品価格

¥74,547から
(2019/2/8 23:11時点)

 

商品紹介 ~ネットワークエンジニアなら読んでおきたい本~

商品紹介 ~ネットワークエンジニアなら読んでおきたい本~

 

スパニングツリーの概要

スパニングツリーの概要 ~基礎編①~

スパニングツリーの概要 〜基礎編②(STP)~

スパニングツリーの概要 ~基礎編③(RSTP)~

スパニングツリーの概要 〜設定編〜

 

 

Follow me!

インターフェース設定 ~ルーテッドポートとスイッチポート~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です