BGPの設定 ~LOCAL_PREFアトリビュート編

ベル

今回の授業は、WEIGHTアトリビュートで経路制御」で勉強してみたいと思います。ここまでは、ただネイバーを確立してルートを配布しただけでしたので、意図した経路になるように制御していきたいと思います。

 

BGPの設定編!

BGPの設定 ~eBGP編~

BGPの設定 ~iBGP編①~

BGPの設定 ~iBGP編②~

BGPの設定 ~iBGP編③~

BGPの設定 ~eBGP&iBGPの組合せ編~

BGPの設定 ~WEIGHTアトリビュート編~

 

お勉強構成

それでは、お勉強構成を紹介させていただきます。今回、iBGPとeBGPの両方を使ってみたいと思います。

 

 

Cisco 1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格

¥4,880から
(2019/1/16 23:54時点)

 

事前設定

それでは、事前設定をしていきます。前回と比べると1台多い4台構成で組んでみるので、お勉強構成図を見ながらインターフェース設定をしていきましょう。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

!

RT1(config-if)#interface FastEthernet1

RT1(config-if)#ip address 10.10.3.1 255.255.255.0

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip address 10.10.2.2 255.255.255.0

!

RT2(config-if)#interface FastEthernet1

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

 

【RT3】

RT3(config)#interface FastEthernet0/0

RT3(config-if)#ip address 10.10.3.3 255.255.255.0

!

RT3(config-if)#interface FastEthernet0/1

RT3(config-if)#ip address 10.10.4.3 255.255.255.0

 

【RT4】

RT4(config)#interface GigabitEthernet1/0/1

RT4(config-if)#ip address 10.10.2.4 255.255.255.0

!

RT4(config-if)#interface GigabitEthernet1/0/2

RT4(config-if)#ip address 10.10.4.4 255.255.255.0

 

 

BGPの設定

それでは、BGPの設定をしていきましょう。今までの授業をちゃんと受けられている方であれば、簡単にできそうですね。それでは設定していこうと思います。

 

BGP-TCP/IPルーティングとオペレーションの実際

BGP―TCP/IPルーティングとオペレーションの実際

新品価格

¥4,536から
(2019/1/26 00:28時点)

 

ネイバー設定

まずは、4台のルータで構成図に合わせてネイバー設定をしていこうと思います。今回は、接続で使用している物理インターフェースのIPアドレスを指定してネイバーを確立したいと思います。

 

【RT1】

RT1(config)#router bgp 100

RT1(config-router)#neighbor 10.10.1.2 remote-as 200

RT1(config-router)#neighbor 10.10.3.3 remote-as 200

 

【RT2】

RT2(config)#router bgp 200

RT2(config-router)#neighbor 10.10.1.1 remote-as 100

RT2(config-router)#neighbor 10.10.2.4 remote-as 200

 

【RT3】

RT3(config)#router bgp 200

RT3(config-router)#neighbor 10.10.3.1 remote-as 100

RT3(config-router)#neighbor 10.10.4.4 remote-as 200

 

【RT4】

RT4(config)#router bgp 200

RT4(config-router)#neighbor 10.10.2.2 remote-as 200

RT4(config-router)#neighbor 10.10.4.3 remote-as 200

 

これで、それぞれのネイバーが確立されているはずです。ここでは確認結果を割愛しますが、show ip bgp neighborsコマンドで確認しておきましょう。

ルート配布

それではルート配布をしていきたいと思います。今回は、ルータ1Loopbackインターフェイスのアドレスだけを配布します。ルータ2とルータ3でルートが受け取れていればOKですね!ただしiBGPの構成も組んでいるので、network xx.xx.xx.xx mask yy.yy.yy.yyだけでなく、 neighbor zz.zz.zz.zz next-hop-selfの設定も忘れずにしましょう。

 

【RT1】

RT1(config)#router bgp 100

RT1(config-router)#network 10.1.1.1 mask 255.255.255.255

 

【RT2】

RT2(config)#router bgp 200

RT2(config-router)#neighbor 10.10.2.4 next-hop-self

 

【RT3】

RT3(config)#router bgp 200

RT3(config-router)#neighbor 10.10.4.4 next-hop-self

 

LOCAL_PREFアトリビュート設定

それでは、LOCAL_PREFアトリビュートの設定をしていきましょう。設定する対象機器はルータ2となります。最初のお勉強構成にも書きましたが、ルータ2を経由するルートに『200』のLOCAL-PREF値を付けるようにします。ちなみにデフォルト値『100』ですので、『200』の値を持つルータ2が優先されるようになります。設定の方法は2種類あり、まずは、簡単な方からいきます。

 

全ルートにかける方法

全てのルートに対してLOCAL_PREF値を変更したい場合、『router bgp xxx』の中に『bgp default local-preference xxx』設定することでデフォルトの値『100』から変更することが出来ます。これにより、指定したネイバーから受け取る全てのルートに対してLOCAL_PREFの値を付与することが出来ます。具体的な設定は以下通りです。

 

【RT2】

RT2(config)#router bgp 200

RT2(config-router)#bgp default local-preference 200

 

 

個別ルートにかける方法

次が複数のルートに対して、通信経路を振り分けたい場合などに使用する方法です。ここで設定する仕組みとしては、まずACL(Access Control List)で対象となるセグメント(ルータ1のLoopback0のセグメント)を指定します。次にループマップで先に作成したACLに対してLOCAL-PREF値(200)を関連付けます。そのループマップをそれぞれのBGPネイバーに対して指定するのです。具体的な設定は以下通りです。

 

【RT2】

RT2(config)#access-list 1 permit 10.1.1.1 0.0.0.0

!

RT2(config)#route-map LOCAL-PREF permit 10

RT2(config-route-map)#match ip address 1

RT2(config-route-map)#set local-preference 200

!

RT2(config-route-map)#route-map LOCAL-PREF permit 20

!

RT2(config-route-map)#router bgp 200

RT2(config-router)#neighbor 10.10.2.4 route-map LOCAL-PREF out

 

 

 

ステータス確認

それでは、ステータス確認をしていきたいと思います。今回は、show ip bgpshow ip routeで確認していこうと思います。

 

【RT4】

RT4#show ip bgp
BGP table version is 5, local router ID is 10.10.4.4
        Network         Next Hop         Metric   LocPrf   Weight   Path
*  i   10.1.1.1/32   10.10.4.3                0      100          0    100 i
* >i                       10.10.2.2                0      200          0    100 i

 

ここでで、『LOCAL-PREF』値が200に変更されていることが確認出来ましたでしょうか?ここの値が大きい方が優先されるはずですので、次のルーティングテーブルで確認してみましょう。

 

RT4#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
B 10.1.1.1/32 [200/0] via 10.10.2.2, 00:00:06
C 10.10.2.0/24 is directly connected, GigabitEthernet1/0/1
L 10.10.2.4/32 is directly connected, GigabitEthernet1/0/1
C 10.10.4.0/24 is directly connected, GigabitEthernet1/0/2
L 10.10.4.4/32 is directly connected, GigabitEthernet1/0/2

 

10.1.1.1/32』のネクストホップが『10.10.2.2』になっていることが確認できますでしょうか?つまりルータ2経由が優先になっているということです。想定通りの結果になりましたね!

 

まとめ

ベル

今回の授業は、LOCAL-PREFアトリビュートで経路制御」について教えてみましたがいかがでしたか?僕の経験上では、LOCAL-PREFアトリビュートでのルート制御は、実際にも多く使われていると思います。しっかり学んでおきましょうね!

 

その他のルーティング

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの設定 ~基礎編~

OSPFの概要 ~基礎編①~

OSPFの設定 ~シングルエリア編①~

BGPの概要 ~基礎編①~

BGPの設定 ~eBGP編~

 

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です