BGPの設定 ~WEIGHTアトリビュート編~

ベル

今回の授業は、WEIGHTアトリビュートで経路制御」で勉強してみたいと思います。ここまでは、ただネイバーを確立してルートを配布しただけでしたので、意図した経路になるように制御していきたいと思います。

 

BGPの授業!

BGPの概要 ~基礎編①~

BGPの概要 ~基礎編②~

BGPの概要 ~基礎編③~

BGPの概要 ~基礎編④~

BGPの設定 ~eBGP編~

BGPの設定 ~iBGP編①~

BGPの設定 ~iBGP編②~

BGPの設定 ~iBGP編③~

BGPの設定 ~eBGP&iBGPの組合せ編~

 

 

お勉強構成

それでは、今回のお勉強構成を紹介していきます。2つの経路を作って、WEIGHTで経路を決めてみたいと思います。

 

 

Cisco 1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2019/1/16 23:54時点)

 

上の構成を見てもらえばわかるかと思いますが、基本的にはeBGPの設定さえ理解していれば、出来ると思いますので、忘れてしまった方は、きちんと思い出しておきましょうね。

 

事前設定

それでは、事前設定をしていきます。今回は、インターフェースの設定をしておきたいと思います。お勉強構成を見ながら設定していきましょう。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

!

RT1(config-if)#interface FastEthernet1

RT1(config-if)#ip address 10.10.3.1 255.255.255.0

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip address 10.10.2.2 255.255.255.0

!

RT2(config-if)#interface FastEthernet1

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

 

【RT3】

RT3(config)#interface FastEthernet0/0

RT3(config-if)#ip address 10.10.3.3 255.255.255.0

!

RT3(config-if)#interface FastEthernet0/1

RT3(config-if)#ip address 10.10.2.3 255.255.255.0

 

 

eBGPの設定

eBGPの設定をしていきましょう。今までの授業をちゃんと受けられている方であれば、簡単にできそうですね。それでは設定していこうと思います。

 

ネイバー設定

まずは、3台のルータで構成図に合わせてネイバー設定をしていこうと思います。今回は、接続で使用している物理インターフェースのIPアドレスを指定してネイバーを確立したいと思います。

 

【RT1】

RT1(config)#router bgp 100

RT1(config-router)#neighbor 10.10.1.2 remote-as 200

RT1(config-router)#neighbor 10.10.3.3 remote-as 300

 

【RT2】

RT2(config)#router bgp 200

RT2(config-router)#neighbor 10.10.1.1 remote-as 100

RT2(config-router)#neighbor 10.10.2.3 remote-as 300

 

【RT3】

RT3(config)#router bgp 300

RT3(config-router)#neighbor 10.10.3.1 remote-as 100

RT3(config-router)#neighbor 10.10.2.2 remote-as 200

 

 

ルート配布

それではルート配布をしていきたいと思います。今回は、ルータ1のLoopbackインターフェイスのアドレスだけを配布します。ルータ2とルータ3でルートが受け取れていればOKですね!

 

【RT1】

RT1(config)#router bgp 100

RT1(config-router)#network 10.1.1.1 mask 255.255.255.255

 

ここまでは、過去の授業で学んできたことだけで設定できると思います。これ以降が新しい設定になっていきます。

 

WEIGHTアトリビュート設定

それでは、WEIGHTアトリビュートの設定をしていきましょう。設定する対象機器はルータ3となります。最初のお勉強構成にも書きましたが、ルータ2を経由するルートに『200』のWEIGHTを、直接ルータ1に向かうルートに『100』のWEIGHTを付けるようにします。設定の方法は2種類あり、まずは、簡単な方からいきます。

 

全ルートにかける方法

全てのルートをルータ2に寄せたい場合、neighbor に直接weightを付けて指定します。これにより、指定したネイバーから受け取る全てのルートに対してWEIGHTを付けることが出来ます。具体的な設定は以下通りです。

 

【RT3】

RT3(config)#router bgp 300

RT3(config-router)#neighbor 10.10.2.2 weight 200

RT3(config-router)#neighbor 10.10.3.1 weight 100

 

このように設定することで、全ての通信をルータ3経由にすることが出来ます。簡単で分かりやすい設定ですね!

 

個別ルートにかける方法

次が複数のルートに対して、通信経路を振り分けたい場合などに使用する方法です。ここで設定する仕組みとしては、まずACL(Access Control List)で対象となるセグメント(ルータ1のLoopback0のセグメント)を指定します。次にループマップで先に作成したACLに対してWEIGHTを紐づけて、ACL名を設定します。そのループマップをそれぞれのBGPネイバーに対して指定するのです。具体的な設定は以下通りです。

 

【RT3】

RT3(config)#access-list 1 permit 10.1.1.1 0.0.0.0

!

RT3(config)#route-map WEIGHT-RT1 permit 10

RT3(config-route-map)#match ip address 1

RT3(config-route-map)#set weight 100

!

RT3(config)#route-map WEIGHT-RT1 permit 20

!

RT3(config)#route-map WEIGHT-RT2 permit 10

RT3(config-route-map)#match ip address 1

RT3(config-route-map)#set weight 200

!

RT3(config)#route-map WEIGHT-RT2 permit 20

!

RT3(config)#router bgp 300

RT3(config-router)#neighbor 10.10.2.2 route-map WEIGHT-RT2 in

RT3(config-router)#neighbor 10.10.3.1 route-map WEIGHT-RT1 in

 

通信の重要度やトラフィック量などに応じて通信の経路を分散したいケースが多いので、比較的、分散出来るような設定をしておくのが無難です。これにより、ルータ3から見えるルータ1のLoopback0のアドレスがルータ2に向いていることが確認出来るはずです。

 

ステータス確認

それでは、ステータス確認をしていきます。今回、使用するコマンドを『show bgp』『show ip route』となります。うまく指定できていれば問題ありません。

 

【RT3】

RT3#show ip bgp
BGP table version is 2, local router ID is 10.10.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
                    r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

      Network             Next Hop                   Metric LocPrf    Weight   Path
*     10.1.1.1/32      10.10.3.1                   0                     100       100 i
*>                          10.10.2.2                                          200      200 100 i

 

ここで、ネクストホップが10.10.2.2に向いていることが、『>』で表現されていることがわかりますか?続いてルーティングテーブルも確認しておきましょう。以下のようなログになっていれば問題ないですね。

 

【RT3】

RT3#show ip route

      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C         10.10.2.0/24 is directly connected, FastEthernet0/1
C         10.10.3.0/24 is directly connected, FastEthernet0/0
B         10.1.1.1/32 [20/0] via 10.10.2.2, 00:21:58

 

まとめ

ベル

今回の授業はここまでとします。いかがでしたでしょうか?WEIGHTアトリビュートを使って通信経路を変えてみました。次回以降もアトリビュートを使って通信経路を変えてみたいと思いますので、ここまでの内容をしっかり理解しておきましょう!

 

BGP-TCP/IPルーティングとオペレーションの実際

BGP―TCP/IPルーティングとオペレーションの実際

新品価格
¥4,536から
(2019/1/26 00:28時点)

 

 

その他のルーティング

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

OSPFの概要 ~基礎編①~

OSPFの設定 ~シングルエリア編①~

BGPの概要 ~基礎編①~

BGPの設定 ~eBGP編~

 

 

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です