DHCPの設定 ~DHCPリレー編~

ベル

今回の授業は、DHCPリレーの設定」について教えていこうと思います。以前の授業でCiscoルータでDHCPサーバを構築」を教えましたが、別のセグメントにDHCPサーバがあった場合、どのような設定をルータで設定すればよいのかを学んでもらおうと思います。以前のCiscoルータでDHCPサーバを構築」を受けていない方は、こちらから。

 

DHCPの授業

DHCPの概要 ~基礎編①~

DHCPの設定 ~サーバ構築編~

 

 

お勉強構成

前回と異なるのは、DHCPサーバの設定が入っているルータです。前回は、ルータ2でDHCP設定を投入しましたが、今回は、ルータ1をDHCPサーバにしてみたいと思います。前回の授業を思い出しながら進めてもらえればと思います。

 

 

 

 

事前設定

それでは、事前設定をしていきたいと思います。いつも通りインターフェース設定をするのと、ルーティング設定をしていきたいと思います。ルーティングの設定は、EIGRPで設定してみたいと思います。設定の仕方が分からない方は、こちらの授業で復習しておいてください。

EIGRPの概要 ~設定編①~

EIGRPの設定 ~基礎編~

 

CISCO 1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格

¥4,880から
(2018/9/28 20:19時点)

 

 

インターフェイス設定

まずは、インターフェイスの設定からですね。お勉強構成を確認しながら設定していきましょう。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

!

RT2(config)#interface vlan 10

RT2(config-if)#ip address 10.1.100.254 255.255.255.0

!

RT2(config-if)#interface fastEthernet 2

RT2(config-if)#switchport access vlan 10

 

ここまではOKですか?それでは、次に進みますよ。

 

ルーティング設定

それでは、ルーティング設定に入っていきます。今回は、全てのルートをEIGRPで動的に学習できるようにしていきましょう。

 

【RT1】

RT1(config)#router eigrp 10

RT1(config-router)#no auto-summary

RT1(config-router)#network 10.0.0.0 0.255.255.255

 

【RT2】

RT2(config)#router eigrp 10

RT2(config-router)#no auto-summary

RT2(config-router)#network 10.0.0.0 0.255.255.255

 

これでネットワーク機器間の疎通が出来るようになりました。ステータス確認をしておきたいところですが、今回は、DHCPサーバからアドレスが取れていることを確認したいので、もう少し進めておきたいと思います。

 

DHCPサーバの設定

それでは、DHCPサーバの設定をしていきます。設定している内容は、前回の設定と同じになりますので、以下のパラメータを見て設定してください。設定内容が分からない方は、以前のDHCPの設定 ~サーバ構築編~』を読んで復習しましょう。

 

 

今回の授業では、ルータ1をDHCPサーバにするので間違えないようにしましょうね。

 

【RT1】

RT1(config)#service dhcp

RT1(config)#ip dhcp pool dhcp-test

RT1(dhcp-config)#network 10.1.100.0 255.255.255.0

RT1(dhcp-config)#default-router 10.1.100.254

RT1(dhcp-config)#dns-server 10.10.10.1

RT2(dhcp-config)#ip dhcp excluded-address 10.1.100.254

 

ここまでの設定を見ると、前回の授業と変わりないように思われるかもしれませんが、DHCPサーバの位置をルータ2からルータ1しただけで大きな影響があります。それは、DHCPサーバの問い合わせ方法にあります。パソコンがDHCPサーバに自分のアドレスを問い合わせる時は、自分が接続しているセグメントに対して、ブロードキャストアドレスして問い合わせます。そのLAN内にDHCPサーバがあれば応答してくれますが、なければDHCPの問い合わせは破棄されてしまいます。

 

今回は、DHCPサーバをルータ1に変更してしまったため、パソコンと同じセグメント(10.1.100.0/24)にいません。そのため、このままではDHCPサーバに問合せすることが出来なくなってしまいますので、一工夫する必要があります。以下の設定をルータ2に入れてください。この設定によってVlan10DHCPの問い合わせパケットを『10.1.1.1』に転送してくれるようになります。

 

【RT2】

RT2(config)#interface vlan 10

RT2(config-if)#ip helper-address 10.1.1.1

 

DHCPでIPアドレス取得

これでDHCPの設定は完了です。実際にパソコンを接続してみてIPアドレスが払い出されていたら完了です。Windowsのコマンドプロンプトでipconfig /allと入力してIPアドレス、サブネットマスク、デフォルトゲートウェイ、DHCPサーバなどのアドレスが表示されていればOKとなります。

 

今回は、前回の構成に追加して、L3SWもDHCPクライアントに追加して確認してみたいと思います。お勉強構成を以下の通りに変更してみたいと思います。L3SWに設定するコマンドは以下になります。

 

 

 

【SW1】

interface FastEthernet0/1

ip address dhcp

 

これだけです。この設定をしてRT2のFastEthernet2に接続すると、IPアドレスが取得できるようになっています。show ip interface briefコマンドで確認すると以下のように表示されるはずです。

 

【SW1】

SW1#show ip interface brief
Interface                IP-Address  OK?    Method   Status  Protocol
Vlan1                     unassigned   YES   NVRAM   up       down
FastEthernet0/1   10.1.100.1   YES   DHCP     up        up
FastEthernet0/2     unassigned   YES   unset      down   down

・・・

 

このFastEthernet0/1のMethodが、DHCPと表示されているのがポイントです。このようにネットワーク機器もDHCPでIPアドレスを取得することが可能となります。もちろんDHCPサーバで設定していたデフォルトゲートウェイも配布されているので、ルーティングテーブルにも表示されています。確認して、ルータ1のLoopbackインターフェイス(10.1.1.1)にも疎通確認してみましょう。

 

【SW1】

SW1#show ip route

・・・

Gateway of last resort is 10.1.100.254 to network 0.0.0.0

10.0.0.0/24 is subnetted, 1 subnets
C 10.1.100.0 is directly connected, FastEthernet0/1
S* 0.0.0.0/0 [254/0] via 10.1.100.254
SW1#ping 10.1.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms

 

このルーティングテーブルに表示されている『S* 0.0.0.0/0 [254/0] via 10.1.100.254』は設定した内容ではなく、DHCPサーバから配布されたルーティングになります。そのため『show running-config』には表示されませんので、確認してみてください。

 

 

 

まとめ

ベル

今回の授業は、いかがでしたか?DHCPサーバの位置をずらすことで、ブロードキャストパケットは届かなくなってしまいます。そのため、HDCPサーバにブロードキャストパケットを転送するための設定をしてみました。実際の現場では、各拠点のパソコンに対してセンタの設置したサーバからIPアドレスを払い出すことが出来るようになりました。

 

コンソールケーブル

【CISCO互換ケーブル】FTDI chipset USB RJ45 コンソールケーブル

新品価格

¥1,130から
(2018/9/28 20:18時点)

 

 

EIGRPの授業

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~基礎編②~

EIGRPの概要 ~基礎編③~

EIGRPの概要 ~基礎編④~

EIGRPの設定 ~基礎編~

EIGRPの設定 ~ルート制御編~

EIGRPの設定 ~メトリック制御編~

 

 

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です