BGPの設定 ~eBGP&iBGPの組合せ編~

ベル

今回の授業は、「eBGPとiBGPを組合せた構成」で勉強してみたいと思います。今までの「eBGP編」と「iBGP編」を思い出しながら勉強していきましょう。忘れてしまった方は、以下の授業を読み返してみてください。

 

BGPの授業!

BGPの概要 ~基礎編①~

BGPの概要 ~基礎編②~

BGPの概要 ~基礎編③~

BGPの概要 ~基礎編④~

BGPの設定 ~eBGP編~

BGPの設定 ~iBGP編①~

BGPの設定 ~iBGP編②~

BGPの設定 ~iBGP編③~

 

 

お勉強構成

今回の授業では、「eBGP」「iBGP」の両方を扱っていきますので、以下のような構成を組んでみたいと思います。

 

 

今回は、あまり難しい構成にせず、単純にeBGPで受け取ったルートをiBGPに配布してみたら、どのように見えるのか?を確認して言いたいと思います。

 

Cisco 1812J

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2019/1/16 23:54時点)

事前設定

それでは、BGPの設定をしていく前に事前の設定をしていきたいと思います。今回は、インターフェイスの設定だけとなりますので、お勉強構成を見ながら設定していきましょうね!

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface Loopback1

RT1(config-if)#ip address 1.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

【RT2】

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

!

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

 

【RT3】

RT3(config)#interface Loopback0

RT3(config-if)#ip address 10.1.1.3 255.255.255.255

!

RT3(config-if)#interface Loopback1

RT3(config-if)#ip address 3.3.3.3 255.255.255.255

!

RT3(config)#interface FastEthernet0/0

RT3(config-if)#ip address 10.10.2.3 255.255.255.0

 

ここまでは、基本的な設定ですので問題なくできたと思います。次のBGPの設定に入っていきますよ。

 

ルーティングの設定

それでは、BGPの設定をしていこうと思いますが、以前の授業で設定していた内容と基本的には一緒です。「eBGP設定」と「iBGP設定」を組み合わせて設定できればOKですが、今回は、Loopbackインターフェイスをネイバー確立するIPアドレスとして使用してみたいと思います。そのため、事前設定にスタティックルートを設定しておきたいと思います。スタティックルートの設定を忘れてしまった方は、こちらから。

 

静的ルーティング(スタティックルート) ~設定編~

静的ルーティング(スタティックルート) ~設定編①~

 

スタティックルートの設定

スタティックルートの設定は、「ip route network-address subnet-mask nexthop-address(interface)でしたね。これをそれぞれのルータに設定していきたいと思います。

 

【RT1】

RT1(config)#ip route 10.1.1.2 255.255.255.255 10.10.1.2

 

【RT2】

RT2(config)#ip route 10.1.1.1 255.255.255.255 10.10.1.1
RT2(config)#ip route 10.1.1.3 255.255.255.255 10.10.2.3

 

【RT3】

RT3(config)#ip route 10.1.1.3 255.255.255.255 10.10.2.2

 

ここまで出来たらOKです。BGPの設定に入っていきますよ。

 

eBGPの設定

それでは、まずルータ1から設定していきます。ルータ1は、AS100に属しており、ネイバーはルータ2のAS200と確立する必要があります。

 

【RT1】

RT1(config)#router bgp 100

RT1(config-router)#neighbor 10.1.1.2 remote-as 200

 

【RT2】

RT2(config)#router bgp 200

RT2(config-router)#neighbor 10.1.1.1 remote-as 100

 

ここまで設定出来たらBGPでネイバー確立出来ているかを簡易確認しておきましょう。一番簡単に確認出来るコマンドは「show ip bgp summary」です。

 

【RT1】

RT1#show ip bgp summary
BGP router identifier 10.1.1.1, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor   V   AS   MsgRcvd   MsgSent     TblVer   InQ   OutQ   Up/Down   State/PfxRcd
10.1.1.2    4  200             0             0             1      0         0    never         Idle

 

Up/Downの状態が『never』になっていることが分かりますか?これは、ネイバーが確立されていないことを意味します。ルータ2も確認してもらえばわかりますが、ルータ1と同様、ネイバーが確立されていないはずです。これには、2つに理由があります。1つは、BGPでネイバー接続しようとする場合、接続している物理インターフェースでネイバーを確立しようとしてしまうため、今回のようなLoopbackインターフェイス使うには、『update-source』に続けて使用するインターフェースを指定する必要があります。これは、『eBGP』でも『iBGP』でも同様になります。

 

もう1つに理由は、eBGPのネイバー確立で使用されるメッセージパケットのTTLは『1』となっているため、物理インターフェースではなくLoopbackインターフェイスなどを使用する場合は、『ebgp-multihop』コマンドでTTLの値を変更する必要があります。今回は、『2』に変更してみたいと思います。これは、『ebgp』でのみ使用するコマンドとなります。

 

【RT1】

RT1(config)#router bgp 100

RT1(config-router)#neighbor 10.1.1.2 update-source loopback 0

RT1(config-router)#neighbor 10.1.1.2 ebgp-multihop 2

 

【RT2】

RT2(config)#router bgp 200

RT2(config-router)#neighbor 10.1.1.1 update-source loopback 0

RT2(config-router)#neighbor 10.1.1.1 ebgp-multihop 2

 

これで、ルータ1~ルータ2間のeBGP接続が出来るようになったはずです。一旦、ステータス確認は後に回して、次の設定に進めていきたいと思います。

 

iBGPの設定

続いてルータ2~ルータ3間のiBGPネイバーを確立させていきたいと思います。先程のeBGPの設定と基本的には一緒で、『ebgp-multihop 2』の設定が不要となるだけです。

 

【RT2】

RT2(config)#router bgp 200

RT2(config-router)#neighbor 10.1.1.3 remote-as 200

RT2(config-router)#neighbor 10.1.1.3 update-source loopback 0

 

【RT3】

RT3(config)#router bgp 200

RT3(config-router)#neighbor 10.1.1.2 remote-as 200

RT3(config-router)#neighbor 10.1.1.2 update-source loopback 0

 

 

ルートの配布

それでは、ルータ1とルータ3のLoopback1のセグメントをBGPに配布してみたいと思います。『network』コマンドで配布したいセグメントを指定します。

 

【RT1】

RT1(config)#router bgp 100

RT1(config-router)#network 1.1.1.1 mask 255.255.255.255

 

【RT3】

RT3(config)#router bgp 200

RT3(config-router)#network 3.3.3.3 mask 255.255.255.255

 

ここまでで設定は終了となります。想定通りのステータスになっているかを確認していきましょう。

 

ステータス確認

それでは、ステータス確認を行っていこうと思います。今回は、以下のコマンドを使っていこうと思います。

 

show ip bgp neighbors

まずは、BGPのネイバーがきちんと確立しているかを『show ip bgp neighbors』で確認してみたいと思います。以下のようなステータスになっていればOKです。

 

【RT1】

RT1#show ip bgp neighbors
BGP neighbor is 10.1.1.2, remote AS 200, external link
BGP version 4, remote router ID 10.1.1.2
BGP state = Established, up for 00:10:31

 

【RT2】

RT2#show ip bgp neighbors
BGP neighbor is 10.1.1.1, remote AS 100, external link
BGP version 4, remote router ID 10.1.1.1
BGP state = Established, up for 00:34:37

BGP neighbor is 10.1.1.3, remote AS 200, internal link
BGP version 4, remote router ID 10.1.1.3
BGP state = Established, up for 00:06:08

 

【RT3】

RT3#show ip bgp neighbors
BGP neighbor is 10.1.1.2, remote AS 200, internal link
BGP version 4, remote router ID 10.1.1.2
BGP state = Established, up for 00:04:52

 

show ip bgp summary

先程も使用しましたが、ネイバーが確立しているかだけを確認するのであれば、『show ip bgp summary』でも見れます。むしろ、見やすく加工されているので、こちらの方が分かりやすかったりもします。以下のように表示されていればOKですね!

 

【RT1】

RT1#show ip bgp summary
BGP router identifier 10.1.1.1, local AS number 100
BGP table version is 3, main routing table version 3

Neighbor   V   AS   MsgRcvd   MsgSent     TblVer   InQ   OutQ   Up/Down   State/PfxRcd
10.1.1.2   4  200           54            55            3       0        0   00:46:22             1

 

【RT2】

RT2#show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 200
BGP table version is 3, main routing table version 3

Neighbor   V   AS   MsgRcvd   MsgSent     TblVer   InQ   OutQ   Up/Down   State/PfxRcd
10.1.1.1    4  100           58            58            3         0      0   00:49:27            1
10.1.1.3    4  200           53            57            3         0      0   00:49:07            1

 

【RT3】

RT3#show ip bgp summary
BGP router identifier 10.1.1.3, local AS number 200
BGP table version is 2, main routing table version 2

Neighbor   V   AS   MsgRcvd   MsgSent     TblVer   InQ   OutQ   Up/Down   State/PfxRcd
10.1.1.2   4   200          61            56            2      0         0    00:52:19            1

 

show ip bgp

最後に『show ip bgp』でちゃんとルートを受け取れているかを確認しておきましょう。今回の構成では、ルータ1の『1.1.1.1/32』とルータ3の『3.3.3.3/32』をすべてのルータで受け取れていればOKです。

 

【RT1】

RT1#show ip bgp
BGP table version is 3, local router ID is 10.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
                    r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

    Network           Next Hop    Metric     LocPrf   Weight    Path
*> 1.1.1.1/32     0.0.0.0              0                  32768    i
*> 3.3.3.3/32     10.1.1.2                                        0   200 i

 

【RT2】

RT2#show ip bgp
BGP table version is 3, local router ID is 10.1.1.2
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
                    r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

    Network           Next Hop    Metric     LocPrf   Weight    Path
*> 1.1.1.1/32    10.1.1.1              0                          0   100 i
*>i3.3.3.3/32    10.1.1.3              0         100            0    i

 

【RT3】

RT3#show ip bgp
BGP table version is 2, local router ID is 10.1.1.3
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
                    r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

    Network           Next Hop    Metric     LocPrf   Weight    Path
*   i1.1.1.1/32     10.1.1.1            0        100            0    100 i
*> 3.3.3.3/32      0.0.0.0             0                  32768     i

 

ルートが想定通り受け取れていることが確認出来ましたか?いきなりルートを確認をしないで段階的に確認していくことが大切です。想定通りになっていない時に、切り分けが楽になると思いますよ。

 

まとめ

ベル

今回の授業は、ここまでとします。次回のBGPの授業からアトリビュートを使って経路を操作してみたいと思います。ここまでの設定をしっかりと理解しておくためにも、自分で構成を組んで練習しておきましょうね!次回は、WEIGHTアトリビュートについて学んでいきますよ!

 

BGPの設定 ~WEIGHTアトリビュート編~

BGPの設定 ~WEIGHTアトリビュート編

 

BGP-TCP/IPルーティングとオペレーションの実際

BGP―TCP/IPルーティングとオペレーションの実際

新品価格
¥4,536から
(2019/1/26 00:28時点)


その他のルーティング

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

OSPFの概要 ~基礎編①~

OSPFの設定 ~シングルエリア編①~

BGPの概要 ~基礎編①~

BGPの設定 ~eBGP編~

 

Follow me!

BGPの設定 ~eBGP&iBGPの組合せ編~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です