BGPの設定 ~iBGP編①~

ベル

今回の授業は、「iBGPの設定」について学んでいきます。iBGPで覚えなければいけない設定が多くあるので、3つに分けて学んでもらいます。今回は、前編となります。また、今までの授業を受けていないと、わからないこともあると思います。こちらも受講するようにしてくださいね!

 

BGPの概要 ~基礎編①~

BGPの概要 ~基礎編②~

BGPの概要 ~基礎編③~

BGPの概要 ~基礎編④~

BGPの設定 ~eBGP編~

 

お勉強構成

それでは、まずは勉強構成から見ていきましょう。今回は、iBGPのみの構成としますので、ゆっくり理解していきましょうね!

 

 

 

事前設定

それでは、BGPの設定をしていく前に事前の設定をしていきたいと思います。今回は、インターフェイスの設定だけとなりますので、お勉強構成を見ながら設定していきましょうね!

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

【RT2】

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

!

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

 

【RT3】

RT3(config)#interface Loopback0

RT3(config-if)#ip address 10.1.1.3 255.255.255.255

!

RT3(config)#interface FastEthernet0/0

RT3(config-if)#ip address 10.10.2.3 255.255.255.0

 

ここまでの設定は、前回のeBGPの授業と同じになります。サラッと出来ましたか?

 

BGPの設定

それでは、BGPの設定に入っていこうと思います。今回、設定するのは「ネイバー設定」「ルート配布」となります。ルート配布も基本的な設定のみを教えていきますので、まずは、ルートが配布できたことを確認していきましょう。

 

BGPネイバーの設定

まずは、ネイバー関係を確立するための設定をしていきます。前回の復習となりますが、BGPでネイバーを確立する時に使用するコマンドは、「neighbor x.x.x.x remote-as numでしたね?それでは、実際の投入するコマンドを見ていきましょう。

 

【RT1】

RT1(config)#router bgp 100

RT1(config-router)#neighbor 10.10.1.2 remote-as 100

 

【RT2】

RT2(config)#router bgp 100

RT2(config-router)#neighbor 10.10.1.1 remote-as 100

RT2(config-router)#neighbor 10.10.2.3 remote-as 100

 

【RT3】

RT3(config)#router bgp 100

RT3(config-router)#neighbor 10.10.2.3 remote-as 100

 

これでルータ1、ルータ2、ルータ3でネイバー関係が確立できたはずです。本来であれば、ここでネイバー関係の確認をしたいところですが、今回も続けてルートの配布までやってしまいます。

 

BGPでルート配布

次にネイバーに配布するルートを設定してみましょう。今回は、それぞれのルータのLoopback0インターフェイスのIPアドレスを配布してみたいと思います。ここで使用するのは「network x.x.x.x mask y.y.y.y」でしたね?eBGPの授業で学んだ設定でルート配布してみましょう。

 

【RT1】

RT1(config)#router bgp 100

RT1(config-router)#network 10.1.1.1 mask 255.255.255.255

 

【RT2】

RT2(config)#router bgp 100

RT2(config-router)#network 10.1.1.2 mask 255.255.255.255

 

【RT3】

RT3(config)#router bgp 100

RT3(config-router)#network 10.1.1.3 mask 255.255.255.255

 

これで各ルータのLoopback0インターフェイスのルートを配布出来るようになったはずです。

 

ステータスの確認

それでは、ステータス確認をしていこうと思います。今回、使用するコマンドは以下になります。(eBGPで学んだこともありますので、一部、コマンドは割愛してあります。)

 

 

show ip bgp summary

まずは、「show ip bgp summary」でネイバーを確認してみたいと思います。こちらも前回の授業で扱ったコマンドですので、さらっと見ていきますね。構成図通りにネイバー関係が確立していれば、以下のような出力結果になっているはずです。

 

【RT1】

RT1#show ip bgp summary
BGP router identifier 10.1.1.1, local AS number 100

Neighbor    V   AS   MsgRcvd  MsgSent  TblVer   InQ  OutQ  Up/Down  State/PfxRcd
10.10.1.2  4  100            8            8          7      0        0   00:03:11         2

 

【RT2】

RT2#show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 100

Neighbor    V   AS   MsgRcvd  MsgSent  TblVer   InQ  OutQ  Up/Down  State/PfxRcd
10.10.1.1   4  100          19          19         4       0       0   00:02:12          1
10.10.2.3   4  100            8            8         4       0       0   00:01:07          1

 

 

【RT3】

RT3#show ip bgp summary
BGP router identifier 10.1.1.2, local AS number 100

Neighbor    V   AS   MsgRcvd  MsgSent  TblVer   InQ  OutQ  Up/Down  State/PfxRcd
10.10.2.2  4   100            5           5          4      0       0   00:00:13          1

 

上記のようなステータスになっていないようでしたら、物理層から確認してみましょう。意外と物理接続が間違っていたりしますよ。今回は、授業が長くなってしまうこともあり物理層の確認は割愛しています。必要に応じて、「show cdp neighbor」、「show ip interface」、「show interface status」などで確認するようにしてください。

 

show ip bgp

次に「show ip bgp」コマンドを実行してみましょう。ここで確認できるのがBGPを通して配布されているルート情報になります。今回、各ルータのLoopback0インターフェイスのセグメントを配布するようにしましたね。これが各ルータで受け取れているかを確認しておきましょう。

 

【RT1】

RT1#show ip bgp
BGP table version is 4, local router ID is 10.1.1.1

Network               Next Hop           Metric  LocPrf  Weight  Path
*> 10.1.1.1/32   0.0.0.0                    0               32768  i
*> 10.1.1.2/32   10.10.1.2                0      100           0  i

 

ここで確認してみると、配布したはずの「10.1.1.3/32」のルートが受け取れていないことが分かりますね。eBGPの時は受け取れていたはずなのに、iBGPでは受け取れなくなっています。他のルータではどうでしょうか?ルータ2、ルータ3のステータスも確認してみましょう。

 

【RT2】

RT2#show ip bgp
BGP table version is 4, local router ID is 10.1.1.2

Network               Next Hop           Metric  LocPrf  Weight  Path
*> 10.1.1.1/32   10.10.1.1                0      100           0   i
*> 10.1.1.2/32   0.0.0.0                    0               32768   i
*> 10.1.1.3/32   10.10.2.3                0      100           0   i

 

ルータ2では、問題なく全てのルートが受け取れていますね。よかった、よかった。それでは、ルータ3は?

 

【RT3】

RT3#show ip bgp
BGP table version is 4, local router ID is 10.1.1.3

Network               Next Hop           Metric  LocPrf  Weight  Path
*> 10.1.1.2/32   10.10.2.2             0         100          0  i
*> 10.1.1.3/32   0.0.0.0                 0                 32768  i

 

やはり、ルータ3でもルータ1で生成した「10.1.1.1/32」のルートが受け取れていないですね。なんででしょうか?今までの授業をちゃんと受けている方は、そろそろ気付きますね。とりあえず、ルーティングテーブルの確認に進みましょう。

 

show ip route

それでは、ルーティングテーブルの確認をしましょう。ここでは、BGPで受け取ったルートに対してだけ確認していきます。

 

RT1#show ip route

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.1.1.1/32 is directly connected, Loopback0
B 10.1.1.2/32 [200/0] via 10.10.1.2, 00:08:34
C 10.10.1.0/24 is directly connected, FastEthernet0

 

【RT2】

RT2#show ip route

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.10.1.0/24 is directly connected, FastEthernet0
C 10.10.2.0/24 is directly connected, FastEthernet1
C 10.1.1.2/32 is directly connected, Loopback0
B 10.1.1.3/32 [200/0] via 10.10.2.3, 00:09:12
B 10.1.1.1/32 [200/0] via 10.10.1.1, 00:09:42

 

【RT3】

RT3#show ip route

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.10.2.0/24 is directly connected, FastEthernet0/0
B 10.1.1.2/32 [20/0] via 10.10.2.2, 00:10:47
C 10.1.1.3/32 is directly connected, Loopback0

 

やはり、先程の「show ip bgp」で確認した内容と同様で、ルータ1にはルータ3で生成したルートが、ルータ3にはルータ1で生成したルートが配布されていないことが確認できますね。理由はなんでしょうか?そろそろ答えを言いますね。それは、iBGPピアから受信したルートは、他のiBGPピアには伝搬させないというルールがあるからです。これによりルータ2は、iBGPピアであるルータ1から受信したルートをiBGPピアであるルータ3には配布しなかったのです。それでは、どうしたら配布してもらえるのでしょうか?それは、次回の授業で教えます。

 

まとめ

ベル

今回の授業は、iBGPのみの構成で解説してきて、まだ想定通りのルーティングにはなっておりませんが、長くなってしまったのでここまでにします。今までの授業で学んできてことだけで授業をしてきていますが、理解しきれていない方は、過去の授業を振り返ってみてください。きっと、理解できるはずですよ。

 

 

BGP-TCP/IPルーティングとオペレーションの実際

BGP―TCP/IPルーティングとオペレーションの実際

新品価格
¥4,536から
(2018/12/9 23:31時点)

 

インターネットルーティングアーキテクチャ BGPリソースの詳細

インターネットルーティングアーキテクチャ ― BGPリソースの詳解 第2版

中古価格
¥8,543から
(2018/12/9 23:33時点)

マスタリングTCP/IP ルーティング編

マスタリングTCP/IP ルーティング編

新品価格
¥2,592から
(2018/12/9 23:30時点)

ルーティングの授業

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

OSPFの概要 ~基礎編①~

OSPFの概要 ~設定編①~

 

Follow me!

BGPの設定 ~iBGP編①~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です