NATの設定 ~NAPT編~

ベル

今回の授業は、NAPTの設定についてです。今まで学んできたスタティックNATとは設定の仕方が大きく異なります。ゆっくり考えながら進めていけば、必ず理解できるはずですのでついてきてくださいね!何度も言いますが、NATはしっかりと理解しながら進めていかないとトラブルになりやすいです。焦らずゆっくりが大切です!以前の授業を受けていない方は、こちらから。

 

【NATの概要 ~基礎編~】

NATの概要 ~基礎編①~

NATの概要 ~基礎編②~

 

【NATの設定】

NATの設定 ~スタティックNAT編①~

NATの設定 ~スタティックNAT編②~

 

お勉強構成

それでは、お勉強構成の紹介となります。物理的な構成は今までと同じになりますが、パソコンを2台用意してあります。Inside側にあるパソコン2台が同じ内部グローバルアドレスに変換されるところを確認していきましょう!

 

 

【Cisco1812J】

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2018/10/16 21:51時点)

 

 

基本設定

それでは、基本設定をしていきます。いつも通りのインターフェイス設定となります。NATの授業で設定するのも3回目となります。さらっといきますよー!

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

!

RT2(config)#interface vlan 10

RT2(config-if)#ip address 10.1.100.254 255.255.255.0

!

RT2(config-if)#interface fastEthernet 2

RT2(config-if)#switchport access vlan 10

 

同じような設定を何度も投入することで、頭ではなく体で覚えることが大切です。何十回も設定してしみ込ませることで、仕事は早くなるものです。飽きずにしっかり設定しましょうね!

 

ルーティング設定

それではルーティングの設定をしていきます。以前のスタティックNAT(Inside NAT版)と同様のルーティング設定となります。そのため、簡単に設定だけ紹介させていただきます。見てもわからない方は、こちらの授業で確認してください。

 

【RT1】

RT1(config)#ip route 192.168.100.1 255.255.255.255 10.10.1.2

 

【RT2】

RT2(config)#ip route 0.0.0.0 0.0.0.0 10.10.1.1

 

ここのポイントは、ルータ1の宛先指定に内部グローバルアドレスを指定しているということです。間違って内部ローカルアドレスにしないように注意してくださいね!

 

NAPTの設定

それでは、NAPTの設定に入っていきましょう。まずは、スタティックNATの時と同じようにInside/Outsideの設定をしていきましょう。今回の設定パラメータは、以下になります。これを見ながら設定していきます。

 

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip nat inside

!

RT2(config-if)#interface vlan 10

RT2(config-if)#ip nat outside

 

それでは、NATの設定をしていくわけですが、ここからがスタティックNATとの違いが出てきます。NAPTは、アクセスリスト(ACL)とPOOL nameを関連付けて設定します。POOL nameとは、アドレスの範囲に名前を付けて使用する方式のことです。アクセスリストには内部ローカルアドレスを指定し、POOL nameには内部グローバルアドレスを指定して変換させる書き方になります。今回ですと、アクセスリストに『10.1.100.0/24』を、POOL nameに『192.168.100.1』を設定していきます。

 

【RT2】

RT2(config)#access-list 1 permit 10.1.100.0 0.0.0.255

RT2(config)#ip nat pool POOL 192.168.100.1 192.168.100.1 netmask 255.255.255.0

 

『ip nat pool nameのコマンドは初めて教えますが、最初に出てくるアドレスはPOOLに含まれる最初のアドレスで、次に表示されるアドレスは最後のアドレスになります。今回は、『192.168.100.1』しか使用しないので同じアドレスを指定すればOKです。アクセスリストの設定が分からない方は、こちらの授業で確認しておきましょうね!

 

【アクセスリストによる通信制御 ~設定編~】

アクセスリストによる通信制御 ~設定編~

 

それでは、このアクセスリストとPOOL nameを使ってNAPTの設定をしていくと以下のような設定になります。ポイントとなるのが、最後の『overload』ですね!これが付けるとNAPTとして動作するので、忘れずに付けましょうね!

 

【RT2】

RT2(config)#ip nat inside source list 1 pool POOL overload

 

スタティックNATのようにアドレスで指定するのではなく、アクセスリストやPOOL nameで関連させる部分が異なりますね。それでは、通信が発生するとどのように動作するのかを見ていきましょう。

 

確認

それでは、それぞれのパソコンから疎通試験を実施してみましょう。疎通直後の『show ip nat translation』で確認出来ます。以下のような結果が表示されていればOKです。

 

RT2#show ip nat translations
Pro   Inside global          Inside local         Outside local         Outside global
icmp 192.168.100.1:1  10.1.100.1:1     10.1.1.1:1            10.1.1.1:1
icmp 192.168.100.1:0  10.1.100.2:1     10.1.1.1:1            10.1.1.1:0

 

見てもらえればわかると思いますが、2つの内部ローカルアドレス(10.1.100.1と10.1.100.2)が同じ内部グローバルアドレス(192.168.100.1)になっていますね?このように同じ内部グローバルアドレスになっても『:』の右に書かれているポート番号が異なるので、戻りのパケットが正しく変換されることが出来るのです。このような仕組みをNAPTとなります。※表示されるポート番号は異なる場合があります。

 

ここまで出来たら完璧!ってなるかもしれませんが、逆からの通信も試してみましょう。ルータ1からパソコンに向けて疎通試験を実施してみてください。Ping応答はありますか?たぶんないですよね?それは、ルータ1からの通信ではルータ2にNATエントリが出来ないからなんです。ここにエントリが出来ていないと192.168.100.1に来た通信の変換先(10.1.100.1 or 10.1.100.2)が不明となり通信ができないのです。これは、以前の授業でも紹介した注意事項になります。

 

まとめ

ベル

今回の授業はいかがでしたか?これまでのスタティックNATを理解できていれば、問題なくクリアできたかと思います。まだ不安を感じている方は、これまでの授業をしっかり復習しておきましょうね。

 

ルーティングの授業

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

OSPFの概要 ~基礎編①~

OSPFの設定 ~シングルエリア編①~

 

商品紹介

ネットワークエンジニアとして仕事していく上で、必要となる商品を紹介させていただいています。よかったら、こちらも読んでみてください。きっと何か面白いものが見つかると思いますよ!

商品紹介 ~ネットワークエンジニアの便利アイテム!~

商品紹介 ~職場で使える便利商品①~

商品紹介 ~ネットワークのお勉強に役立つ商品①~

無線LAN商品の紹介 ~Arubaで遊ぼう!~

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です