NATの設定 ~スタティックNAT編②~

ベル

今回の授業は、前回に引き続きスタティックNATですが、前回と違うのはOutside NATという点です。どう違うのかを比較しながら解説していくので、ゆっくり理解していきましょうね!前回までの授業を読まれていない方は、こちらから。

 

【NATの概要 ~基礎編~】

NATの概要 ~基礎編①~

NATの概要 ~基礎編②~

 

【NATの設定】

NATの設定 ~スタティックNAT編①~

 

 

お勉強構成

それではお勉強構成からですね。物理構成は、前回と同じですがNATのOutsideとInsideが逆になっているところがポイントです!間違えて設定しないように注意しましょうね!

 

 

【Cisco1812J】

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2018/10/16 21:51時点)

基本設定

それでは、基本設定をしていきましょう!まずはインターフェイスの設定からいきますよ。構成図を見ながら間違えないようにしましょうね!前回と同じ設定となりますので、設定が残っている方は、ルーティングの設定に進みましょう。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

!

RT2(config)#interface vlan 10

RT2(config-if)#ip address 10.1.100.254 255.255.255.0

!

RT2(config-if)#interface fastEthernet 2

RT2(config-if)#switchport access vlan 10

 

ここまでは大丈夫ですか?次に進みますよ。

 

ルーティングの設定

それでは、ルーティングの設定をしていきます。前回と違いが出てくるので注意していきましょう。ルータ1の設定をしていきますが、前回は、以下の設定をしたと思います。

 

【RT1】

RT1(config)#ip route 192.168.100.1 255.255.255.255 10.10.1.2

 

今回も、この設定のままでいけそうですね。ちなみに、この『192.168.100.1』というのは、外部ローカルアドレスと名前が変わるので注意しておきましょうね。

 

それでは、続いてルータ2のスタティックルートを設定していく分けですが、前回と同様の設定だけで行きましょう。

 

【RT2】

RT2(config)#ip route 0.0.0.0 0.0.0.0 10.10.1.1

 

このデフォルトルートのネクストホップがルータ1向けの設定でしたね。前回と同様の疎通試験を実施すると、ルータ1のLoopback0宛てのパケットは、ルータ1に転送してくれるので大丈夫そうですね!以上となりますが、結局、ルーティング設定に差分はなしでいけそうかな?

 

スタティックNATの設定

それでは、最後にスタティックNATの設定に入っていきますが、前回と同様のルータ2でNATの設定をしていきます。以下のお勉強構成を見ながら設定をしていきましょう!

 

 

 

必要となるポイントを事前に整理しておきましょう。前回との差分になるところは、Outside/Insideインターフェイスと内部/外部のアドレスです。間違わないように設定してきましょうね!

 

 

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip nat inside

!

RT2(config-if)#interface vlan 10

RT2(config-if)#ip nat outside

 

Outside/Insideが間違わずに設定できましたか?続いてスタティックNATの設定をしていきますが、基本的なコマンドに差分はないので、サラッと設定していきましょう。

 

【RT2】

RT2(config)#ip nat outside source static 10.1.100.1 192.168.100.1

 

これで設定は終了です。「あれ?たいした難しくないじゃん?」って思われたかもしれませんが、ちゃんと疎通試験までしっかりやりましょうね!

 

確認

それでは、確認していきますよ。使用するコマンドは、前回と同様『show ip nat translations』です。

 

【RT2】

RT2#show ip nat translations
Pro   Inside global        Inside local       Outside local       Outside global
—    —                      —                   192.168.100.1   10.1.100.1

 

このように表示されているはずです。これは、最初のNAT定義をした情報が表示されている状態ですので、通信が発生するとNATテーブルにエントリが追加されていくはずですので見ていきましょう。

 

それでは、パソコンからRT2のLoopback0(10.1.1.1)にPing疎通を実行してみてください。「あれ?通信できない。。。」ってなりませんか?これはInside NATとOutside NATの差分を考慮していないからです。『NATの概要 ~基礎編②~』で注意したことを思い出してみましょう。Outside NATはルーティング処理されてからNAT変換されるため、外部ローカルアドレスのネクストホップがInsideインターフェイス向けに設定されていないとNAT変換されないのです。これを忘れてしまうとこのような事態になるのです。

 

ルーティングの再設定

さあ、ルーティングの再設定をしていきましょう。今回の外部ローカルアドレスは、『192.168.100.1』ですので、これに対してネクストホップを指定して行きますが、今回は外部ローカルアドレスの『10.1.100.1』を指定します。ただ『Vlan10』だけを指定すると通信が断続的に切れるので指定しないようにしましょうね。

 

【RT2】

RT2(config)#ip route 192.168.100.1 255.255.255.255 10.1.100.1

 

これでルーティングの再設定は終了です。これで通信は出来るようになったでしょうか。改めて疎通確認を実施してみましょう。

 

※今回は、ネクストホップがなくホストアドレスになってしまうので気持ち悪く感じますが、ネクストホップがネットワーク機器の場合は、通常のスタティックルートのようにアドレス指定すれば問題ないです。

 

再確認

それでは、先程と同様にパソコンからRT2のLoopback0(10.1.1.1)にPing疎通を実行してみてください。Ping応答がありますでしょうか?応答があれば、『show ip nat translations』でNATテーブルを確認しましょう。

 

【RT2】

RT2#show ip nat translations
Pro   Inside global          Inside local         Outside local          Outside global
—    —                        —                      192.168.100.1       10.1.100.1
icmp 10.1.1.1:1            10.1.1.1:1          192.168.100.1     10.1.100.1

 

このように『ICMP』のエントリが増えていたら成功です。

 

まとめ

ベル

今回の授業はいかがでしたか?Inside NATかOutside NATかでルーティングの設定に違いが出ることを理解することが出来たでしょうか?本で読んでなんとなく理解しただけですと、ピンと来なかったり忘れてしまうことがよくあります。僕の現場でも設定間違いしてトラブルを起こしてしまうことが多々ありますので、ちゃんとラボ環境で検証して理解しましょうね!次はNAPTの設定に入りますよ!

【NATの設定 ~NAPT編~】

NATの設定 ~NAPT編~

 

【Ciscoコンソールケーブル】

【CISCO互換ケーブル】FTDI chipset USB RJ45 コンソールケーブル

新品価格
¥1,150から
(2018/10/16 21:54時点)

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です