NATの設定 ~スタティックNAT編①~

ベル

今回の授業は、いよいよNATの基本的な設定をしていきたいと思います。NATの種類はいくつかありますが、まずは、スタティックNATからですね。基本的な設定なので、ゆっくり設定してもらえれば必ずわかると思いますので、一緒に頑張りましょう!前回までの授業を受けていない方、忘れてしまった方は、そちらから勉強しましょうね!

 

【NATの概要 ~基礎編~】

NATの概要 ~基礎編①~

NATの概要 ~基礎編②~

 

お勉強構成

今回、スタティックNATを勉強する上で、使用する勉強構成は以下の通りとします。まずは、基本的な設定をお勉強するのでシンプルにシングル構成でやってみたいと思います。

 

 

【Cisco1812J】

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2018/10/16 21:51時点)

基本設定

それでは、NATに関係しない基本的な設定をしていきましょう。まずは、インターフェイスの設定ですね。使用するインターフェイスにIPアドレスを設定していきましょう。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

!

RT2(config)#interface vlan 10

RT2(config-if)#ip address 10.1.100.254 255.255.255.0

!

RT2(config-if)#interface fastEthernet 2

RT2(config-if)#switchport access vlan 10

 

ここまでは問題なくできましたか?難しかった方は、本校の他の授業を振り返ってみましょう。いろんなところで設定してきているので、きっと理解することが出来ると思いますよ。

 

ルーティング設定①

それでは、ルーティング設定をしていきたいと思います。まずは、ルータ1からいきますね。

 

【RT1】

RT1(config)#ip route 192.168.100.1 255.255.255.255 10.10.1.2

 

これだけです。あれ?『10.1.100.0/24』向けのルーティング設定はいらないの?って思うかもしれませんが不要です。今回は、パソコンで使用している内部ローカルアドレス(10.1.100.1)を内部グローバルアドレス(192.168.100.1)に変換します。そのためルータ1は、『10.1.100.0/24』のルートを知る必要がなくなります。必要となるのは、内部グローバルアドレスの情報だけとなるため、『192.168.100.1/32』向けのスタティックルートだけ設定すれば十分となります。

 

続いて、ルータ2の設定をしたいと思いますが、このルータは、特段難しいルーティングは不要なので、デフォルトルートだけルータ1に向けて設定しておきましょう。

 

【RT2】

RT2(config)#ip route 0.0.0.0 0.0.0.0 10.10.1.1

 

これでルーティングの設定は終了です。そろそろNATの設定に入っていこうと思いますが、ここまでは大丈夫ですか?ついてきてくださいねー。

 

スタティックNATの設定

それでは、いよいよスタティックNATの設定に入っていこうと思います。今回は、ルータ2でNATの設定をしていこうと思いますが、ここでお勉強構成を振り返っておきましょう。

 

 

NATの設定をする上で、必要となるポイントを整理しておきますね。

 

 

これらのパラメータを使用して設定していこうと思います。まずは、InsideインターフェイスとOutsideインターフェイスの定義からです。

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip nat outside

!

RT2(config-if)#interface vlan 10

RT2(config-if)#ip nat inside

 

これだけ、Inside/Outsideの定義は終了です。簡単ですね。

 

それでは続いてスタティックNATの設定をしていきますが、今回はInside側にあるIPアドレス(セグメント)をNAT変換するので、以下のようなコマンドを使用します。

 

【RT2】

RT2(config)#ip nat inside source static 10.1.100.1 192.168.100.1

 

これだけです。中身の解説をしておくと、先に『内部ローカルアドレス』、続いて『内部グローバルアドレス』を指定します。逆に設定してしまったりしないように注意しましょうね。

 

 

今回は、ホスト(端末)単位でNATを設定していますが、セグメント単位で設定することも可能です。セグメント単位で設定する場合は、こんな感じのコマンドになります。

 

【RT2】

RT2(config)#ip nat inside source static network 10.1.100.0 192.168.100.0 /24

 

確認

それでは、確認していきましょう。NATの正常性確認だけに絞って確認するので、使用するコマンドは『show ip nat translations』となります。まずは、何も通信が発生していない状態でコマンドを実行してみたいと思います。

 

【RT2】

RT2#show ip nat translations
Pro   Inside global        Inside local       Outside local       Outside global
—    192.168.100.1   10.1.100.1       —                      —

 

 

それでは、パソコンからRT2のLoopback0(10.1.1.1)にPing疎通を実行してみてください。その直後に、先程と同じ『show ip nat translations』を実行してみましょう。以下のようなログが出力されるはずです。

 

【RT2】

RT2#show ip nat translations
Pro   Inside global          Inside local         Outside local         Outside global
icmp 192.168.100.1:1  10.1.100.1:1     10.1.1.1:1            10.1.1.1:1
—    192.168.100.1       10.1.100.1         —                        —

 

これは、最初に作成されたスタティックNATを使用してICMP通信が発生したことで表示される内容となります。何らかの理由でNAT変換されない場合は、最初のコマンド実行結果と同様の内容となります。ちなみに、通信が発生してしばらくするとログは削除されてしまうので、Ping疎通を実施したら、すぐに確認するようにしましょうね。

 

Ping以外にもTelnetなどを実行すると、先程の『ICMP』の部分が『TCP』に変わって表示されるので、他のプロトコルで実行してみる面白いかもしれません。ちなみにTelnetアクセスしてみると以下のような結果が見受けられると思います。

 

【RT2】

RT2#show ip nat translations
Pro   Inside global                Inside local               Outside local       Outside global
tcp   192.168.100.1:50814  10.1.100.1:50814      10.1.1.1:23         10.1.1.1:23
—    192.168.100.1            10.1.100.1                —                      —

 

 

まとめ

ベル

今回の授業はここまでとなりますが、いかがでしたか?NATの設定をする際に『内部』、『外部』、『ローカル』、『グローバル』でぐちゃぐちゃになってしまうことがありますので、まずは構成図をしっかりと書いて頭を整理することが大切です。焦らずゆっくりと理解していきましょうね。次回以降もNATの設定をしていくので、復習しておきましょう。

 

 

ルーティングの授業

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

OSPFの概要 ~基礎編①~

OSPFの設定 ~シングルエリア編①~

 

Follow me!

NATの設定 ~スタティックNAT編①~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です