DHCPの設定 ~サーバ構築編~

ベル

今回の授業は、「CiscoルータでDHCPサーバを構築」してみたいと思います。サーバって聞くとネットワークエンジニアの守備範囲ではないように思われますが、実はネットワーク機器でも構築出来るものもあるのです。その中でもよく作られるのが、DHCPサーバです。しっかりと覚えておきましょう!

 

【DHCPの概要 ~基礎編①~】

DHCPの概要 ~基礎編①~

 

お勉強構成

今回は、パソコンにIPアドレスを割り当てるので、今、使われているパソコンをそのまま使われてもいいですが、デフォルトゲートウェイまで変更してしまうので、インターネットに出れなくなってしまいます。このサイトをご覧になりながら設定したい方はご注意ください!

 

 

事前設定

それでは、事前設定をしていきたいと思います。今回はDHCPサーバを構築したいので、それ以外の設定は出来るだけシンプルにしておきたいと思います。

インターフェイス設定

まずは、インターフェイスの設定からですね。お勉強構成を確認しながら設定していきましょう。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

!

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

 

【RT2】

RT2(config)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

!

RT2(config)#interface vlan 10

RT2(config-if)#ip address 10.1.100.254 255.255.255.0

!

RT2(config-if)#interface fastEthernet 2

RT2(config-if)#switchport access vlan 10

 

インターフェイス設定は、サクッと出来ましたか?次に進みますよ。

 

ルーティング設定

それではルーティング設定をしていきましょう。今回は、簡単にスタティックルートにします。

 

【RT1】

RT1(config)#ip route 10.1.100.0 255.255.255.0 10.10.1.2

 

【RT2】

RT2(config)#ip route 10.1.1.1 255.255.255.255 10.10.1.1

 

ここまではOKですか?ダメだった方は、前の授業から振り返ってみましょう。

静的ルーティング(スタティックルート) ~設定編①~

静的ルーティング(スタティックルート) ~設定編①~

 

DHCP設定

それでは、本題のDHCPの設定に入っていきたいと思います。

 

払出し範囲の指定

それでは基本となる、払出し範囲の指定からしていきたいと思います。まずは、『service dhcp』コマンドでルータ2でDHCPサーバ機能を有効にします。その後、払出しアドレスの範囲を『ip dhcp pool nameコマンドで指定していきます。ここで指定した名前で払出しアドレスを管理していくようになります。

 

【RT2】

RT2(config)#service dhcp

RT2(config)#ip dhcp pool dhcp-test

 

次に払い出す『ネットワーク設定』『デフォルトゲートウェイ』『DNSサーバ』の指定を行います。適当に入れるのではなく、一旦、整理をしてから入れていきましょう。今回は、以下のような設定を入れます。

 

 

【RT2】

RT2(dhcp-config)#network 10.1.100.0 255.255.255.0

RT2(dhcp-config)#default-router 10.1.100.254

RT2(dhcp-config)#dns-server 10.10.10.1

 

今回は設定しませんが、ドメイン名の指定も『domain-name』コマンドで指定することが出来ます。必要に応じて指定するようにしてください。

 

有効期限設定

次にDHCPサーバが払い出したアドレスの返却期限の設定です。デフォルトでは1日となっていますが、今回は2時間に変更してみます。

 

【RT2】

RT2(dhcp-config)#lease 0 2 0

ここで定義している数値が3つあると思いますが、左から『日』『時』『分』となっているので、設計に合わせて設定するようにしてください。

 

除外範囲の指定

これにより、DHCPサーバとして払出すアドレス範囲の指定が出来ました。しかし、払出しアドレスの中でも、特定のアドレスを払出したくない場合もありますよね。例えば、前回の授業てあげさせてもらったプリンタとかです。そのような場合は、『ip dhcp excluded-address』コマンドで除外することが可能となります。今回は、『10.1.100.201 ~ 10.1.100.254』を除外してみたいと思います。

 

【RT2】

RT2(config)#ip dhcp excluded-address 10.1.100.201 10.1.100.254

 

払い出し結果の確認

それでは、パソコンをルータ2のFastEthernet2に接続してみてください。コマンドプロンプトを立ち上げて『ipconfig /all』と入力してみてください。以下のような設定データが表示されていれば、DHCPサーバからIPアドレスが払い出されているのでOKです。(確認に関係しない部分に関してはマスクしています。)

 

イーサネット アダプター イーサネット:

接続固有の DNS サフィックス . . . . .:
説明. . . . . . . . . . . . . . . . .: XX
物理アドレス. . . . . . . . . . . . .: XX-XX-XX-XX-XX-XX
DHCP 有効 . . . . . . . . . . . . . .: はい
自動構成有効. . . . . . . . . . . . .: はい
リンクローカル IPv6 アドレス. . . . .: XXXX::XXXX:XXXX:XXXX:XXXX(優先)
IPv4 アドレス . . . . . . . . . . . .: 10.1.100.1(優先)
サブネット マスク . . . . . . . . . .: 255.255.255.0
リース取得. . . . . . . . . . . . . .: 2018年9月27日 22:45:20
リースの有効期限. . . . . . . . . . .: 2018年9月28日 0:45:20
デフォルト ゲートウェイ . . . . . . .: 10.1.100.254
DHCP サーバー . . . . . . . . . . . .: 10.1.100.254
DHCPv6 IAID . . . . . . . . . . . . .:
DHCPv6 クライアント DUID. . . . . . .: XX-XX-XX-XX-XX-XX-XX-XX-XX-XX-XX-XX-XX-XX
DNS サーバー. . . . . . . . . . . . .: 10.10.10.1
NetBIOS over TCP/IP . . . . . . . . .: 有効

 

払い出し結果は、DHCPサーバ側でも確認できます。コマンドは、『show ip dhcp binding』『show ip dhcp pool』を使用していこうと思います。

 

【RT2】

RT2#show ip dhcp pool

Pool dhcp-test :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 0
Pending event : none
1 subnet is currently in the pool :
Current index      IP address range                        Leased addresses
10.1.100.2        10.1.100.1 – 10.1.100.254       1

 

ここで確認できるのが、先程作成したDHCP-poolが表示されていて払い出すアドレス範囲が表示されていると思います。また、『Current index』で書かれているアドレスが次に払い出されるアドレスになります。

 

RT2#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address            Client-ID/                       Lease expiration                Type
Hardware address/
User name
10.1.100.1          XXXX.XXXX.XXXX.XX   Sep 28 2018 0:45 AM      Automatic

 

ここで確認できるのが、払い出されたアドレスになります。今回は隠していますが、払い出されたパソコンのMACアドレスが表示されています。また、貸出期限も表示されていますので、この時間になったらIPアドレスの返却してもらうようになります。Ciscoのデフォルトでは1日になっているので、あまり変更しない方がいいと思います。

 

まとめ

ベル

今回、CiscoルータでDHCPサーバを構築してみましたが、いかがでしたか?ちょっとネットワークっぽくなかったかもしれませんが、Windowsサーバで構築したりするよりは簡単に出来るので、覚えておくと便利だったりもします。一度、設定してみるといいかもしれません。

 

【コンソールケーブル】

Cisco機器に接続する際に使用するケーブルとなります。通常ですとCisco機器付属されているコンソールケーブルにUSB変換ケーブルをジョイントして使うのが一般的でしたが、最近ではこれ一本で使えるようになっているんです。かなり便利ですので、よかったら購入してみてください。

Amazon

【CISCO互換ケーブル】FTDI chipset USB RJ45 コンソールケーブル

新品価格
¥1,130から
(2018/9/28 20:18時点)

 

【Cisco1812J】

10年位前に発売されたルータですが、いまだに根強い人気があります。何と言ってもルータとスイッチの両方の機能が使えてこの価格。勉強するのであれば一番の商品だと思います。

Amazon

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2018/9/28 20:19時点)


【Cisco891FJ】

Cisoc1812Jの後継機種となります。(間にCisco892Jがありますが。。)スイッチポートがすべてGigabitEthernetとなっており、ギガポートを使った検証が必要であればおすすめです。ちょっと高いですが。

Amazon

Cisco 891FJ-K9 C891FJ-K9 サービス統合型ルータ

中古価格
¥18,900から
(2018/9/28 20:19時点)

Follow me!

DHCPの設定 ~サーバ構築編~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です