OSPFの設定 ~トータリースタブ編~

ベル

今回の授業は、OSPFのトータリースタブ設定について、勉強していきます。標準エリア、スタブエリア、トータリースタブエリアのルーティングテーブルを比較しながら確認してもらえるとわかりやすいかと思います。

 

OSPFの授業

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

OSPFの設定 ~シングルエリア編①~

OSPFの設定 ~シングルエリア編②~

OSPFの設定 ~マルチエリア編~

OSPFの設定 ~スタブ編~

 

前回のスタブ編を読まれて理解されている方は、「トータリースタブエリア設定」からお読みください。

 

お勉強構成

さて、今回のお勉強構成は、以下の感じになります。

 

 

前回のスタブ構成と似ていますが、エリア1がトータリースタブエリアになっています。エリア1を標準エリア、スタブエリア、トータリースタブエリアに変更させていきますので、ルーティングテーブルの差分について学んでもらえたらと思います。前回の授業の振り返りにもなると思いますので、ついてきてくださいね。

 

事前設定

今回の事前設定は、インターフェイスだけでなく、エリア1を標準エリアにするまでを設定していこうと思います。ここまでは迷わず出来るようにしましょうね!

 

インターフェイス設定

それでは、まずは、インターフェイス設定をしていきます。構成図を見ながら設定していきましょうね。

 

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

【RT2】

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

RT2(config-if)#interface FastEthernet1

RT2(config-if)#ip address 10.10.2.2 255.255.255.0

 

【RT3】

RT3(config)#interface Loopback0

RT3(config-if)#ip address 10.1.1.3 255.255.255.255

RT3(config-if)#interface FastEthernet0/0

RT3(config-if)#ip address 10.10.2.3 255.255.255.0

RT3(config-if)#interface FastEthernet0/1

RT3(config-if)#ip address 10.10.3.3 255.255.255.0

 

【RT4】

RT4(config)#interface Loopback0

RT4(config-if)#ip address 10.1.1.4 255.255.255.255

RT4(config-if)#interface FastEthernet0/0

RT4(config-if)#ip address 10.10.3.4 255.255.255.0

 

まずはここまで。インターフェイスにアドレスを設定していくだけなので、簡単にできましたか?

 

EIGRPの設定

それでは、EIGRPの設定をしていきましょう。ルータ1のLoopback0、FastEthernet0とルータ2のFastEthernet1をEIGRPに含めていきたいと思います。今回は、単純にEIGRPに含めるだけなのでネットワーク設定だけでいけますね。

 

【RT1】

RT1(config)#router eigrp 1

RT1(config-if)#network 10.1.1.1 0.0.0.0

RT1(config-if)#network 10.10.1.0 0.0.0.255

 

【RT2】

RT2(config)#router eigrp 1

RT2(config-if)#network 10.10.1.0 0.0.0.255

 

OSPF 標準エリア設定

エリア1を標準エリアで設定していきたいと思います。今回の授業では、エリア0とエリア1のみの構成となっているので、サクサクと設定していきたいと思います。エリア間でのルート制御はないので、すべてのルートを交換することにします。それでは、お勉強構成を見ながら設定していきましょう。

 

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#router-id 10.1.1.2

RT2(config-router)#network 10.1.1.2 0.0.0.0 area 0

RT2(config-router)#network 10.10.2.0 0.0.0.255 area 0

 

【RT3】

RT3(config)#router ospf 1

RT3(config-router)#router-id 10.1.1.3

RT3(config-router)#network 10.1.1.3 0.0.0.0 area 1

RT3(config-router)#network 10.10.2.0 0.0.0.255 area 0

RT3(config-router)#network 10.10.3.0 0.0.0.255 area 1

 

【RT4】

RT4(config)#router ospf 1

RT4(config-router)#router-id 10.1.1.4

RT4(config-router)#network 10.1.1.4 0.0.0.0 area 1

RT4(config-router)#network 10.10.3.0 0.0.0.255 area 1

 

再配布の設定

前回と同様、EIGRPとOSPF間で再配布を行うのはルータ2となります。このルータ2の設定をしていきたいと思います。特にルート制御をするわけではないので、頑張って設定してみましょう。

 

EIGRPをOSPFに再配布

それではまず、EIGRPで学習したルートをOSPFのネットワークに再配布していきたいと思います。

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#redistribute eigrp 1 subnets

 

OSPFをEIGRPに再配布

続いて、OSPFで学習したルートをEIGRPのネットワークに再配布していきたいと思います。

 

【RT2】

RT2(config)#router eigrp 1

RT2(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500

 

スタータス確認

それでは、ステータス確認に入りますが、今回はルーティングテーブルだけの確認とさせていただきます。その他の確認を知りたい方は、以前までのOSPFの授業を読んでみてください。

 

標準エリア設定時のルーティングテーブル

それでは、標準エリア設定時のルーティングテーブルを確認してみたいと思います。関係ありそうなルータ3とルータ4のルーティングテーブルを確認していきます。以下のようなルーティングテーブルになっていれば問題ないです。

 

【RT3】

RT3#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O E2 10.10.1.0/24 [110/20] via 10.10.2.2, 00:08:14, FastEthernet0/0
C      10.10.2.0/24 is directly connected, FastEthernet0/0
C      10.10.3.0/24 is directly connected, FastEthernet0/1
O      10.1.1.2/32 [110/2] via 10.10.2.2, 00:08:14, FastEthernet0/0
C      10.1.1.3/32 is directly connected, Loopback0
O E2 10.1.1.1/32 [110/20] via 10.10.2.2, 00:08:14, FastEthernet0/0
O      10.1.1.4/32 [110/2] via 10.10.3.4, 00:08:14, FastEthernet0/1

 

【RT4】

RT4#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O E2 10.10.1.0/24 [110/20] via 10.10.3.3, 00:09:54, FastEthernet0/0
O IA 10.10.2.0/24 [110/2] via 10.10.3.3, 00:09:54, FastEthernet0/0
C     10.10.3.0/24 is directly connected, FastEthernet0/0
O IA 10.1.1.2/32 [110/3] via 10.10.3.3, 00:09:54, FastEthernet0/0
O     10.1.1.3/32 [110/2] via 10.10.3.3, 00:09:54, FastEthernet0/0
O E2 10.1.1.1/32 [110/20] via 10.10.3.3, 00:09:54, FastEthernet0/0
C      10.1.1.4/32 is directly connected, Loopback0

 

 

ここまでは普通ですね。先にも述べた通りルート制御をしていないので、すべてのルーティングが見えている状態になります。それでは、前回と同様のスタブ設定に変更していこうと思います。

 

 

スタブエリア設定

それでは、スタブエリアに変更していきましょう。設定するコマンドは、「router ospf numの中にスタブエリアにしたいにエリアをしていする「area num stub」を投入するだけでしたね。今回の設定で言うと、以下の設定を投入するだけで、エリア1を標準エリアからスタブエリアに変更することが出来ます。

 

 

【RT3】

RT3(config)#router ospf 1

RT3(config-router)#area 1 stub

 

【RT4】

RT4(config)#router ospf 1

RT4(config-router)#area 1 stub

 

スタブエリア設定時のルーティングテーブル

それでは、スタブエリアの設定が完了したら、ルーティングテーブルを見ていきましょう。標準エリア設定時と比較しながら見てみましょう。

 

【RT3】

RT3#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O E2 10.10.1.0/24 [110/20] via 10.10.2.2, 00:08:14, FastEthernet0/0
C      10.10.2.0/24 is directly connected, FastEthernet0/0
C      10.10.3.0/24 is directly connected, FastEthernet0/1
O      10.1.1.2/32 [110/2] via 10.10.2.2, 00:08:14, FastEthernet0/0
C      10.1.1.3/32 is directly connected, Loopback0
O E2 10.1.1.1/32 [110/20] via 10.10.2.2, 00:08:14, FastEthernet0/0
O      10.1.1.4/32 [110/2] via 10.10.3.4, 00:08:14, FastEthernet0/1

 

【RT4】

RT4#show ip route

Gateway of last resort is 10.10.3.3 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O IA 10.10.2.0/24 [110/2] via 10.10.3.3, 00:03:12, FastEthernet0/0
C      10.10.3.0/24 is directly connected, FastEthernet0/0
O IA 10.1.1.2/32 [110/3] via 10.10.3.3, 00:03:12, FastEthernet0/0
O      10.1.1.3/32 [110/2] via 10.10.3.3, 00:03:12, FastEthernet0/0
C      10.1.1.4/32 is directly connected, Loopback0
O*IA 0.0.0.0/0 [110/2] via 10.10.3.3, 00:03:12, FastEthernet0/0

 

前回の授業と同様で、以下の2ルートがなくって、デフォルトルートが増えているはずです。

O E2 10.10.1.0/24 [110/20] via 10.10.3.3, 00:09:54, FastEthernet0/0

O E2 10.1.1.1/32 [110/20] via 10.10.3.3, 00:09:54, FastEthernet0/0

 

つまり、EIGRPで再配布されたルーティング情報が、スタブエリアには配布されないようになっているのです。その代わり、バックボーンエリアと接続されているルータ3(ABR)が、デフォルトルートを生成しスタブエリア内に配布するようになるのです。そのためルータ3(ABR)では、ルーティング差分が発生していないことも確認しておきましょう。

 

トータリースタブエリア設定

それでは、今回の授業のメインに入りますね。ここまで長かったですね。もうちょっとですので頑張りましょう。

さて、トータリースタブエリアの設定ですが、その前に、トータリースタブエリアとは?について復習しておきましょう。トータリースタブエリアとは、スタブエリアよりも負荷を軽減させるために作られたエリアのことで、バックボーンエリア内のルートも配布するのをやめてしまったエリアになります。

 

設定は、スタブエリアと似ていて、「area 1 stub」「no-summary」を追加するだけです。ただし、スタブと異なるのは、ABRで「area 1 stub no-summary」を投入すればOKという点です。それ以外のルータには、「area 1 stub」だけでも問題ありません。それでは、今回の構成では、ルータ3のみが対象になりますので、設定変更していきましょう。

※今まで当たり前のように全機器で設定していましたが、とある優秀なエンジニアさんから指摘いただいたので修正しました。(2018/9/14)

 

 

 

【RT3】

RT3(config)#router ospf 1

RT3(config-router)#area 1 stub no-summary

 

 

トータリースタブエリア設定時のルーティングテーブル

それでは、トータリースタブエリアに設定したルーティングを見ていきましょう。どのように変化したでしょうか?

 

【RT3】

RT3#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O E2 10.10.1.0/24 [110/20] via 10.10.2.2, 00:08:14, FastEthernet0/0
C      10.10.2.0/24 is directly connected, FastEthernet0/0
C      10.10.3.0/24 is directly connected, FastEthernet0/1
O      10.1.1.2/32 [110/2] via 10.10.2.2, 00:08:14, FastEthernet0/0
C      10.1.1.3/32 is directly connected, Loopback0
O E2 10.1.1.1/32 [110/20] via 10.10.2.2, 00:08:14, FastEthernet0/0
O      10.1.1.4/32 [110/2] via 10.10.3.4, 00:08:14, FastEthernet0/1

 

まずルータ3に関しては、何も変わっていませんね。それもそのはず。スタブエリアと同様に、配布するルート内容を制御しているのが、ABRであるルータ3だからです。それでは、その配下にあたるルータ4はどうなったでしょうか?

 

【RT4】

RT4#show ip route

Gateway of last resort is 10.10.3.3 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C      10.10.3.0/24 is directly connected, FastEthernet0/0
O      10.1.1.3/32 [110/2] via 10.10.3.3, 00:03:32, FastEthernet0/0
C      10.1.1.4/32 is directly connected, Loopback0
O*IA 0.0.0.0/0 [110/2] via 10.10.3.3, 00:00:24, FastEthernet0/0

 

スタブエリアの時には、デフォルトルートを含めて6ルートあったはずが、4ルートに減っていますね!中身を見ると以下の2ルートが削除されたようです。

 

O IA 10.10.2.0/24 [110/2] via 10.10.3.3, 00:03:12, FastEthernet0/0

O IA 10.1.1.2/32 [110/3] via 10.10.3.3, 00:03:12, FastEthernet0/0

 

左側に『O IA』と書かれていますね。これは、バックボーンエリア(エリア0)内のルートですね。そう!スタブエリアとの違いは、ABRが生成するLSA3を受け取らないことで、非OSPFのルートと他のエリアのルートを受け取らなくするのです。このようにすることで、スタブエリアよりも、さらにトータリースタブエリア内のルーティングを簡素化し、負荷を軽減しているのです。

 

まとめ

ベル

今回の授業はいかがでしたか?標準エリア、スタブエリアと比較してみると、ルーティングテーブルが少なくなっていることがわかりましたか?標準エリアと比較しても3ルートくらいしか減っていないと思うかもしれませんが、大きなネットワークとなると効果が大きくなります。しっかり設計して、うまく使えるようになりましょうね!

 

【Cisco1921-K9】

Cisco IP45/C1921-K9 1921/K9 V04 HWIC-4ESW IPBASE Ver.15.1(4)M4 (NEC OEM) C1900-UNIVERSALK9-M Ver.15.1(4)M4 設定初期化済 【中古】【20170509】

価格:15,600円
(2018/9/13 22:52時点)
感想(0件)


【Cisco1812J】

CISCO Cisco 1812J 固定構成型 セキュアブロードバンドアクセスルータ CISCO1812-J/K9

中古価格
¥4,880から
(2018/9/13 22:55時点)

【シリアルコンソールケーブル】

<楽天>

KAUMO USB RJ45 シリアル コンソールケーブル FTDI チップ(Cisco Juniper などに対応) (, ) [ブラック][2.0m]

価格:2,780円
(2018/9/13 22:57時点)
感想(0件)


<amazon>

USBコンソールケーブル CableCreation 1.8m [FTDI-FT232RL チップセット内蔵] USB-RJ45シリアルケーブル Cisco、NETGEAR、TP-Link、Linksys、Ubiquiti、Huaweiルータ/スイッチ用 Mac、Windows及びLinuxに対応 ブラック

新品価格
¥999から
(2018/9/13 22:58時点)

Follow me!

OSPFの設定 ~トータリースタブ編~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です