OSPFの設定 ~スタブ編~

ベル

今回の授業は、OSPFのスタブ設定について、勉強していきます。標準エリアとスタブエリアで比較してみるとわかりやすいので、まずは、標準エリアで設定していきます。その後、スタブエリアに変えて差分を確認しましょう。

 

OSPFの授業

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

OSPFの設定 ~シングルエリア編①~

OSPFの設定 ~シングルエリア編②~

OSPFの設定 ~マルチエリア編~

 

お勉強構成

それでは、お勉強構成からいきますね。以下のような標準エリア構成とスタブエリア構成で比較してみたいと思います。

【標準エリア】

 

【スタブエリア】

 

スタブエリアで見えるルーティングテーブルに注目してもらえれば、標準エリアとは違いが分かってもらえるかと思います。

 

事前設定

それでは、事前設定からいきます。まずは、インターフェイスの設定をしていきましょう!今回は、いつもより1台多いので頑張っていきましょう!

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

【RT2】

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

RT2(config-if)#interface FastEthernet1

RT2(config-if)#ip address 10.10.2.2 255.255.255.0

 

【RT3】

RT3(config)#interface Loopback0

RT3(config-if)#ip address 10.1.1.3 255.255.255.255

RT3(config-if)#interface FastEthernet0/0

RT3(config-if)#ip address 10.10.2.3 255.255.255.0

RT3(config-if)#interface FastEthernet0/1

RT3(config-if)#ip address 10.10.3.3 255.255.255.0

 

【RT4】

RT4(config)#interface Loopback0

RT4(config-if)#ip address 10.1.1.4 255.255.255.255

RT4(config-if)#interface FastEthernet0/0

RT4(config-if)#ip address 10.10.3.4 255.255.255.0

 

ここまでです。今回、使用するインターフェイスの設定が完了しました。ここまでは大丈夫ですか?次に進みますよ。

 

EIGRPの設定

それでは、設定したインターフェイスを各ルーティングプロトコルに属していきたいと思います。まずは、EIGRPの設定からです。ルータ1のLoopback0とFastEthernet0をEIGRPの仲間に入れてみたいと思います。

 

【RT1】

RT1(config)#router eigrp 1

RT1(config-if)#network 10.1.1.1 0.0.0.0

RT1(config-if)#network 10.10.1.0 0.0.0.255

 

続いてルータ2のFastEthernet1もEIGRPの仲間に入れていきたいと思います。

 

【RT2】

RT2(config)#router eigrp 1

RT2(config-if)#network 10.10.1.0 0.0.0.255

 

 

EIGRPのネイバー確認

それではいつも順番が違いますが、ここでEIGRPのネイバーが確立されているかを確認しておきたいと思います。構成が複雑になってくると、まとめて確認するのではなく、都度、確認して進めていった方が手戻りが少なくてすみます。

 

【RT1】

RT1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H  Address  Interface  Hold Uptime    SRTT   RTO  Q     Seq
            (sec)               (ms)           Cnt   Num
10.10.1.2 Fa0         14  01:06:21  1012  5000  0      4

 

【RT2】

RT2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H  Address  Interface  Hold Uptime    SRTT   RTO  Q     Seq
                                (sec)               (ms)           Cnt   Num
10.10.1.1  Fa0       14 01:05:58     1        200   0     4

 

このように、お互いのIPアドレスと接続インターフェイスが表示されていれば、ちゃんとネイバーが確立していることとなります。表示されていない場合は、ケーブルの接続などをインターフェイスのステータスを見て確認してみてください。結構、凡ミスしていたりするものです。

 

 

標準エリアの設定

それではOSPFの設定をしていきたいと思いますが、まずは、標準エリアで設定してみたいと思います。まず、標準エリアの構成を振り返っておきましょう。以下の構成でやってみたいと思いますが、エリア分けするだけでエリア1は標準エリアになります。以前の授業を思い出しながらやってみましょう。

 

【標準エリア】

 

設定するのは、ルータIDの設定とネットワークの設定でしたね。ルータIDは『router-id addressで、ネットワークの設定は『network address wildcard area numで指定することができます。この際にOSPFのネイバーを確立してからルータIDを設定しても反映されませんので、機器間接続する前に設定しましょうね!

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#router-id 10.1.1.2

RT2(config-router)#network 10.1.1.2 0.0.0.0 area 0

RT2(config-router)#network 10.10.2.0 0.0.0.255 area 0

 

【RT3】

RT3(config)#router ospf 1

RT3(config-router)#router-id 10.1.1.3

RT3(config-router)#network 10.1.1.3 0.0.0.0 area 1

RT3(config-router)#network 10.10.2.0 0.0.0.255 area 0

RT3(config-router)#network 10.10.3.0 0.0.0.255 area 1

 

【RT4】

RT4(config)#router ospf 1

RT4(config-router)#router-id 10.1.1.4

RT4(config-router)#network 10.1.1.4 0.0.0.0 area 1

RT4(config-router)#network 10.10.3.0 0.0.0.255 area 1

 

いかがですか?OSPFの設定はすんなりできましたか?

 

OSPFのネイバー確認

ここまで設定できましたでしょうか?出来たらネイバーを確認していきましょう。

 

【RT2】

RT2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.1.3 1 FULL/BDR 00:00:36 10.10.2.3 FastEthernet1

 

【RT3】

RT3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.1.2 255 FULL/DR 00:00:31 10.10.2.2 FastEthernet0/0
10.1.1.4 1 FULL/BDR 00:00:32 10.10.3.4 FastEthernet0/1

 

【RT4】

RT4#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.1.3 1 FULL/DR 00:00:30 10.10.3.3 FastEthernet0/0

 

今回は、特にOSPFのプライオリティを指定していないので、どちらがDR/BDRでも構いません。気になる方は、インターフェイスでPriorityの設定をして、DR/BDRを固定してみてください。

 

再配布の設定

今回、EIGRPとOSPF間で再配布を行うのはルータ2となります。このルータ2の設定をしていきたいと思いますが、これらは、前回の授業で教えた内容となります。忘れてしまった方は、もう一度思い出してくださいね。

OSPFの設定 ~マルチエリア編~

 

EIGRPをOSPFに再配布

それではまず、EIGRPで学習したルートをOSPFのネットワークに再配布していきたいと思います。

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#redistribute eigrp 1 subnets

 

OSPFをEIGRPに再配布

続いて、OSPFで学習したルートをEIGRPのネットワークに再配布していきたいと思います。前回でも教えましたが、ちゃんとメトリックを指定しないとルートは流れませんので、注意してくださいね!

 

【RT2】

RT2(config)#router eigrp 1

RT2(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500

 

 

ルーティングの確認

それでは、ルーティングテーブルの確認をしていきましょう。今回は、スタブのお勉強ですので、関係があるルータ4だけに絞って確認していきたいと思いますが自宅ラボをお持ちの方は、他の機器でも確認してみてくださいね。

 

【RT4】

RT4#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
O E2 10.10.1.0/24 [110/20] via 10.10.3.3, 00:09:54, FastEthernet0/0
O IA 10.10.2.0/24 [110/2] via 10.10.3.3, 00:09:54, FastEthernet0/0
C 10.10.3.0/24 is directly connected, FastEthernet0/0
O IA 10.1.1.2/32 [110/3] via 10.10.3.3, 00:09:54, FastEthernet0/0
O 10.1.1.3/32 [110/2] via 10.10.3.3, 00:09:54, FastEthernet0/0
O E2 10.1.1.1/32 [110/20] via 10.10.3.3, 00:09:54, FastEthernet0/0
C 10.1.1.4/32 is directly connected, Loopback0

 

想定通り、全てのルートを受け取れていることが確認出来ましたか?この中でも注目して見てもらいのが、「E2」の外部ルートで学習している2ルートです。この2つのルートは、エリア1が標準エリアのため外部ルートとして表示されていますが、スタブエリアにするとどのような影響を受けるのでしょうか?これから試してみたいと思います。

 

OSPFのスタブ設定

それでは、エリア1をスタブエリアにしていこうと思います。今回の構成ですと、ルータ3とルータ4でエリア1を使っているため、このエリアをスタブに変更していきたいと思います。設定の内容は簡単で、エリアをスタブに指定するだけです。

 

【スタブエリア】

 

【RT3】

RT3(config)#router ospf 1

RT3(config-router)#area 1 stub

 

【RT4】

RT4(config)#router ospf 1

RT4(config-router)#area 1 stub

 

たったこれだけです。簡単ですが、ABRのルータ3だけで設定するのではなく、エリアに属する全ての機器で設定しないとネイバーを確立することができません。商用環境で変更する際は、注意しないといけませんね。

 

 

ルーティング確認

それではルーティングテーブルを確認していこうと思います。先程の「E2」ルートはどうなったでしょうか。

 

【RT4】

RT4#show ip route

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O IA 10.10.2.0/24 [110/2] via 10.10.3.3, 00:00:01, FastEthernet0/0
C 10.10.3.0/24 is directly connected, FastEthernet0/0
O IA 10.1.1.2/32 [110/3] via 10.10.3.3, 00:00:01, FastEthernet0/0
O 10.1.1.3/32 [110/2] via 10.10.3.3, 00:00:01, FastEthernet0/0
C 10.1.1.4/32 is directly connected, Loopback0
O*IA 0.0.0.0/0 [110/2] via 10.10.3.3, 00:00:01, FastEthernet0/0

 

以下の2つのルートがなくなっていることが、わかりますでしょうか。

<先程の「E2」ルート>

O E2 10.1.1.1/32 [110/20] via 10.10.3.3, 00:09:54, FastEthernet0/0

O E2 10.10.1.0/24 [110/20] via 10.10.3.3, 00:09:54, FastEthernet0/0

 

これは、外部(EIGRP)から学習したルートをスタブエリアには配布しないというルールがあるからです。これによりスタブエリア内のルータ(L3スイッチ)には、外部ルートが表示されなくなるのです。それでは、スタブエリアからは外部のルートに到達できないのか?というと、そうではありません。スタブエリアには外部ネットワークに到達するために、ABR(ルータ3)からデフォルトルートが配布されます。

 

先程のルーティングテーブルの一番最後に記載されているのが、それにあたります。このようにしてOSPFのスタブエリアには、ルート情報を減らして伝達することで、負荷を軽減させているのです。

 

まとめ

ベル

今回の授業は、ここまでにします。まだスタブエリアについては学ぶべきことがありますし、トータリースタブやNSSAなど多くのエリアがあります。まずは、ここまでをしっかりと抑えておきましょうね。それでは、次のトータリースタブエリアに進みましょう。

 

OSPFの設定 ~トータリースタブ編~

 

【詳解OSPF(Network Technology Series)】

詳解OSPF (Network Technology Series)

中古価格
¥6,399から
(2018/9/9 21:22時点)

【ルーティング&スイッチング標準ハンドブック】

ルーティング&スイッチング標準ハンドブック 一番大切な知識と技術が身につく

Follow me!

OSPFの設定 ~スタブ編~” に対して1件のコメントがあります。

  1. 石畳のん♪ より:

    授業には全く付いていけない劣等生と化してしまった石畳のん♪ですが・・・
    カズさんの御実家が北海道と、以前に伺っていたので、何処かは知りませんが
    今回の地震の影響が無ければよいと、心配しております。大丈夫でしたか??
    こうして更新をされているのだから、きっとOKですね?そうであります様に!

    追伸
    これまた全然関係ない話で恐縮ですが、9年間書き続けた「はてなダイアリー」が
    来春で終了とのことで、「はてなブログ」(今書いているのとは別のブログに?)
    移行しようかと思っています。記事の長さにもよりますが、9年分あると、かなり
    時間が掛かる作業でしょうか?ざっくりでいいので教えて頂けると嬉しいです♪

    1. ベル より:

      石畳のん様
      コメントありがとうございます。
      北海道の震災は大丈夫でした。仕事の方が忙しくてバタバタはしていますが。。

      ブログの移行に関しては、いい方法を探してみますね。(僕は移行しなかったもので・・・。)
      何か方法があれば、はてなの方にコメントさせていただきます。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です