OSPFの設定 ~再配布編~

ベル

今回の授業は、EIGRPとOSPFのルート再配布について勉強してみたいと思います。以前に勉強したEIGRPも出てくるので、忘れてしまった方は、こちらも復習しておきましょうね!

 

OSPFの授業

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

OSPFの設定 ~シングルエリア編①~

OSPFの設定 ~シングルエリア編②~

OSPFの設定 ~マルチエリア編~

 

EIGRPの基礎

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

 

 

お勉強構成

それでは、さっそく、お勉強構成から。こんな感じの構成を組んでいこうと思いますので、実機のある方は真似して構成組んでみてください。

 

 

事前設定

それでは、OSPFの勉強をする前に事前の設定を入れていきましょう。

 

インターフェイス設定

まずは、いつも通りのインターフェイス設定です。お勉強構成図を見ながら設定してみましょうね。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

【RT2】

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

RT2(config-if)#interface FastEthernet1

RT2(config-if)#ip address 10.10.2.2 255.255.255.0

 

【RT3】

RT3(config)#interface Loopback0

RT3(config-if)#ip address 10.1.1.3 255.255.255.255

RT3(config-if)#interface FastEthernet0/0

RT3(config-if)#ip address 10.10.2.3 255.255.255.0

 

 

EIGRP設定

以前の授業でも教えてたと思いますが、忘れてしまった方は、振り返りながら設定していきましょうね。今回は、特段難しいことをやらずに、ネットワーク設定だけにしておきましょう。

 

【RT1】

RT1(config)#router eigrp 1

RT1(config-router)#network 10.1.1.1 0.0.0.0

RT1(config-router)#network 10.10.1.0 0.0.0.255

 

【RT2】

RT2(config)#router eigrp 1

RT2(config-router)#network 10.10.1.0 0.0.0.255

 

 

OSPF設定

ここまで事前設定が問題なく出来たら、本題であるOSPFの設定をしていきましょう。

 

OSPFの基本設定

まずは、ここまでやってきたOSPFの基本設定をしていきましょう。まずは、ルータIDとネットワーク設定までを投入していきますが、以前の設定を覚えていますか?忘れてしまった方は、復習しながら思い出してくださいね!

 

【RT2】

RT2(config)#router ospf 1

RT2(config)#router-id 10.1.1.2

RT2(config-router)#network 10.10.2.0 0.0.0.255 area 0

RT2(config-router)#network 10.1.1.2 0.0.0.0 area 0

 

【RT3】

RT3(config)#router ospf 1

RT2(config)#router-id 10.1.1.3

RT3(config-router)#network 10.10.2.0 0.0.0.255 area 0

RT3(config-router)#network 10.1.1.3 0.0.0.0 area 0

 

ここまで設定が出来たら、ネットワーク機器間の配線をしてみましょう。LANケーブルの配線ってあまり深く考えずにやりがちなんですが、実際の工事トラブルの多くが物理作業だったりします。ケーブル1本の接続間違えで、ネットワークが全断してしまうことだってあるのです。構成図をちゃんと見てやりましょうね!

 

 

正常性確認①

さて、ここまで出来たら正常性の確認を行っていきましょう!今回は、重要となるコマンドだけで確認していこうと思いますが、本来であれば以下のコマンドくらいは確認すべきです。ここでは、コマンドだけの紹介とさせていただきますので、ラボで検証される際は、確認しておきましょう。

 

<確認コマンド>

 

この中でも、最も重要となる『show ip eigrp neighber』『show ip ospf neighbor』『show ip route』だけを確認していくことにします。

 

show ip eigrp neighber

今回の構成ですと、EIGRPを使っているのは、RT1とRT2だけになりますね。そのため、この2台だけでネイバーの確認をしましょう。以下のように隣接する機器のIPアドレス、インターフェイスが構成通りになっていることが確認できればOKです。

 

【RT1】

RT1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H  Address   Interface  Hold Uptime  SRTT  RTO   Q   Seq
(sec)            (ms)          Cnt  Num
10.10.1.2 Fa0         12 00:18:53  1589  5000  0    2

 

【RT2】

RT2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H  Address   Interface  Hold Uptime  SRTT  RTO   Q   Seq
(sec)            (ms)          Cnt  Num
10.10.1.1 Fa0         12 00:22:56  4        300    0    2

 

ネイバーが確立していない場合は、コンフィグをちゃんと確認してみましょう。結構、凡ミスだったりしますよ。

 

show ip ospf neighber

今回の構成ですと、OSPFを使っているのは、RT2とRT3だけになりますね。そのため、この2台だけでネイバーの確認をしましょう。以下のように隣接する機器のIPアドレス、ステータス、インターフェイスが構成通りになっていることが確認できればOKです。

 

【RT2】

RT2#show ip ospf neighbor

Neighbor ID Pri State   Dead Time  Address   Interface
10.1.1.3 1 FULL/BDR 00:00:33   10.10.2.3 FastEthernet1

 

【RT3】

RT3#show ip ospf neighbor

Neighbor ID  Pri State    Dead Time  Address    Interface
10.1.1.2 255 FULL/DR 00:00:32    10.10.2.2 FastEthernet0/0

 

show ip route

それでは、最後にルーティングテーブルを見ていきましょう。

 

【RT1】

RT1#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.1.1.1/32 is directly connected, Loopback0
C 10.10.1.0/24 is directly connected, FastEthernet0

 

【RT2】

RT2#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.10.1.0/24 is directly connected, FastEthernet0
C 10.10.2.0/24 is directly connected, FastEthernet1
C 10.1.1.2/32 is directly connected, Loopback0
O 10.1.1.3/32 [110/2] via 10.10.2.3, 00:36:23, FastEthernet1
D 10.1.1.1/32 [90/156160] via 10.10.1.1, 00:37:21, FastEthernet0

 

【RT3】

RT3#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.10.2.0/24 is directly connected, FastEthernet0/0
O 10.1.1.2/32 [110/2] via 10.10.2.2, 00:35:25, FastEthernet0/0
C 10.1.1.3/32 is directly connected, Loopback0

 

ここまで確認すると、EIGRPやOSPFの設定に問題がないのに、EIGRPとOSPF間でルート情報が交換されていないことがわかりますね。なぜなら、EIGRPとOSPFで別のルーティングプロトコルが使われているため、相互でルート情報の交換がなされていないからなんです。

 

ルート再配布

それでは、今回の授業のメインともなる『ルート再配布』について勉強していきましょう。今回使用しているルーティングプロトコルはEIGRPとOSPFとなり、相互で全てのルート情報を交換できるようにしていこうと思います。

 

OSPFのルート情報をEIGRPに再配布

それでは最初に、OSPFのルート情報をEIGRPに再配布してみたいと思います。ただ再配布するだけなのですが、EIGRPにOSPFを再配布するときは、メトリックを設定しないとルートが流れません。注意してくださいね。今回は、とりあえず以下の内容で指定しておこうと思います。

 

 

【RT2】

RT2(config)#router eigrp 1

RT2(config-router)#redistribute ospf 1 metric 100000 100 255 1 1500

 

これによりEIGRP1にOSPF1で学習したルートを再配布することができます。しかし、他のルーティングプロトコルなども再配布したい場合は、都度メトリックを指定なければならず、めんどくさいですよね。その場合、デフォルトのメトリックを指定しておくことで、とりあえずの再配布が可能となります。以下のような設定になります。

 

RT2(config)#router eigrp 1

RT2(config-router)#redistribute ospf 1

RT2(config-router)#default-metric 100000 100 255 1 1500

 

 

EIGRPのルート情報をOSPFに再配布

次にEIGRPのルート情報をOSPFに再配布してみたいと思います。こちらは単純にメトリック指定をせずに再配布してみたいと思います。最後の『subnet』を忘れずにしてくださいね!

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#redistribute eigrp 1  subnets

 

これで相互の再配布設定は完了になります。これだけなので、すごい簡単ですね!

 

正常性確認②

それでは、ここまでの正常性確認を実施していきましょう。

 

show ip route

今回はルーティングテーブルの確認だけにします。先程なかったルートが増えていることを確認していきましょう。

 

【RT1】

RT1#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.1.1.1/32 is directly connected, Loopback0
D EX 10.1.1.2/32 [170/53760] via 10.10.1.2, 00:00:42, FastEthernet0
D EX 10.1.1.3/32 [170/53760] via 10.10.1.2, 00:00:42, FastEthernet0
C 10.10.1.0/24 is directly connected, FastEthernet0
D EX 10.10.2.0/24 [170/53760] via 10.10.1.2, 00:00:42, FastEthernet0

ルータ2から受け取っていなったOSPFのルートが増えていることが分かりましたか?

 

 

【RT3】

RT3#show ip route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O E2 10.10.1.0/24 [110/20] via 10.10.2.2, 01:05:42, FastEthernet0/0
C 10.10.2.0/24 is directly connected, FastEthernet0/0
O 10.1.1.2/32 [110/2] via 10.10.2.2, 01:05:53, FastEthernet0/0
C 10.1.1.3/32 is directly connected, Loopback0
O E2 10.1.1.1/32 [110/20] via 10.10.2.2, 01:05:42, FastEthernet0/0

RT2がEIGRPで学習したルートをちゃんともらえるようになりましたね。外部ルートとして学習したため、コードが『E2』で表示されていますね。このようになっていれば問題なしです。この外部ルートにするコードは、『E2』の他に『E1』がありますが、これは次回以降に解説しますが、Ciscoではデフォルトで『E2』になります。

 

 

まとめ

ベル

今回の授業はいかがでしたか?EIGRPとOSPFの再配布について、基本的なところだけを教えてきましたが、理解することはできましたか?再配布されると、それまでのメトリックはリセットされてしまうため、ちゃんと検討しておく必要があります。自宅ラボなどで、多くのパターンを検証しておくことが大切になります。

 

【ゼロからはじめるCCNA 「超」基礎講座】

ゼロからはじめるCCNA「超」基礎講座

ゼロからはじめるCCNA「超」基礎講座 (Informatics&IDEA)

新品価格
¥2,570から
(2018/9/2 23:47時点)

【短期集中!CCNA Routing and Switching】

短期集中!CCNA Routing and Switching/CCENT教本

 

短期集中! CCNA Routing and Switching/CCENT教本

新品価格
¥3,024から
(2018/9/2 23:48時点)

ベル

次は、OSPFのスタブエリアについてお勉強しましょう!まだまだ続きますよ~。

 

OSPFの設定 ~スタブ編~

 

OSPFの授業

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

OSPFの設定 ~シングルエリア編①~

OSPFの設定 ~シングルエリア編②~

OSPFの設定 ~マルチエリア編~

OSPFの設定 ~スタブ編~

 

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です