OSPFの設定 ~マルチエリア編~

ベル

今回の授業は、『OSPFのマルチエリア』について少し勉強してみましょう。今まではシングルエリアの設定をしてきましたが、設定自体はそれ程変わりませんので、難しいかもしれませんが、ゆっくりと読み進めてもらえればと思います。まだシングルエリアでの授業を受けられていない方は、こちらからお勉強してくださいね!

 

OSPFの授業

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

OSPFの設定 ~シングルエリア編①~

OSPFの設定 ~シングルエリア編②~

 

 

お勉強構成

それでは、今回のお勉強構成は以下の感じでいきますよ。ルータ2がABR(Area Border Router)であることがわかりますね。

 

以前の授業でも教えましたが、OSPFのバックボーンエリア(エリア0)と標準エリア間では、何も設定しないと全てのルート情報が交換されるようになっています。後でゆっくりとみていくことにしましょう。

 

事前設定

それでは、OSPFの事前設定からいきますよ。毎回、同じような事前設定でめんどくさくなっている方もいるかもしれませんが、上級者になるために一番の近道は、コマンドをどれだけたくさん打ち込んだかなんです。めんどくさがらずにやりましょうねー。

 

【RT1】

RT1(config)#interface Loopback0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

RT1(config-if)#interface FastEthernet0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

 

 

【RT2】

RT2(config)#interface Loopback0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

RT2(config-if)#interface FastEthernet0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

RT2(config-if)#interface FastEthernet1

RT2(config-if)#ip address 10.10.2.2 255.255.255.0

 

 

【RT3】

RT3(config)#interface Loopback0

RT3(config-if)#ip address 10.1.1.3 255.255.255.255

RT3(config-if)#interface FastEthernet0/0

RT3(config-if)#ip address 10.10.2.3 255.255.255.0

 

はい!ここまで。インターフェイスへのアドレス割当は、出来ましたか?それでは、OSPFの設定に入っていきます。

 

OSPFの設定

今回のポイントは、エリアを分割することですね。それ以外の設定は、さらっとやってしまいましょう。

 

OSPFのプロセスIDとルータID

まずは、OSPFのプロセスIDとルータIDの指定ですね。この辺は、前回と同様に指定していくだけですね。

 

【RT1】

RT1(config)#router ospf 1

RT1(config-router)#router-id 10.1.1.1

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#router-id 10.1.1.2

 

【RT3】

RT3(config)#router ospf 1

RT3(config-router)#router-id 10.1.1.3

 

プライオリティ値の設定

今回は、ネイバー関係を構築するインターフェイスにプライオリティ値を設定してDRとBDRを明確に指定しておきたいと思います。わかりやすいように、ルータ1とルータ2間はルータ1のインターフェイス(FastEthernet0)に255のプライオリティ値を、ルータ2とルータ3間はルータ2のインターフェイス(FastEthernet0)に255のプライオリティ値を指定したいと思います。

 

【RT1】

RT1(config)#interface FastEthernet0

RT1(config-if)#ip ospf priority 255

 

【RT2】

RT2(config)#interface FastEthernet1

RT2(config-if)#ip ospf priority 255

 

 

ネットワークの設定

ルータ1はエリア0を、ルータ2はエリア0と1を、ルータ3はエリア1に属するように、それぞれのインターフェイスアドレスを構成図通りに指定するだけです。それでは、設定していきましょう。

 

【RT1】

RT1(config)#router ospf 1

RT1(config-router)#network 10.1.1.1 0.0.0.0 area 0

RT1(config-router)#network 10.10.1.0 0.0.0.255 area 0

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#network 10.1.1.2 0.0.0.0 area 0

RT2(config-router)#network 10.10.1.0 0.0.0.255 area 0

RT2(config-router)#network 10.10.2.0 0.0.0.255 area 1

 

【RT3】

RT3(config)#router ospf 1

RT3(config-router)#network 10.1.1.3 0.0.0.0 area 1

RT3(config-router)#network 10.10.2.0 0.0.0.255 area 1

 

 

OSPFの確認①

これでOSPFの設定が完了しましたので、ステータスの確認をしていきたいと思います。今回は、だいぶ簡略化しますが、商用ネットワークの構築時は、もっとちゃんと確認しましょうね。

 

OSPFネイバー確認

それでは、物理的な構成に誤りがないことを前提に、OSPFネイバー確認からさせていただきます。確認に使うコマンドは『show ip ospf neighbor』でしたね。以下のような結果が表示されていたらOKです。

 

【RT1】

RT1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.1.2 1 FULL/BDR 00:00:34 10.10.1.2 FastEthernet0

 

【RT2】

RT2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 255 FULL/DR 00:00:35 10.10.1.1 FastEthernet0
10.1.1.3 1 FULL/BDR 00:00:34 10.10.2.3 FastEthernet1

 

【RT3】

RT3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.1.2 255 FULL/DR 00:00:39 10.10.2.2 FastEthernet0/0

 

 

ルーティングテーブルの確認

それではルーティングテーブルを確認してみましょう。ここでチェックしてもらいたいのが、Codesで『O』と『O IA』の行ですね。どちらもOSPFで学習したルートなのですが、『O』の方は自信が所属しているエリア内のルートで、『O IA』は、別のエリアからもらったルートのこととなります。

 

ルータ1で言うと、『10.1.1.3/32』がルーティングテーブルに表示されていますが、これはエリア1のルータ3から学習したルートのため『O IA』で表示されていることになります。またルータ2は、エリア0と1の両方に属しているので、『O IA』はなく『O』だけがルーティングテーブルにあることがわかりますね。

 

【RT1】

RT1#show ip route

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C        10.1.1.1/32 is directly connected, Loopback0
O        10.1.1.2/32 [110/2] via 10.10.1.2, 00:58:57, FastEthernet0
O IA    10.1.1.3/32 [110/3] via 10.10.1.2, 00:23:08, FastEthernet0
C        10.10.1.0/24 is directly connected, FastEthernet0
O IA   10.10.2.0/24 [110/2] via 10.10.1.2, 00:23:23, FastEthernet0

 

【RT2】

RT2#show ip route

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.10.1.0/24 is directly connected, FastEthernet0
C       10.10.2.0/24 is directly connected, FastEthernet1
C       10.1.1.2/32 is directly connected, Loopback0
O       10.1.1.3/32 [110/2] via 10.10.2.3, 00:30:41, FastEthernet1
O       10.1.1.1/32 [110/2] via 10.10.1.1, 00:32:41, FastEthernet0

 

【RT3】

RT3#show ip route

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O IA   10.10.1.0/24 [110/2] via 10.10.2.2, 00:33:01, FastEthernet0/0
C       10.10.2.0/24 is directly connected, FastEthernet0/0
O IA   10.1.1.2/32 [110/2] via 10.10.2.2, 00:33:01, FastEthernet0/0
C       10.1.1.3/32 is directly connected, Loopback0
O IA   10.1.1.1/32 [110/3] via 10.10.2.2, 00:33:01, FastEthernet0/0

 

 

ルート制御設定の追加

それでは、前回のルート制御をエリア間でやってみましょう。前回は、同一エリア内でルート制御をしようとしたら、設定しているルータではルーティングテーブルから削除することができましたが、すぐ後ろのルータではルーティングテーブルに表示されてしまいましたよね。それは、同一エリア内のルータでは、同一のルート情報を共有するからでしたね。今回は、エリア分割してルート制御してみます。

 

プレフィックスリストの設定

まずは、プレフィックスリストというリストを作成して、エリア0からエリア1に配布したいルートを指定していきます。今回はも、前回の授業と同じ制御をしたいと思いますので、ルータ1のLoopback0アドレス(10.1.1.1)をエリア0からエリア1に配布しないようにしたいと思います。それ以外のルートはすべて、配布しても問題ないものとします。それを『test』という名前のプレフィックスリストに定義すると以下のような設定となります。

 

【RT2】

RT2(config)#ip prefix-list test deny 10.1.1.1/32

RT2(config)#ip prefix-list test permit 0.0.0.0/0 le 32

 

 

フィルタリストの設定

先に定義したプレフィックスリスト『test』をOSPFのエリア0から他のエリアに配布する『OUT方向』に適用してみたいと思います。

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#area 0 filter-list prefix test out

 

たったこれだけです。この設定はエリア0から他の全てのエリアに『10.1.1.1』を配布しない場合に使用する方式ですが、逆にどのエリアからでもエリア1は『10.1.1.1』のルートを受け取らないように設定することもできます。今回の構成で言えば、どちらの設定でも結果は一緒になりますね。

 

<サンプル>

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#area 1 filter-list prefix test in

 

こんな感じで設定するとエリア1に配布されようとするルートを制御することができるようになります。どちらがいいということではなく、要件に応じて設定する方向を変更するようにしてください。

 

OSPFの確認②

それでは、ルーティングが想定通りになっているかを確認してみましょう。以下のようにルータ3のルーティングテーブルに『10.1.1.1/32』が載っていなければOKとなります。

 

【RT3】

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
O IA   10.10.1.0/24 [110/2] via 10.10.2.2, 00:01:33, FastEthernet0/0
C       10.10.2.0/24 is directly connected, FastEthernet0/0
O IA   10.1.1.2/32 [110/2] via 10.10.2.2, 00:01:33, FastEthernet0/0
C       10.1.1.3/32 is directly connected, Loopback0

 

事前では、『O IA   10.1.1.1/32 [110/3] via 10.10.2.2, 00:33:01, FastEthernet0/0』があったと思いますが、これが先程の設定で『10.1.1.1』がなくなるようにしましたので、上記のようになっていたら成功です。もし、この通りになっていなければ、適用してるプレフィックスリスト名が誤っていたりしてる可能性がありますので、ちゃんと確認してみてください。

 

まとめ

ベル

今回の授業はいかがでしたか?いきなりマルチエリアからルートフィルタまで駆け足で説明してしまって、難しかったかもしれませんね。同じ構成で何度も設定投入してみて、コマンドと動作を学んでおいてください。特に、マルチエリアになると、どんどん複雑になっていきますので、ここで復習をしておくようにしましょう。それでは、次の再配布の授業にいきましょう。

 

OSPFの設定 ~再配布編~

 

OSPFの授業

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

OSPFの設定 ~シングルエリア編①~

OSPFの設定 ~シングルエリア編②~

 

その他のルーティング

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

 

Follow me!

OSPFの設定 ~マルチエリア編~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です