OSPFの設定 ~シングルエリア編②~

ベル

今回の授業は、『OSPFのルート制御』について教えていこうと思います。前回までの授業ができていることが前提となりますので、まだ受講していない方はこちらからお勉強していきましょう。

 

OSPFの授業

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

OSPFの設定 ~シングルエリア編①~

 

 

お勉強構成

今回のお勉強構成は、こんな感じになります。まだまだシンプルにシングルエリア構成です。

 

 

 

事前設定

OSPFのお勉強に入る前に、以下のような事前設定をしておきましょう。

 

【RT1】

RT1#configure terminal

RT1(config)#interface loopback 0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

RT1(config)#interface fastEthernet 0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

RT1(config-if)#no shutdown

 

【RT2】

RT2#configure terminal

RT2(config)#interface loopback 0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

RT2(config)#interface fastEthernet 0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

RT2(config-if)#no shutdown

RT2(config)#interface fastEthernet 1

RT2(config-if)#ip address 10.10.2.2 255.255.255.0

RT2(config-if)#no shutdown

 

【RT3】

RT3#configure terminal

RT3(config)#interface loopback 0

RT3(config-if)#ip address 10.1.1.3 255.255.255.255

RT3(config)#interface fastEthernet 0/0

RT3(config-if)#ip address 10.10.2.3 255.255.255.0

RT3(config-if)#no shutdown

 

 

OSPFの設定

それでは、OSPFの勉強となる設定をしていきましょう。

 

OSPFの基本設定

前回の授業で設定した内容については、さらっと復習しながら入れていきましょう。以下の順番で設定していきましょう。

 

 

【RT1】

RT1(config)#router ospf 1

RT1(config-router)#router-id 10.1.1.1

RT1(config-router)#network 10.1.1.1 0.0.0.0 area 0

RT1(config-router)#network 10.10.1.0 0.0.0.255 area 0

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#router-id 10.1.1.2

RT2(config-router)#network 10.1.1.2 0.0.0.0 area 0

RT2(config-router)#network 10.10.1.0 0.0.0.255 area 0

RT2(config-router)#network 10.10.2.0 0.0.0.255 area 0

 

【RT3】

RT3(config)#router ospf 1

RT3(config-router)#router-id 10.1.1.3

RT3(config-router)#network 10.1.1.3 0.0.0.0 area 0

RT3(config-router)#network 10.10.2.0 0.0.0.255 area 0

 

ここまでは前回の授業でやっていたことなので、問題なくできましたか?もしつまずくようでしたら、前回の授業を復習してみてください。

 

 

ルーティング確認

それでは前回と同様にOSPFのネイバーやデータベースルーティングを確認したいところですが、今回は割愛させてもらいます。この後の授業に関係あるルーティングを中心にチェックしておきます。

 

【RT2】

RT2#show ip route

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C 10.10.1.0/24 is directly connected, FastEthernet0
C 10.10.2.0/24 is directly connected, FastEthernet1
C 10.1.1.2/32 is directly connected, Loopback0
O 10.1.1.3/32 [110/2] via 10.10.2.3, 00:01:30, FastEthernet1
O 10.1.1.1/32 [110/2] via 10.10.1.1, 00:01:30, FastEthernet0

 

今回は、ルートフィルタを設定して、RT1のLoopback0アドレスをRT2のルーティングテーブルから削除してみたいと思います。

 

OSPFのフィルタ設定

それでは、RT2にてOSPFのフィルタ設定を追加してみたいと思います。今回はRT1のLoopbackアドレスのみを受け取らないようにアクセスリストを設定したいので、最後に『permit any』を追加しておきます。というのは、アクセスリストには暗黙のdenyがあるため、必ず『permit』がないとすべての通信を拒否してしまうからです。

 

【RT2】

RT2(config)#access-list 10 deny 10.1.1.1

RT2(config)#access-list 10 permit any

 

これでアクセスリストの追加完了です。このアクセスリストを『distribute-list』というリストに紐づけて、使用したいインターフェイスに適用させます。その際にフィルタを適用する方向というものがあり、『IN方向』と『OUT方向』のどちらかを決めます。ただし、注意しなければいけないのが、OSPFでは『OUT』方向へのフィルタ設定は出来ないということです。今回は、RT2で設定するので、RT1と接続しているインターフェイス(FastEthernet0)の『IN』方向に設定してきます。

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#distribute-list 10 in FastEthernet0

 

 

ルーティング確認

それでは、ルーティングテーブルの確認をしてみましょう。想定通りにルーティングはなくなっているでしょうか?

 

【RT2】

RT2#show ip route

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.1.0/24 is directly connected, FastEthernet0
C 10.10.2.0/24 is directly connected, FastEthernet1
C 10.1.1.2/32 is directly connected, Loopback0
O 10.1.1.3/32 [110/2] via 10.10.2.3, 00:10:38, FastEthernet1

 

よし!これで、ルーティングテーブルも完璧!って思われるかもしれませんが、まで安心してはいけません!RT3のルーティングテーブルも見てみましょう。

 

【RT3】

RT3#show ip route

10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O 10.10.1.0/24 [110/2] via 10.10.2.2, 00:51:03, FastEthernet0/0
C 10.10.2.0/24 is directly connected, FastEthernet0/0
O 10.1.1.2/32 [110/2] via 10.10.2.2, 00:51:03, FastEthernet0/0
C 10.1.1.3/32 is directly connected, Loopback0
O 10.1.1.1/32 [110/3] via 10.10.2.2, 00:51:03, FastEthernet0/0

 

「あれ?」って思われるかもしれませんが、これが正解なんです。というのは、以前の授業でも教えていますが、OSPFというは、同一エリア内で同じ地図を持ちます。ルートフィルタは、その地図からルーティングテーブルに載せるかどうかを制御する機能です。そのため、RT2がルーティングテーブルに載せなかったとしても、後ろにいるRT3にはルート情報を転送します。そのため、RT3のルーティングテーブルには載るようになるのです。

 

「じゃあルート制御なんて出来ないの?」って思われるかもしれませんが、大丈夫です。そのためにOSPFはエリア分割する機能があるのです。次回以降で学習していきます。

 

 

まとめ

ベル

今回の授業はいかがでしたか?OSPFのルート制御は難しいことがわかってもらえましたか?EIGRPみたいにルート制御にも制限があるので、最初にエリア設計をしておく必要があります。それでは、次の『OSPFの概要 ~設定編③~』でマルチエリアネットワークのお勉強をしていきましょう!

 

OSPFの概要 ~設定編③~

 

OSPFの授業

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

OSPFの設定 ~シングルエリア編①~

 

その他のルーティング

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~設定編①~

 

Follow me!

OSPFの設定 ~シングルエリア編②~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です