OSPFの設定 ~シングルエリア編①~

ベル

今回の授業は、『OSPF(Open Shortest Path First)の設定編』教えていこうと思います。以前にOSPFの基礎編で学んできたことを実際に機器に設定していきますので、ここまでのOSPFの授業をまだ受けていない方は、こちらから受けてくださいね。

 

OSPFの基礎

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

 

 

お勉強構成

それでは、今回のお勉強構成を紹介していきます。今回は基本的なコマンドのお勉強となるので、まずは、シングルエリア構成で学習していきたいと思います。

 

 

 

 

事前設定

それでは、OSPFの設定を勉強する前に事前設定をしておきましょう。まずは、今回使用するインターフェイスのアドレス設定をしますので、自分のラボ環境のインターフェイス番号に合わせて設定してみてください。

 

【RT1】

RT1#configure terminal

RT1(config)#interface loopback 0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

RT1(config)#interface fastEthernet 0

RT1(config-if)#ip address 10.10.1.1 255.255.255.0

RT1(config-if)#no shutdown

 

 

【RT2】

RT2#configure terminal

RT2(config)#interface loopback 0

RT2(config-if)#ip address 10.1.1.2 255.255.255.255

RT2(config)#interface fastEthernet 0

RT2(config-if)#ip address 10.10.1.2 255.255.255.0

RT2(config-if)#no shutdown

 

 

【RT3】

RT3#configure terminal

RT3(config)#interface loopback 0

RT3(config-if)#ip address 10.1.1.3 255.255.255.255

RT3(config)#interface fastEthernet 0/0

RT3(config-if)#ip address 10.10.1.3 255.255.255.0

RT3(config-if)#no shutdown

 

 

 

OSPFの設定

それでは、OSPFの設定をしていきましょう。今回は基本的な設定しないので、ゆっくり覚えていきましょう!

 

ルータIDの設定

まずは、『router ospf numでプロセスIDを指定してOSPFを起動させます。その後に、ルータID『router-id xx.xx.xx.xx』で指定します。これはネイバー関係を確立する前に設定しておかないと、再起動しないと反映されないことがあるので、まず先に設定してしまいましょう。

 

【RT1】

RT1(config)#router ospf 1

RT1(config-router)#router-id 10.1.1.1

 

【RT2】

RT2(config)#router ospf 1

RT2(config-router)#router-id 10.1.1.2

 

【RT3】

RT3(config)#router ospf 1

RT3(config-router)#router-id 10.1.1.3

 

 

OSPFのネットワーク設定

OSPFのネイバー関係を構築するには、2つ方法があります。OSPFネットワークに属するインターフェイスのセグメントをネットワーク設定で含む方法とネイバー関係を構築したい相手のアドレスを指定する方法があります。今回は、ネットワークで指定してみます。

 

『network network wildcard-mask area numでOSPFを動作させたいインターフェイスのアドレスを含めるように設定します。それによりOSPFで動作している機器を探しに行くようになります。それでは、実際のルータに設定を入れてみますね。おっと!Loopbackアドレスも含めることを忘れてはいけないでくださいね!

 

【RT1】

RT1(config-router)#network 10.1.1.1 0.0.0.0 area 0

RT1(config-router)#network 10.10.1.0 0.0.0.255 area 0

 

【RT2】

RT2(config-router)#network 10.1.1.2 0.0.0.0 area 0

RT2(config-router)#network 10.10.1.0 0.0.0.255 area 0

 

【RT3】

RT3(config-router)#network 10.1.1.3 0.0.0.0 area 0

RT3(config-router)#network 10.10.1.0 0.0.0.255 area 0

 

 

プライオリティの設定

プライオリティは、DR/BDRをセグメント単位で選択する際に優先させるために使います。そのため設定は、インターフェイスに直接していきます。設定するコマンドは簡単で『ip ospf priority numを投入するだけです。設定可能な数値は『0~255』までとなっており、数値が大きいほどDR(BDR)に優先的に選出されるようになります。今回は、RT1に『255』を設定してDRに、RT2に『128』を設定してBDRにさせてみたいと思います。

 

【RT1】

RT1(config)#interface fastEthernet 0

RT1(config-if)#ip ospf priority 255

 

 

【RT2】

RT2(config)#interface fastEthernet 0

RT2(config-if)#ip ospf priority 128

 

 

ここまで出来たら設定は終了です。お勉強構成を元にステータスを確認していきましょう。

 

 

ステータス確認

今回は、OSPFに特化した内容だけを確認していきますが、本来の作業であれば、物理層からきちんと確認していくのが当たり前です。最低限、以下のコマンドくらいは確認しておきましょうね。

 

 

最後にPingの疎通確認が含まれていますが、商用環境であれば送信数やサイズなどを調整してLANケーブルの品質確認なども実施しておくことをおすすめします。

 

OSPFのネイバー確認

まずは、OSPFのネイバー関係かちゃんと確立できているかを確認してみましょう。

 

【RT1】

RT1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.1.2 128 FULL/BDR 00:00:36 10.10.1.2 FastEthernet0
10.1.1.3 1 FULL/DROTHER 00:00:32 10.10.1.3 FastEthernet0

 

ここでは、ネイバーのルータIDプライオリティ値役割(DR/BDR/DROTHER)接続されたインターフェイスのアドレスなどが表示されています。ここでネイバー関係が確立していないと次以降の確認の意味がなくなってしまうので、しっかり確認しておきましょうね!

 

もし、OSPFの役割(DR/BDR/DROTHER)が想定と異なる場合は、再起動を行うか、『clear ip ospf process』OSPFのネイバー関係を再構築する必要があります。これは、OSPFの基礎編でも教えましたが、OSPFのプライオリティ値よりも起動時間が優先されてしまうためです。ピンとこない方は、基礎編を復習してみてください。それでは、RT2とRT3についてもステータスを確認しておきましょう!

 

【RT2】

RT2#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 255 FULL/DR 00:00:35 10.10.1.1 FastEthernet0
10.1.1.3 1 FULL/DROTHER 00:00:30 10.10.1.3 FastEthernet0

 

【RT3】

RT3#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
10.1.1.1 255 FULL/DR 00:00:37 10.10.1.1 FastEthernet0/0
10.1.1.2 128 FULL/BDR 00:00:37 10.10.1.2 FastEthernet0/0

 

 

OSPFのデータベース

次にOSPFのデータベースを確認してみましょう。使用するコマンドは『show ip ospf database』となります。ここでは、まず自身の『ルータID』『OSPFのプロセスID』が最初に表示されています。その後に『Router Link States』『Net Link States』に分かれて表示されているのがわかるでしょうか?

 

最初の『Router Link States』では、LSA-Type1を生成したルータの一覧が表示されます。LSA-Type1を生成するのはOSPFが起動しているルータすべてなので、今回の構成では、RT1、RT2、RT3の3台が表示されていれば想定通りとなります。ちなみに全てのルータの右端に『Link count』として『2』が表示されていると思いますが、この数値はOSPFが動作しているインターフェイスの数を表しています。今回の構成では接続するインターフェイス以外にLoopbackインターフェイスも含めているので『2』が表示されることになります。

 

次の『Net Link States』では、LSA-Type2を生成したルータの情報が表示されています。この構成ではRT1がDRになるため、RT1のルートIDが表示されているはずです。この情報は当然、他のルータでも同様の内容が表示されているはずです。

 

 

【RT1】

RT1#show ip ospf database

OSPF Router with ID (10.1.1.1) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
10.1.1.1 10.1.1.1 769 0x80000006 0x006F5A 2
10.1.1.2 10.1.1.2 642 0x80000003 0x0020A8 2
10.1.1.3 10.1.1.3 576 0x80000003 0x003490 2

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
10.10.1.1 10.1.1.1 769 0x80000005 0x0013D1

 

【RT2】

RT2#show ip ospf database

OSPF Router with ID (10.1.1.2) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
10.1.1.1 10.1.1.1 851 0x80000006 0x006F5A 2
10.1.1.2 10.1.1.2 723 0x80000003 0x0020A8 2
10.1.1.3 10.1.1.3 657 0x80000003 0x003490 2

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
10.10.1.1 10.1.1.1 851 0x80000005 0x0013D1

 

【RT3】

RT3#show ip ospf database

OSPF Router with ID (10.1.1.3) (Process ID 1)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
10.1.1.1 10.1.1.1 881 0x80000006 0x006F5A 2
10.1.1.2 10.1.1.2 753 0x80000003 0x0020A8 2
10.1.1.3 10.1.1.3 686 0x80000003 0x003490 2

Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
10.10.1.1 10.1.1.1 881 0x80000005 0x0013D1

 

 

ルーティングテーブル

それでは、最後にルーティングテーブルを見ていきます。今回は、OSPFの内部ルートしかないのですっきりした感じになると思いますが、一応、確認していきましょう。最初の文字が『C』になっているのは、『connected』の意味でインターフェイスに設定しているセグメントを意味します。もう一つ、『O』があると思いますが、これがOSPFで学習したルートになります。以下のようなルーティングテーブルになっていれば想定通りですね!

 

【RT1】

RT1#show ip route

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.1.1.1/32 is directly connected, Loopback0
O 10.1.1.2/32 [110/2] via 10.10.1.2, 00:48:05, FastEthernet0
O 10.1.1.3/32 [110/2] via 10.10.1.3, 00:47:21, FastEthernet0
C 10.10.1.0/24 is directly connected, FastEthernet0

 

 

【RT2】

RT2#show ip route

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.1.0/24 is directly connected, FastEthernet0
C 10.1.1.2/32 is directly connected, Loopback0
O 10.1.1.3/32 [110/2] via 10.10.1.3, 00:46:23, FastEthernet0
O 10.1.1.1/32 [110/2] via 10.10.1.1, 00:46:23, FastEthernet0

 

 

【RT3】

RT3#show ip route

10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
C 10.10.1.0/24 is directly connected, FastEthernet0/0
O 10.1.1.2/32 [110/2] via 10.10.1.2, 00:45:27, FastEthernet0/0
C 10.1.1.3/32 is directly connected, Loopback0
O 10.1.1.1/32 [110/2] via 10.10.1.1, 00:45:27, FastEthernet0/0

 

 

 

まとめ

ベル

今回の授業はいかがだったでしょうか?OSPFの基本的な設定を学習してきましたが、理解することは出来ましたか?次回以降もOSPFの設定を教えていこうと思いますので、まずは基本をしっかりと覚えて進めていきましょうね!次の授業はOSPFのルート制御は難しいことを知ってもらえることを学んでみましょう!

 

OSPFの設定 ~シングルエリア編②~

 

その他のルーティング

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~基礎編②~

EIGRPの概要 ~基礎編③~

EIGRPの概要 ~設定編①~

EIGRPの概要 ~設定編②~

 

Follow me!