EIGRPの概要 ~設定編②~

ベル

今回の授業は、『EIGRP(Enhanced Interior Gateway Routing Protocol)の応用設定』を教えていこうと思います。以前の授業で基礎設定を教えました。まずは、それが出来ることが前提とさせてもらいますので、まだ受講されていない方は、こちらから。

EIGRPの概要 ~設定編①~

 

検証前の準備

今回のお勉強構成は以下となります。まずは、構成図を頭に入れておきましょうね!

 

 

それでは、基本設定としてインターフェイスにアドレスの設定を投入していきましょう。

【RT1】

interface loopback 0

ip address 10.1.1.1 255.255.255.255

!

interface fastEthernet 0

ip address 10.0.0.1 255.255.255.0

no shutdown

 

【RT2】

interface fastEthernet 1

ip address 10.0.0.2 255.255.255.0

no shutdown

!

interface fastEthernet 0

ip address 10.0.1.1 255.255.255.0

no shutdown

 

【RT3】

interface fastEthernet 0/1

ip address 10.0.1.2 255.255.255.0

no shutdown

!

interface loopback 0

ip address 10.1.2.1 255.255.255.255

!

interface loopback 1

ip address 10.1.2.2 255.255.255.255

 

EIGRPのルーティング設定

インターフェイスのアドレス設定が終わったら、EIGRPの基本設定を入れていきましょう。以前のEIGRPの基本設定を入れたのを思い出しながら投入していきましょう。

 

まずは、『router eigrp 1』でEIGRPを有効にし、「AS1」のグループを作成します。それから自動経路集約を無効にするために、『no auto-summary』を投入しておきますね。それから各インターフェイスをEIGRP AS1に属するための『network』設定をセグメント単位で指定しておきます。

 

これは、セグメント単位ではなく、インターフェイスのアドレス単位でも、集約して指定することも出来ます。多くのインターフェイスをEIGRPのネットワークに属する場合は、まとめて指定した方がいいので、設計に合わせて設定するようにしましょう。

 

【RT1】

router eigrp 1

no auto-summary

network 10.1.1.1 0.0.0.0

network 10.0.0.0 0.0.0.255

 

【RT2】

router eigrp 1

no auto-summary

network 10.0.0.0 0.0.0.255

network 10.0.1.0 0.0.0.255

 

【RT3】

router eigrp 1

no auto-summary

network 10.1.2.1 0.0.0.0

network 10.1.2.2 0.0.0.0

 

設定内容の確認

ここまで設定が出来たら、一度、ネットワーク機器間を接続していきましょう。物理作業をするときはちゃんと構成図を見ながら作業しましょうね。物理作業が正確にできていないが故に、トラブルになること結構多かったりしますので、作業後の確認も忘れずに!

 

今回の確認コマンドは、『show ip eigrp neighbor』『show ip route』だけとします。この時点では、以下の内容になっていれば問題ないと思います。

 

EIGRPのネイバー確認

まずは、EIGRPのネイバー確認を行います。「RT1」のネイバーは「RT2」、「RT2」のネイバーは「RT1」と「RT3」、「RT3」のネイバーは「RT2」となっていれば想定通りですね。以下の黒板で確認してください。

 

 

【RT1】

RT1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address    Interface    Hold Uptime    SRTT    RTO    Q    Seq
(sec)               (ms)             Cnt   Num
0   10.0.0.2    Fa0           11 00:09:16         4    300     0    8

 

【RT2】

RT1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address    Interface    Hold Uptime    SRTT    RTO    Q    Seq
(sec)               (ms)             Cnt   Num
1   10.0.0.1   Fa1            11 00:14:23   1278     5000   0    2
0   10.0.1.2   Fa0            12 00:15:39     654     3924   0    4

 

【RT3】

RT1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address    Interface    Hold Uptime    SRTT    RTO    Q    Seq
(sec)               (ms)             Cnt   Num
0   10.0.1.1   Fa0/1         12 00:21:36         1     450     0    9

 

ルーティングテーブル確認

EIGRPのネイバー確認が終わったら、ルーティングテーブルが想定通りになっていることを確認しましょう。今回は、「RT3」のLoopbackアドレスを制御して、「RT1」では「10.1.2.1/32」は受信するが、「10.1.2.2/32」は受信しないようにしたいと思います。現時点では何も制御していないので、以下のようになっていると思います。

 

【RT1】

     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
D     10.1.2.1/32 [90/158720] via 10.0.0.2, 00:42:57, FastEthernet0
C     10.0.0.0/24 is directly connected, FastEthernet0
D     10.1.2.2/32 [90/158720] via 10.0.0.2, 00:42:57, FastEthernet0
C     10.1.1.1/32 is directly connected, Loopback0
D     10.0.1.0/24 [90/30720] via 10.0.0.2, 00:42:57, FastEthernet0

 

これから、「RT3」の設定変更を行って、「10.1.2.2」だけを受信しないように設定変更をしていきたいと思います。

 

ルーティング制御

 

アクセスリスト(ACL)

以下のように設定して「10.1.2.1」のルート配布は許可するが、「10.1.2.2」の通信は拒否するように設定しましょう。ただし、アクセスリストには『暗黙のdeny』というものがあり、最後に全て拒否となるようになっています。つまり、『access-list 1 deny 10.1.2.2』を書かなくても、『10.1.2.1』以外は全て拒否のなりますが、今回は授業のために明示的に『access-list 1 deny 10.1.2.2』を入れておきます。

 

access-list 1 permit 10.1.2.1
access-list 1 deny 10.1.2.2

 

 

 

ディストリビュートリスト

先程、設定したアクセスリストをEIGRPを動作しているインターフェイスに紐づけしていきましょう。今回は、「RT3」の「RT2」向けのインターフェイスであるFastEthernet0/1のアウト方向に設定してみたいと思います。

 

router eigrp 1
distribute-list 1 out FastEthernet0/1

 

 

 

ルーティング確認

それでは、ルーティングテーブルを確認していきましょう。想定では、「10.1.2.2」のルートだけがなくなっていることですね。ちゃんとそれ以外に影響がないことも確認しておきましょうね!

 

     10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D     10.1.2.1/32 [90/158720] via 10.0.0.2, 00:05:58, FastEthernet0
C     10.0.0.0/24 is directly connected, FastEthernet0
C     10.1.1.1/32 is directly connected, Loopback0
D     10.0.1.0/24 [90/30720] via 10.0.0.2, 00:58:28, FastEthernet0

 

 

まとめ

ベル

今回の授業は、いかがでしたか?ネットワークは「繋げる」ことだけでなく、「繋げない」ことも重要なことです。その方法は様々ですが、ルーティングの制御は、とても分かりやすい制御方法です。ルーティングテーブルを見れば一発ですからね!EIGRPに限らず、多くルーティングプロトコルで使用されることがあるので、しっかり覚えていきましょう。

Follow me!

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です