EIGRPの概要 ~設定編①~

ベル

今回の授業は、前回の授業で宣言させてもらった通り、『EIGRP(Enhanced Interior Gateway Routing Protocol)の設定』を教えていこうと思います。まずは基本的な設定となりますので、一緒に学んでいきましょう!まだ、概要編を読まれていない方は、概要編から勉強されることをオススメします。

EIGRPの概要 ~基礎編①~

 

 

検証前の準備

それでは基本的な設定を入れておきましょうね!まずは以下の構成に合わせて機器にコンソール接続して、インターフェイスにIPあどれすを設定してください。

 

 

 

コンソール接続を忘れてしまった方は、以前の授業を振り返ってみてくださいね!

Cisco機器にコンソール接続してみよう!

 

それでは実際に設定を投入していきましょう。以下のコマンドを見ないでも入れれるようになると素晴らしいですね!

 

【RT1】

RT1(config)#interface fastEthernet 0

RT1(config-if)#ip address 10.0.0.1 255.255.255.0

RT1(config-if)#no shutdown

!

RT1(config)#interface loopback 0

RT1(config-if)#ip address 10.1.1.1 255.255.255.255

 

 

【RT2】

RT2(config)#interface fastEthernet 0

RT2(config-if)#ip address 10.0.0.2 255.255.255.0

RT2(config-if)#no shutdown

!

RT2(config)#interface loopback 0

RT2(config-if)#ip address 10.1.2.1 255.255.255.0

 

 

EIGRPの設定

 

EGIRPの有効化

それではEIGRPの設定を入れていきましょう!まずはEIGRPの『AS(Autonomous System)』することでこのルータでEIGRPを使用するという宣言になります。

 

【RT1】

RT1(config)#router eigrp 1

 

【RT2】

RT2(config)#router eigrp 1

 

 

自動経路集約(auto-summary)の無効化

EIGRPでは、デフォルトで自動経路集約が有効になっていました。EIGRPでは、ルート数が多く経路計算に負荷がかかったりするため、経路の集約をすることがあります。特に昔の機器ではCPUやメモリが強くなかったため大規模なネットワークに耐えられない懸念からデフォルトで自動経路集約されていました。

 

しかし、今日のハードウェアは今日枯れてきており、最近のIOSではデフォルトで無効化されているので設定は不要です。ネットワークの構成変更をしていくうちにルーティングがわからなくなってしまうことがあるので、基本的には自動経路集約しない方がいいです。先程の『router eigrp 1』に続いて、以下のコマンドだけで無効化できます。

 

【RT1】

RT1(config-router)#no auto-summary

※RT2でも同じ設定ないので設定しておきましょうね!

 

 

 

EIGRPを動かすネットワークの設定

EIGRPの動作を宣言すれば、全てのネットワークで動作するわけではないんです。動作するネットワークを指定する必要があります。今回使用するセグメントは以下となっています。

 

 

インターフェイスのセグメントをそのままネットワークとして設定してもいいですし、まとめてネットワークを指定することも出来ます。今回は、インターフェイスのセグメントをそのまま指定してみます。これも先程の『router eigrp 1』の設定に続けて入力してくださいね。

 

【RT1】

RT1(config-router)#network 10.0.0.0 0.0.0.255

RT1(config-router)#network 10.1.1.1 0.0.0.0

 

 

【RT2】

RT2(config-router)#network 10.0.0.0 0.0.0.255

RT2(config-router)#network 10.1.2.1 0.0.0.0

 

ここで『あれ?』って思った方もいるかもしれません。サブネットが『255.255.255.0』となっているのに、設定では『0.0.0.255』で数字が逆転していることに気が付きました?これは『サブネットマスク』ではなく『ワイルドカードマスク』と言われるものです。一言で言えば、サブネットの値を2進数にしてひっくり返したような値になります。って急に言われてもわからないですよね?

正確にはサブネットマスクとは概念が違うので、ちゃんと知っておきたい方はこちらの授業を見てください。

サブネットマスクとワイルドカードマスク

 

これでルータ#1とルータ#2を接続するとネイバー関係が確立するはずです。それでは接続してみましょう!

 

EIGRPの確認コマンド

それでは、EIGRPの設定が問題なくできているかを『showコマンド』を使って確認していきましょう。

 

EIGRPのネイバー関係の確認

EIGRPを確認するために使用するコマンドはいくつかありますが、まずは『show ip eigrp neighbors』でネイバー関係が確立しているかを確認しましょう。ちゃんとネイバー関係が確立していれば以下のような結果になるはずです。

 

【RT1】

RT1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime  SRTT RTO  Q     Seq
(sec)            (ms)          Cnt  Num
0 10.0.0.2 Fa0        14 00:00:18  4       300  0     3

 

【RT2】

RT2#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(1)
H Address Interface Hold Uptime  SRTT  RTO  Q     Seq
(sec)            (ms)           Cnt  Num
0 10.0.0.1 Fa0        12 00:03:03  1278  5000 0     2

 

まず、隣接ルータのIPアドレスが表示されていることを確認してください。ルータ#1の『show ip eigrp neighbors』を見てみると『10.0.0.2』が表示されていますよね?これがルータ#2のIPアドレスであることが確認できればOKです。それ以外にも表示されている内容がありますが、ここでは割愛しておきます。ルータ#2でも同様に『10.0.0.1』が表示されていることが確認できればOKです。

 

 

EIGRPのトポロジーテーブル確認

ネイバーの確立が確認できたら、次はEIGRPのトポロジーテーブルを確認していきましょう。

 

【RT1】

RT1#show ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(10.1.1.1)

Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 10.1.2.0/24, 1 successors, FD is 156160
via 10.0.0.2 (156160/128256), FastEthernet0
P 10.0.0.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0
P 10.1.1.1/32, 1 successors, FD is 128256
via Connected, Loopback0

 

ここで確認できるのが『宛先ネットワークアドレス』『ネクストホップアドレス』『FD(フィージブルディスタンス)/AD(アドバタイズドディスタンス』『受信したインターフェス』などです。ここで想定通りのテーブルになっているかを確認しておきましょうね!ルータ#2でも同様な結果が見られます。

 

【RT2】

RT2#show ip eigrp topology
EIGRP-IPv4 Topology Table for AS(1)/ID(10.1.2.1)
Codes: P – Passive, A – Active, U – Update, Q – Query, R – Reply,
r – reply Status, s – sia Status

P 10.1.1.1/32, 1 successors, FD is 156160
via 10.0.0.1 (156160/128256), FastEthernet0
P 10.0.0.0/24, 1 successors, FD is 28160
via Connected, FastEthernet0
P 10.1.2.0/24, 1 successors, FD is 128256
via Connected, Loopback0

 

 

ルーティングテーブルの確認

それでは、最後にルーティングテーブルを確認してみましょう。ルータ#1ではルータ#2のLoopbackアドレスが、ルータ#2ではルータ#1のLoopbackアドレスがルーティングテーブルに『D』で載っていればOKですが、等コストバランシングや再配布などを使用している複雑なネットワークなどになると、確認が難しくなるのでしっかり内容を理解しておきましょうね。

 

【RT1】

RT1#show ip route

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

D 10.1.2.0/24 [90/156160] via 10.0.0.2, 00:39:30, FastEthernet0

C 10.0.0.0/24 is directly connected, FastEthernet0

C 10.1.1.1/32 is directly connected, Loopback0

 

【RT2】

RT2#show ip route

10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks

C 10.0.0.0/24 is directly connected, FastEthernet0

D 10.1.1.1/32 [90/156160] via 10.0.0.1, 00:40:06, FastEthernet0

C 10.1.2.0/24 is directly connected, Loopback0

 

 

まとめ

ベル

今回の授業は、『EIGRP設定編』の初回ということであまり複雑なことはしませんでした。ダイナミックルーティングの勉強となるといろんな機能があり複雑になってきます。次回以降では『ルートの再配布』『バランシング』『ルート制御』など、様々な機能を使っていきますのでゆっくりでいいので理解して進んでいくようにしましょう!

EIGRPの概要 ~設定編②~

 

ルーティングの授業

静的ルーティング(スタティックルート) ~基礎編①~

静的ルーティング(スタティックルート) ~設定編①~

EIGRPの概要 ~基礎編①~

EIGRPの概要 ~基礎編②~

EIGRPの概要 ~基礎編③~

EIGRPの概要 ~設定編①~

EIGRPの概要 ~設定編②~

OSPFの概要 ~基礎編①~

OSPFの概要 ~基礎編②~

OSPFの概要 ~基礎編③~

OSPFの概要 ~設定編①~

Follow me!

EIGRPの概要 ~設定編①~” に対して1件のコメントがあります。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です